Solved

Cannot connect to the Citrix metaframe server. There is no Citrix metaframe server configured on the specified address.

Posted on 2006-07-20
7
4,163 Views
Last Modified: 2008-06-30
I have setup a test Presentation Server 4.0 (running everything including IIS) on our network.  I am tiring to get the web interface to work.  I can connect and run it on the LAN and from home via our VPN (using the internal IP address of the server)
 
I have opened the following ports on my PIX 515e firewall: 80 and the citrix-ica - 1494 I think.
 
When I try to connect I am presented with a login box and can see the Citrix web interface server with my applications available.  However, when I try to launch the application, I get "Cannot connect to the Citrix metaframe server. There is no Citrix metaframe server configured on the specified address"
 
I am guessing that I need to set up the server to it understands the PIX and NAT (PAT) headers from the outside interface.  I have found in the presentation server admin under the web interface under the secure client admin I can access routes where I put the external (live internet) address with a mask of 255.255.255.255 for both translated and alternate.  Under firewall translations I have put the internal and external addresses with port 80.  And nothing under secure gateway.
 
I am guessing this is a simple question for someone who knows Citrix.  I have not seen Citrix for over 6+ years so I am a noob.
 
Thanks in advance for any help!
0
Comment
Question by:e_vanheel
  • 3
  • 3
7 Comments
 
LVL 18

Expert Comment

by:mgcIT
ID: 17149324
1. have you given the server an external IP Address using the altaddr command?  for example run altaddr /set xx.xx.xx.xxx on the citrix server

2. yes you need to configure these address translations for your web interface using the Access Suite Console.  Also under DMZ Settings you need to create a rule for external connections by enabling the Alternate connections.  You should probably make this the default connection and then create specific rules for the Direct (internal) connections.
0
 
LVL 6

Author Comment

by:e_vanheel
ID: 17149449
I ran the altaddr command.

Like I said, I am new at this so please confirm.

I have edited the DMZ settings so I have:
     Client IP address: Default
     Access Method: Alternate

Next line
    Client IP address: 192.168.1.4 - the internal address
    Subnet: 255.255.248.0
    Access Method: Direct


Under Access Routes:
Default - Direct
x.x.x.x - external IP 255.255.255.255 Translated (should this be all 255's or the actual subnet mask)? Do I need this translated?
x.x.x.x - external IP 255.255.255.255 Alternate
0
 
LVL 18

Expert Comment

by:mgcIT
ID: 17150579
You won't need the translated addresses but will need the Alternate.

As a test to see if the problem is with your citrix config, or your network do this:

Log into the web interface and rather than launching an application right-click on it and choose 'Save Target As...'.
Save this file (launch.ica) and open it with notepad.  Inside the file there will be a line that says:
Address= xxxxxxx

When connecting from the outside you should see your external IP there.  And vice versa when connecting from the internal LAN or VPN.
0
How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

 
LVL 6

Author Comment

by:e_vanheel
ID: 17150920
I still see the internal address.  If I change the files address and save it --- it works!!!

What do I need to change on the application or server to make it work from the icon?

getting closer....thanks!
0
 
LVL 18

Accepted Solution

by:
mgcIT earned 500 total points
ID: 17151060
ok good.. Then your network/router/firewall are all configured correctly.  so let's do this first:

1. Open the Access Suite Console
2. Click Manage Secure Client Access > Edit DMZ Settings
3. Make sure the Default is set to "Alternate"
4. Delete any other rules you have there (for now).
5. Click Manage Secure Client Access > Edit Address Translations
6. Add a rule (select "Both") for the internal IP of your Citrix server (port 1494) and the external IP of your Citrix server (port 1494 also).
7. Close the ASC and run IISRESET to restart IIS... then test again.  Check the IP Address in the launch.ica file to verify.
0
 
LVL 6

Author Comment

by:e_vanheel
ID: 17151241
Great Job!

Thanks!
0
 
LVL 1

Expert Comment

by:CorpTechLLC
ID: 21904645
perfect! I have been thinking it was my firewall and was frustrated. Thanks for the great info!
0

Featured Post

Enabling OSINT in Activity Based Intelligence

Activity based intelligence (ABI) requires access to all available sources of data. Recorded Future allows analysts to observe structured data on the open, deep, and dark web.

Join & Write a Comment

Citrix XenDesktop, Citrix Studio, Citrix Policies, Citrix XenApp
ADCs have gained traction within the last decade, largely due to increased demand for legacy load balancing appliances to handle more advanced application delivery requirements and improve application performance.
How to install and configure Citrix XenApp 6.5 - Part 1. In this video tutorial we have explained step by step installation of Citrix XenApp 6.5 Server on Windows Server 2008 R2 is explained in this video. We have explained the difference between…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.

705 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

20 Experts available now in Live!

Get 1:1 Help Now