Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 352
  • Last Modified:

ssh from office to home windows to linux

I fairly new to linux so I am not sure where to start.

I have a laptop running windows xp and I want to be able to ssh using putty to a linux machine that I have at home which is attached to a WRT54G linksys router

My linux box has a static ip address 192.168.1.110  
My router is 192.168.1.1

When I run ipconfig/all from my laptop when I am at home attached to wireless router I get the following. I can ssh from laptop to linux when I am at home no problem.
Where do I start?
Thanks in advance.

C:\Documents and Settings\plinnane>ipconfig/all

Windows IP Configuration

        Host Name . . . . . . . . . . . . : plinnane-us
        Primary Dns Suffix  . . . . . . . : us.dell.com
        Node Type . . . . . . . . . . . . : Hybrid
        IP Routing Enabled. . . . . . . . : No
        WINS Proxy Enabled. . . . . . . . : No
        DNS Suffix Search List. . . . . . : us.dell.com
                                            austin.rr.com
                                            dell.com

Ethernet adapter Local Area Connection:

        Connection-specific DNS Suffix  . : austin.rr.com
        Description . . . . . . . . . . . : Broadcom NetXtreme 57xx Gigabit Controll
        Physical Address. . . . . . . . . : 00-15-C5-0A-D5-85
        Dhcp Enabled. . . . . . . . . . . : Yes
        Autoconfiguration Enabled . . . . : Yes
        IP Address. . . . . . . . . . . . : 192.168.1.100
        Subnet Mask . . . . . . . . . . . : 255.255.255.0
        IP Address. . . . . . . . . . . . : fe80::215:c5ff:fe0a:d585%20
        Default Gateway . . . . . . . . . : 192.168.1.1
        DHCP Server . . . . . . . . . . . : 192.168.1.1
        DNS Servers . . . . . . . . . . . : 24.93.41.125
                                            24.93.41.126
                                            fec0:0:0:ffff::1%4
                                            fec0:0:0:ffff::2%4
                                            fec0:0:0:ffff::3%4
        Lease Obtained. . . . . . . . . . : Wednesday, July 19, 2006 9:04:23 PM
        Lease Expires . . . . . . . . . . : Thursday, July 20, 2006 9:04:23 PM

Tunnel adapter Teredo Tunneling Pseudo-Interface:

        Connection-specific DNS Suffix  . :
        Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
        Physical Address. . . . . . . . . : FF-FF-FF-FF-FF-FF-FF-FF
        Dhcp Enabled. . . . . . . . . . . : No
        IP Address. . . . . . . . . . . . : fe80::5445:5245:444f%5
        Default Gateway . . . . . . . . . :
        NetBIOS over Tcpip. . . . . . . . : Disabled

Tunnel adapter Automatic Tunneling Pseudo-Interface:

        Connection-specific DNS Suffix  . : austin.rr.com
        Description . . . . . . . . . . . : Automatic Tunneling Pseudo-Interface
        Physical Address. . . . . . . . . : C0-A8-01-64
        Dhcp Enabled. . . . . . . . . . . : No
        IP Address. . . . . . . . . . . . : fe80::5efe:192.168.1.100%2
        Default Gateway . . . . . . . . . :
        DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%4
                                            fec0:0:0:ffff::2%4
                                            fec0:0:0:ffff::3%4
        NetBIOS over Tcpip. . . . . . . . : Disabled

0
dplinnane
Asked:
dplinnane
  • 6
  • 5
  • 3
2 Solutions
 
DbergertCommented:
you need to configure port forwarding on your router to expose ssh to the interent and point it at the ip our your linux box...
0
 
Cyclops3590Commented:
but you should have the wrt54g do a port translation for you.

for example, ssh uses port 22.  Everyone knows that and thus scans for it.  Have your router expose say port 2022 and in the port forwarding tell it that the public port 2022 goes to your linux box on port 22.

This will help cut down on the number of people scanning your ssh port tremendously
0
 
dplinnaneAuthor Commented:
How do I set up port forwarding?
I still need to ssh to an ip address where do I get that?
If I ssh to the ipaddress of my internet connection eg 168.192.2.66  but I have two linux machines with static ip addresses how can I ssh to one over the other. I gus I need to figure out port forwarding first.
0
Nothing ever in the clear!

This technical paper will help you implement VMware’s VM encryption as well as implement Veeam encryption which together will achieve the nothing ever in the clear goal. If a bad guy steals VMs, backups or traffic they get nothing.

 
dplinnaneAuthor Commented:
0
 
DbergertCommented:
funny looks like you are on the right path :)
0
 
Cyclops3590Commented:
that's no problem
I did the same thig
forward one port 2022 to machine A, then say 3022 to your machine B

then wen you ssh to your machines you do this
ssh to 168.192.2.66 port 2022 for A
ssh to 168.192.2.66 port 3022 for B

I switched my wrt54g out a while ago so I don't totally remember the menus, but you should find a port forwarding section, it then says what port to forward to what internal IP and what port for that internal IP
0
 
dplinnaneAuthor Commented:
My linksys router only allows me to port forward addresses of the format 192.168.1. XXX one of my ip's is 192.168.2.xxx anyway around this. IS there anyway of testing this locally instead of waiting until tomorrow when I go into the office.  
0
 
Cyclops3590Commented:
doubt it, but the wrt54g does have the capability to allow remote mgmt.  now you shouldn't normally turn this on, but temporarily I would think is ok.  this way you can test it at work and if it doesn't work, you can at least log in and change some.  when you're satisfied turn the remote mgmt off.

as for the diff. ip I'd have to say no.  Why do you have a 192.168.2.x inside anyway out of curiousity
0
 
dplinnaneAuthor Commented:
I'm using 192.168.2.x just following instructions. I can overcome it by ssh from linux1 machine to linux2 machine.


I tried from work and got a connection error connection refused. I followed the instructions for port forwarding.. Not sure what could be wrong.
0
 
Cyclops3590Commented:
is there a firewall on your server that might be rejecting the connections, also, you sure you forwarded to the correct port and and referencing the public port?
0
 
dplinnaneAuthor Commented:
No firewall at least I have not setup a firewall.  I used port 2022.
0
 
Cyclops3590Commented:
and forwarded it to port 22 on the server correct?
then you tried to connect to 2022 for the public ip correct?
0
 
dplinnaneAuthor Commented:
I'll send a link to my settings later when I get home, I can't remember.
0

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 6
  • 5
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now