?
Solved

InRepeatedGroupHeader

Posted on 2006-07-20
10
Medium Priority
?
1,922 Views
Last Modified: 2012-06-27
I have multiple groups in my Crystal Report.  I suppressed them so that you can only see them if you drill down into them.  I want to be able to see the page headers in the additional suppressed groups.  I found the topic InRepeatedGroupHeader but couldn't figure out how to do it.  So for example:


First Page
                                                              Total Units Sold                            Total Revenue
Accessories                                                    25                                              6000



When you drill down you see

Clock                                                             15                                                3000
Picture                                                           10                                                3000

The problem is that on the drill down you can't see the headers from the first page.

Thanks
0
Comment
Question by:skielark
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
  • 3
10 Comments
 
LVL 17

Expert Comment

by:MIKE
ID: 17150736
Can't you just move the Headings into the PAGE HEADER...  it appears that they are in the GROUP HEADER???

MikeV
0
 

Author Comment

by:skielark
ID: 17150747
They are the the page header as I stated above but they do not repeat in the drill down pages.
0
 
LVL 17

Expert Comment

by:MIKE
ID: 17150813
INREPEATGROUPHEADER is used to repeat the group header when the GROUP is continued on the next page. Not the page header

0
Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
LVL 17

Expert Comment

by:MIKE
ID: 17150825
So just to clarify..you want the PAGE HEADER...to repeat?

Not the REPORT HEADER...and not the GROUP HEADER, correct?

What do you have in the page header that is displaying please?

MikeV
0
 
LVL 28

Expert Comment

by:bdreed35
ID: 17150845
Under the File menu, click on Report Options.
Set the property "Show All Headers on Drill Down"
0
 

Author Comment

by:skielark
ID: 17150980
Total Units Sold                            Total Revenue

I want to see the field headers that are displayed on the first page of my report.  When I drill down into the group summary sections I can't see the field headers.  I don't want to add field headers in the group summary because it lists them mutiple times within the summary.  I simply want the Page Headers to repeat on the drilled down summary pages.  Example below:


                     Total Units Sold        Total Revenue
4578                       56                      78
                     Total Units Sold        Total Revenue
4579                       79                     108  

Here is what I want to see:

                     Total Units Sold        Total Revenue
4578                       56                      78
4579                       79                     108  
0
 
LVL 28

Expert Comment

by:bdreed35
ID: 17150987
Try setting the property I posted in my previous post.
0
 

Author Comment

by:skielark
ID: 17150999
If you are referring to INREPEATGROUPHEADER, that is not what I want to use because I am not using group headers because I don't want to see this:

                     Total Units Sold        Total Revenue
4578                       56                      78
                     Total Units Sold        Total Revenue
4579                       79                     108  

Is there any way that I can display the group header only once and not for every record?
0
 
LVL 28

Accepted Solution

by:
bdreed35 earned 2000 total points
ID: 17151015
2 different people have posted replies for you, so please only look at mine for a minute and try this:  

Under the File menu, click on Report Options.
Set the property "Show All Headers on Drill Down"
0
 

Author Comment

by:skielark
ID: 17151028
Ok bdreed35 that is exactly what I needed.  Thanks so much for you help.  I spent an hour trying to figure it out.  
0

Featured Post

On Demand Webinar - Networking for the Cloud Era

This webinar discusses:
-Common barriers companies experience when moving to the cloud
-How SD-WAN changes the way we look at networks
-Best practices customers should employ moving forward with cloud migration
-What happens behind the scenes of SteelConnect’s one-click button

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Crystal Reports: 5 Tests for Top Performance It is complete, your masterpiece report.  Not only does it meet your customer’s expectations, it blows them out the water, all they want is beautifully summarised and displayed in a myriad of ways. …
Hot fix for .Net Crystal Reports 10.2.3600.0 to fix problems with sub reports running on 64 bit operating systems ISSUE: Reports which contain subreports fail with error "Missing Parameter Value" DEPLOYMENT SERVER OS: Windows 2008 with 64 bi…
Monitoring a network: how to monitor network services and why? Michael Kulchisky, MCSE, MCSA, MCP, VTSP, VSP, CCSP outlines the philosophy behind service monitoring and why a handshake validation is critical in network monitoring. Software utilized …
Visualize your data even better in Access queries. Given a date and a value, this lesson shows how to compare that value with the previous value, calculate the difference, and display a circle if the value is the same, an up triangle if it increased…
Suggested Courses
Course of the Month15 days, 2 hours left to enroll

771 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question