Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1083
  • Last Modified:

Sonic Wall client won't connect

I have the latest Sonic Wall client 3.1.0 running on a Laptop with XP Home. If i connect through my router (linksys) it connects but asks me to enter my username and password every 2 minutes. if i remove the linksys and plug straight to the dsl modem the connection just says it is trying to connect but never does and my error log in te connection client says   -The peer is not responding to phase 1 ISAKMP requests?

Need help!!
0
tkthelpdesk
Asked:
tkthelpdesk
  • 2
1 Solution
 
jakosysadminCommented:
so. just to be on the safe side: you remove the linksys and do pull up the pppoe connection on your 'puter BEFORE you try to connect with your Sonic Wall client?
if you do, it could be the issue of fragmented packets and MTU. If not, well.. you just have to.
0
 
tkthelpdeskAuthor Commented:
ok how do i fix if this is the case???
0
 
jakosysadminCommented:
in case of the Linksys router, it probably feeds your machine a sufficiently small MTU through the means of DHCP. You would need to copy that MTU and set it manually when you launch the pppoe directly.
be aware that setting a lower MTU would mean a bigger protocol header overhead comparing to the bigger MTU. Therefore, some of the protocols favouring big payloads in packets will get a performance hit.
0
 
PowerITCommented:
I have seen this happen to a Sonicwall VPN client when the MTU is to LOW, certainly not to high.
The initial negotiation then fails because the firewall can't handle the fragmentation.

So, try to increase the MTU:
In case of a PPPOE connection (PC authenticating, not the modem):
In XP: open regedit and go to the key:
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NdisWan\Parameters\Protocols\0]
Add a DWORD value named MTU and give it the value '5aa' in hex or 1450 in decimal.
If the MTU value already exist, just change to the above value.
Then in the VPN Client: delete the existing connection and create it anew.

In case of  LAN connection (modem or router authenticating, like with your linksys):
In XP: open regedit and go to the key:
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{Select Interface Nummer}]
The interface number can easily be found by looking at all of them till you find the one with the matching IP-address.
The IP-adress itself can be found by running ipconfig in a command window and looking for your LAN-card.
When you have found the correct interface number, add a DWORD value named MTU and give it the value '5aa' in hex or 1450 in decimal.
If the MTU value already exist, just change to the above value.
Then reboot.

Let me know if this helped you.

J.
0

Featured Post

Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now