Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

tenacious "delayed write failed" error - ONLY when acronis imaging to usb drive (many fixes tried)

Posted on 2006-07-20
3
Medium Priority
?
2,908 Views
Last Modified: 2016-10-27
Where to begin. There are thousands and thousands of webpages on this error. Most trumpeting a solution, Half of them totally contradicting the other half. ("Change VM to programs" "Change VM to System Cache" "convert to NTFS" "Convert to Fat32" "turn on bios udma" "turn off bios udma" "turn off write caching on destination drive" "turn off write caching on source drive"

I've spent tons of time on this issue. Brain fried. Uninstalled lots of recent software, causing new issues. Still getting teh error.

What I'd like your help is --

WHICH of the untried fixes (see below) for this issue can I ignore, and which should I continue pursuing (which I haven't already) - -based on my particulars?  If you can whittle it down, and I fix it, I'll be eternally grateful (if I don't have a stroke first).


Main "particular" is -- THE HARDWARE HAS NOT CHANGED AT ALL, and I have been using acronis on this same PC to back up images to these same USB drives for over a years. So something fucked up the OS? Muswt be!  


SPECS:
Windows XP Home, SP2 (WINDOWS IS COMPLETELY UPDATED), Dell Dimension 8200, 2ghz P4, 1.5gb ram, Acronis True Image 8, "Maxtor Personal Storage 3100" external USB2 hard drive (among others).  "Ali PCI to USB Open Host Controller" / "Intel 82801BA/BAM USB Universal Host Controller"

PROBLEM:
My actual acronis error is:
Acronis Error:
E00070004: Failed to write data to the image archive file. A possible reason might be poor media quality.

Windows XP Home also gives an error --
Windows - Delayed Write Failed
Windows was unable to save all the data for the file M:\$Mft. The data has been lost.


and then sometimes:
The Unknown USB Device is a Hi-Speed USB Device and will function at reduced speed when plugged into a non-Hi Speed port.



CONTEXT:
The following issue is happening ONLY on my Hard Drives that are in USB enclosures, NOT on my other (internal EIDE PATA) drives.

Also, the following issue so far happens when I try to create ACRONIS hard drive disk image backups ONTO the USB drives. I can create ACRONIS files on my EIDE hard drives fine.  HOwever, after the error, the USB drive is STILL VISIBLE, and I can copy SOME Files to the usb HD.  

At one point, after getting the error, I tried manually copying large files (700mb - 4gb) from my internal drives to the USB drives, using windows explorer, I got the "Delayed Write Failed" error again -- AND the USB hd disappeared from explorer.  But since then (dunno why), I am able to copy 10gb plus files OK, manyually. SO FAR!.

NOTE -- in the past, with exactly the same hardware, I was able to do the above Acronis imaging to USB hard drives fine.  No hardware changes have occured since the last time it worked.  Only thing that's changed has been software installation. TRied to get rid of all recent stuff. (see below).

FIXES ATTEMPTED SO FAR:

I tried different cables, and two different external USB drives (EIDE PATA drives in USB2 to IDE enclosures), no diff.

-- Uninstalled recent stuff:
blindwrite.  (VSO device now gone from device mgr)
gspot
Nvidia drivers
quickbooks pro
quicktime
winavivideoconverter
workspace macro pro
AGEIA PhysX driver (came with Graw)

(note above removal of blindwrite, one of the recommended fixes)
(note -  I also installed GRAW,the game, but havent' uninstalled it yet. seems irrelevant)

-- emptied recycle bin
-- write caching already disabled
-- 'LargeSystemCache' in registry already at 0
-- updated windows - installed MS .Net Framework 1.1 service pack 1
-- explorer's "check disk" program says both usb drives are fine. (BUT not e-- if I run them with the "fix" option, it freezes

-- Scrolling issue appeared in windows (see other post by me)

-- updated windows - auto security update for prev update
-- changed all usb cables, all new.

-- successfully copied 9 GB file using TC, from internal D drive to one usb drive. Before it failed. But
Acronis still failing to both usb drives.

-- DISABLED indexing service (undo later)
-- changed virtual memory from "programs" to "system cache" pref
-- BIOS -- changed IDE Drive UDMA to "On"
-- Disabled write caching on ALL hd's, even internals
-- changed vm back to programs (from system cache)

-- added page file to both USB drives (200-400) (stupid?) there's no OS on them
as microsoft suggests, changed HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management, System Pages from c3000 to 0xFFFFFFFF

-- BIOS - turned IDE DRIVE UDMA back off

-- TRied diff sizes in Acronis (tib files, vary from auto to 4gb to 700mb)

NO DIFF YET.


Other Weirdness:
-- Acronis stalls when beginning to back up to a second USB hd, won't go past 0%
-- checkdisk (run from xp) says both usb drives are FINE, but if i run checkdisk wtih the FIX / Repair swithes, it hangs. (phase 4)
-- Windows no longer opens an expolorer page to announce turning on / plugging in of usb drives
-- It's very hot here now

Other Things to try:
-- try another PCI card
-- try usb1 = only connection
-- replace graphics card?

other fixes from internet not tried, because it looks irrelevant:
-- MS hotfix for this issue -- they said it was only if Event Viewer had "event ID 50 with a source of MrxSMB" -- my source was different! also different status code
--disable firewall -- irrelevant - file transfer begins, then fails
-- "anydvd" was never insatlled
-- got rid of extra hubs/connections
-- ATI / VIA related stuff. I don't have VIA (intel board), and uninstalleed nvidia. Never had ati.
-- no room because of recycle bin. Already tried emptying.
-- upgrade windows - done
-- search in your Registry for " noide " (not found)
-- wrong ata cable (40 wire vs 80) - Nope, 80 wire cable, and besides, never changed!
-- BAD GRAPHICS CARD... (sounds like red herring -- never changed)
-- master file table (?) Not sure what this was
-- disable usb printing support  (sounds like red herring -- never changed)
-- NTFS not FAT32 / FAT32 not NTFS (!)  People cannot seem to make up their minds minds which file system is the "final fix for the problem". Mine are NTFS all around.



0
Comment
Question by:dgrrr
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
3 Comments
 
LVL 28

Expert Comment

by:burrcm
ID: 17153403
You used a word which will cause your question to be ignored. Delete this question. start again, and be polite.
0
 

Author Comment

by:dgrrr
ID: 17264957
I think I found the answer.

It was my USB2 pci card.  

I put in a new one. Now transfers done using the ports on the old one still fail - -but on all other USB ports they succeed.
0
 
LVL 1

Accepted Solution

by:
GhostMod earned 0 total points
ID: 17337283
Closed, 500 points refunded.

GhostMod
Community Support Moderator
0

Featured Post

Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

The recent Petya-like ransomware attack served a big blow to hundreds of banks, corporations and government offices The Acronis blog takes a closer look at this damaging worm to see what’s behind it – and offers up tips on how you can safeguard your…
Learn how to use the free Acronis True Image app to easily transfer data between iPhones and Android phones.
Two types of users will appreciate AOMEI Backupper Pro: 1 - Those with PCIe drives (and haven't found cloning software that works on them). 2 - Those who want a fast clone of their boot drive (no re-boots needed) and it can clone your drive wh…
Have you created a query with information for a calendar? ... and then, abra-cadabra, the calendar is done?! I am going to show you how to make that happen. Visualize your data!  ... really see it To use the code to create a calendar from a q…
Suggested Courses

618 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question