Solved

Screen Resolution

Posted on 2006-07-21
12
433 Views
Last Modified: 2013-12-06
I have installed Linux Redhat Enterpeise ES version 3 on a Dell Poweredge 2850. I am running the Gnome desktop.  When the resolution is set to 640 x 480 the icons are huge.  When I change the resolution to 1024 x 768 the dsiplay does not fit the screen.  It's like the screen goes beyond the edge of the display and I have to move the mouse to see from one side to the other.

I have the correct video card selected  ATI Radeon 7000 series and a Dell M781p monitor.

I need to get this system up and running very quickly.

Any help would be appreicated
0
Comment
Question by:carric01
  • 5
  • 3
  • 2
  • +1
12 Comments
 
LVL 6

Expert Comment

by:wirthr
ID: 17154612
please post the contents of the file located at /etc/X11/XF86Config
0
 

Author Comment

by:carric01
ID: 17154904
# XFree86 4 configuration created by redhat-config-xfree86

Section "ServerLayout"
      Identifier     "Default Layout"
      Screen      0  "Screen0" 0 0
      InputDevice    "Mouse0" "CorePointer"
      InputDevice    "Keyboard0" "CoreKeyboard"
      InputDevice    "DevInputMice" "AlwaysCore"
EndSection

Section "Files"

# RgbPath is the location of the RGB database.  Note, this is the name of the
# file minus the extension (like ".txt" or ".db").  There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
      RgbPath      "/usr/X11R6/lib/X11/rgb"
      FontPath     "unix/:7100"
EndSection

Section "Module"
      Load  "dbe"
      Load  "extmod"
      Load  "fbdevhw"
      Load  "glx"
      Load  "record"
      Load  "freetype"
      Load  "type1"
EndSection

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
#      Option      "Xleds"            "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
#      Option      "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults).  For example, for a non-U.S.
# keyboard, you will probably want to use:
#      Option      "XkbModel"      "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
#      Option      "XkbModel"      "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
#      Option      "XkbLayout"      "de"
# or:
#      Option      "XkbLayout"      "de"
#      Option      "XkbVariant"      "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
#      Option      "XkbOptions"      "ctrl:swapcaps"
# Or if you just want both to be control, use:
#      Option      "XkbOptions"      "ctrl:nocaps"
#
      Identifier  "Keyboard0"
      Driver      "keyboard"
      Option          "XkbRules" "xfree86"
      Option          "XkbModel" "pc105"
      Option          "XkbLayout" "us"
EndSection

Section "InputDevice"
      Identifier  "Mouse0"
      Driver      "mouse"
      Option          "Protocol" "PS/2"
      Option          "Device" "/dev/psaux"
      Option          "ZAxisMapping" "4 5"
      Option          "Emulate3Buttons" "no"
EndSection

Section "InputDevice"

# If the normal CorePointer mouse is not a USB mouse then
# this input device can be used in AlwaysCore mode to let you
# also use USB mice at the same time.
      Identifier  "DevInputMice"
      Driver      "mouse"
      Option          "Protocol" "IMPS/2"
      Option          "Device" "/dev/input/mice"
      Option          "ZAxisMapping" "4 5"
      Option          "Emulate3Buttons" "no"
EndSection

Section "Monitor"
      Identifier   "Monitor0"
      VendorName   "Monitor Vendor"
      ModelName    "Dell M781p"
      DisplaySize  381      330
      HorizSync    30.0 - 85.0
      VertRefresh  50.0 - 160.0
      Option          "dpms"
EndSection

Section "Device"
      Identifier  "Videocard0"
      Driver      "ati"
      VendorName  "Videocard vendor"
      BoardName   "ATI Radeon 7000"
EndSection

Section "Screen"
      Identifier "Screen0"
      Device     "Videocard0"
      Monitor    "Monitor0"
      DefaultDepth     16
      SubSection "Display"
            Depth     16
            Modes    "1024x768" "800x600" "640x480"
      EndSubSection
EndSection

Section "DRI"
      Group        0
      Mode         0666
EndSection

0
 
LVL 6

Assisted Solution

by:wirthr
wirthr earned 167 total points
ID: 17155213
While I am looking at this, have you called dell?  They officially support ES3.
0
 

Author Comment

by:carric01
ID: 17155338
No I have not contacted Dell.  I have not had good experiences with their phone support.
0
 
LVL 16

Expert Comment

by:xDamox
ID: 17155435
Hi,

As root type this:

system-config-display

This will allow you to configure your display.
0
 

Author Comment

by:carric01
ID: 17155515
Doesn't work
Get the following response

 -bash: system-config-display: command not found
0
Why You Should Analyze Threat Actor TTPs

After years of analyzing threat actor behavior, it’s become clear that at any given time there are specific tactics, techniques, and procedures (TTPs) that are particularly prevalent. By analyzing and understanding these TTPs, you can dramatically enhance your security program.

 
LVL 16

Assisted Solution

by:xDamox
xDamox earned 166 total points
ID: 17155630
Hi,

Try:

redhat-config-display
0
 
LVL 22

Expert Comment

by:pjedmond
ID: 17155849
I think:

redhat-config-xfree86

is what you are after?

/usr/bin/redhat-config-xfree86

if the path isn't set. You will need to do this as root.

(   (()
(`-' _\
 ''  ''

0
 

Author Comment

by:carric01
ID: 17156286
That command brings up the Gui to allow me t change the settings.  I can access the gui no problem.  The problem which is difficult to explain, is that when I change the resolution the output does not fit the screen, it is to big which requires me to like schroll from one side of the desktop to the other.
0
 
LVL 22

Accepted Solution

by:
pjedmond earned 167 total points
ID: 17156718
http://www.xfree86.org/4.3.0/XF86Config.5.html

Gives details of the meanings of the directives. First idea is to delete the DisplaySize entry for your monitor.

If that doesn't work, then I'd be tempted to boot into single user mode or run level 3, and:

mv /etc/X11/XF86Config /etc/X11/XF86Configbu

and then run:

/usr/X11R6/bin/xf86config

or use

Xconfigurator

(   (()
(`-' _\
 ''  ''
 
0
 

Author Comment

by:carric01
ID: 17156894
The issue has been resolved.  I installed the latest updates for the X86Free and the latest driver for the ATI Radeon.  One of those fixed the issue.  Thanks for all the responses
0
 
LVL 6

Expert Comment

by:wirthr
ID: 17156905
glad it's fixed, I was going to say you should upgrade to xorg...
0

Featured Post

6 Surprising Benefits of Threat Intelligence

All sorts of threat intelligence is available on the web. Intelligence you can learn from, and use to anticipate and prepare for future attacks.

Join & Write a Comment

Suggested Solutions

Introduction We as admins face situation where we need to redirect websites to another. This may be required as a part of an upgrade keeping the old URL but website should be served from new URL. This document would brief you on different ways ca…
The purpose of this article is to show how we can create Linux Mint virtual machine using Oracle Virtual Box. To install Linux Mint we have to download the ISO file from its website i.e. http://www.linuxmint.com. Once you open the link you will see …
Connecting to an Amazon Linux EC2 Instance from Windows Using PuTTY.
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

757 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

21 Experts available now in Live!

Get 1:1 Help Now