• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1011
  • Last Modified:

tape drive not found linux using TAPEWARE

here is my dmesg

dmesg |grep -i TAPE
hdd: Seagate STT8000A, ATAPI TAPE drive

 
The job Backup All Machines has been terminated:                     │   │

│   │    Error 88 : No devices specified or all devices are now offline    │   │
│
│   │ There are no devices that can possibly meet the requirements for     │   │
│   │ the job to complete. If any devices were specified, they are         │   │
│   │ marked as 'dead' due to communication failure, device failure,       │gs │
│


i tried setting preferences of /dev/st0
/dev/hdd
/dev/rm0
/dev/tape

please help exactly what is needed to get my tape drive in tapeware or TAR for that matter to be detected.
0
aot2002
Asked:
aot2002
  • 4
  • 3
  • 3
1 Solution
 
pjedmondCommented:
Normally for this type of drive you need the ftape module:

http://www.tldp.org/FAQ/Ftape-FAQ-2.html

Check that it is installed:

lsmod

If so, check that the result of

ls -al /dev/tape

points to something like:

/dev/nqft0

ftape is now considered to be a bit outdated, and may atapi tape drives were never supported due to using their own proprietary protocol, so it may be that you never get this tape drive running under Linux:(

Another option to using ftape, is to use an ide-scsi module to enable access via the scsi interface. Here for more details:

http://www.linux.com/howtos/SCSI-2.4-HOWTO/st.shtml

"ATAPI tape drives can be controlled by this driver with help from the ide-scsi pseudo adapter driver. The discussion in Section 9.2.4 also applies for ATAPI tape drives (and ATAPI floppies)."

(   (()
(`-' _\
 ''  ''
0
 
pjedmondCommented:
As an aside:

dmesg | more

and check whether is does get allocated to a specific device such as /dev/nqft0 or similar. If you print out the whole block around that message, along with the output of lsmod, then we should be able to help you further.

(   (()
(`-' _\
 ''  ''
0
 
aot2002Author Commented:
lsmod
Module                  Size  Used by
lp                     12077  0
md5                     4033  1
ipv6                  234881  10
autofs4                23237  0
sunrpc                159269  1
ipt_REJECT              6593  1
ipt_state               1857  4
ip_conntrack           40565  1 ipt_state
iptable_filter          2753  1
ip_tables              16705  3 ipt_REJECT,ipt_state,iptable_filter
button                  6481  0
battery                 8901  0
ac                      4805  0
uhci_hcd               31065  0
parport_pc             24577  0
parport                37129  2 lp,parport_pc
8139too                25921  0
mii                     4673  1 8139too
dm_snapshot            16901  0
dm_zero                 2369  0
dm_mirror              27824  0
ext3                  116809  2
jbd                    71385  1 ext3
dm_mod                 56661  6 dm_snapshot,dm_zero,dm_mirror






Probing IDE interface ide0...
Probing IDE interface ide1...
hdd: Seagate STT8000A, ATAPI TAPE drive
Using cfq io scheduler
ide1 at 0x170-0x177,0x376 on irq 15
PDC20270: IDE controller at PCI slot 0000:00:0c.0
ACPI: PCI interrupt 0000:00:0c.0[A] -> GSI 11 (level, low) -> IRQ 11
PDC20270: chipset revision 2
PDC20270: ROM enabled at 0xdffe0000
PDC20270: 100% native mode on irq 11
    ide2: BM-DMA at 0xcc00-0xcc07, BIOS settings: hde:pio, hdf:pio
    ide3: BM-DMA at 0xcc08-0xcc0f, BIOS settings: hdg:pio, hdh:pio
Probing IDE interface ide2...
hde: ST340810A, ATA DISK drive
ide2 at 0xdc00-0xdc07,0xd802 on irq 11
Probing IDE interface ide3...
hdh: Maxtor 6Y060L0, ATA DISK drive
ide3 at 0xd400-0xd407,0xd002 on irq 11
Probing IDE interface ide0...
Probing IDE interface ide4...
Probing IDE interface ide5...



0
Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
aot2002Author Commented:
ls -al /dev/tape
ls: /dev/tape: No such file or directory
0
 
btomkinsCommented:
hi,
I have used the travan backup drives with tapeware and linux before but and have found that these problems are usually something to do with the ide-scsi module.

Although I feel I should warn you that travan is a very troublesome solution (in my experience) and now with the price of dat solutions down to similar prices, I sugeest that you check them out. Tapeware on the otherhand is excellent.  

If you have your heart set on the STT8000A then you might try these two solutions, I found in google. In the past I think I added both insmod ide-scsi and modprobe ide-scsi to the /etc/rc.d/rc.local reboot the machine and when tapeware started it could see the device. Its been a while so I can't remember.
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Solution 1

Tapeware uses a module called IDE-SCSI to enable IDE tape drive support.

 1.            Type: insmod ide-scsi. This is to add the module
 2.            Edit the file /etc/rc.d/rc.local and remove the line: modprobe ide-scsi
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Solution 2

Depending what linux you are using you might alternativly try:
When TapeWare runs as a service and it cannot detect a drive, be sure that the ide-scsi module is loaded before the service starts. So load this module at startup or change the modules.conf file in /etc so that whenever the sg module is loaded the ide-scsi module is loaded too.

An example of this might be :

in section "options" in the modules.conf file add this line :

pre-install sg /sbin/modprobe ide-scsi;
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

My best Travan advice : keep your tapes and drive completely dust free and clean the drive fanaticaly.

Good Luck
Brian
0
 
pjedmondCommented:
Well - it recognises your tape drive successfully. Try btomkins' ideas, beyong that I agree that you are better off getting a DAT drive.

(   (()
(`-' _\
 ''  ''

0
 
aot2002Author Commented:
insmod ide-scsi
insmod: can't read 'ide-scsi': No such file or directory

using centos 4
0
 
btomkinsCommented:
I am not familiar with centos have you tried method 2?

It looks like your kernel does not have the the ide-scsi module.
If you run 'lsmod' this will list the modules included in your kernel and you can check if it is there. If not then
you will need to recofigure and recompile your kernel to include the ide-scsi module.


Take a look at this thread which discusses a similar problem.
http://www.linuxforums.org/forum/installation/3860-slackware-9-cd-burner-recognition-problem.html
0
 
aot2002Author Commented:
modprobe ide-scsi
worked

if i add that line is it possible to have this detected at boot?
0
 
btomkinsCommented:
sorry the first instructions should have read
not
2.            Edit the file /etc/rc.d/rc.local and remove the line: modprobe ide-scsi
but
2.            Edit the file /etc/rc.d/rc.local and add the line: modprobe ide-scsi

although this is for fedora/redhat

so if you add 'modprobe ide-scsi' to rc.local that should load it at boottime
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: Amazon Web Services - Basic

Are you thinking about creating an Amazon Web Services account for your business? Not sure where to start? In this course you’ll get an overview of the history of AWS and take a tour of their user interface.

  • 4
  • 3
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now