Solved

Unable to get fibre interfaces up on Cisco 3750?

Posted on 2006-07-21
15
3,466 Views
Last Modified: 2013-11-15
Hi there,

Trying to connect a Cisco 3750 to a 2950 using twin link-aggregated fibres. Got LT - MTRJ fibres, connected the two machines, I was expecting to see some activity LEDs flash, but nothing. Both switches sit there blissfully unaware of each other and can't seem to get them talking.

I'm obviously missing something very obvious. Anyone care to tell me what it is?!

Thanks.

George
0
Comment
Question by:georgemason
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
15 Comments
 
LVL 6

Expert Comment

by:wirthr
ID: 17154755
do the switches show the ports as up?  just to eliminate the extremely obvious..
0
 
LVL 5

Expert Comment

by:jeffkell
ID: 17155284
Are you even getting link?
You may have xmt/rcv reversed (won't get link until you get them right).
Please post a 'show interface' so we can see what the switch thinks.
0
 
LVL 1

Author Comment

by:georgemason
ID: 17155649
Hi both, no not getting any sort of link, and the ports come up as not connected. I was expecting to get link straight away, same as with copper Ethernet, but not happening.

Don't think I have got the tx/rx the wrong way round as these are duplex fibres and as such only go in one way? The LT connector has two sides to it, and 2 fibres going into it, which I assume must be tx & rx. It won't go in the other way around, nor on the MTRJ end.
0
Learn how to optimize MySQL for your business need

With the increasing importance of apps & networks in both business & personal interconnections, perfor. has become one of the key metrics of successful communication. This ebook is a hands-on business-case-driven guide to understanding MySQL query parameter tuning & database perf

 
LVL 1

Author Comment

by:georgemason
ID: 17155667
This is what it thinks - not much!

GigabitEthernet1/0/25 is down, line protocol is down (notconnect)
  Hardware is Gigabit Ethernet, address is 0017.59c0.ab99 (bia 0017.59c0.ab99)
  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive not set
  Auto-duplex, Auto-speed, link type is auto, media type is 1000BaseSX SFP
  input flow-control is off, output flow-control is unsupported
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input never, output never, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts (0 multicast)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 0 multicast, 0 pause input
     0 input packets with dribble condition detected
     0 packets output, 0 bytes, 0 underruns
     0 output errors, 0 collisions, 1 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 PAUSE output
     0 output buffer failures, 0 output buffers swapped out
gig-switch#
0
 
LVL 1

Author Comment

by:georgemason
ID: 17155670
It's the same the other end too - (notconnect)
0
 
LVL 1

Author Comment

by:georgemason
ID: 17155717
Seeing as I've got to get this working, I'm instead trying to link aggregate some of the ethernet ports as a second-best. Not nearly as fast, but I can spare a few ports on either switch for the time being, so not the end of the world. Can someone let me know where i'm going wrong with the following config? I've configured port-channel settings for each interface but when I do a show port-channel 1 on either it still tells me it's running at 100mbps - I expected to see the aggregated total speed?

Thanks! Sorry for all the st00pid questions....

sh run below:

sh rubn  n
Building configuration...

Current configuration : 2192 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname gig-switch
!
enable secret 5 xxxxxxxxxxxxxxxxxxxx
enable password xxxxxxxxxxxxxxxxxxx
!
no aaa new-model
switch 1 provision ws-c3750g-24ts
udld aggressive

ip subnet-zero
!
!
mls qos map cos-dscp 0 8 16 26 32 46 46 56
!
macro global description cisco-global
errdisable recovery cause link-flap
errdisable recovery interval 60
no file verify auto
!
spanning-tree mode rapid-pvst
spanning-tree loopguard default
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
interface Port-channel1
!
interface GigabitEthernet1/0/1
!
interface GigabitEthernet1/0/2
!
interface GigabitEthernet1/0/3
!
interface GigabitEthernet1/0/4
!
interface GigabitEthernet1/0/5

interface GigabitEthernet1/0/6
!
interface GigabitEthernet1/0/7
!
interface GigabitEthernet1/0/8
!
interface GigabitEthernet1/0/9
!
interface GigabitEthernet1/0/10
!
interface GigabitEthernet1/0/11
!
interface GigabitEthernet1/0/12
!
interface GigabitEthernet1/0/13
!
interface GigabitEthernet1/0/14
!
interface GigabitEthernet1/0/15
!
interface GigabitEthernet1/0/16
!
interface GigabitEthernet1/0/17
!
interface GigabitEthernet1/0/18
!
interface GigabitEthernet1/0/19
!
interface GigabitEthernet1/0/20
!
interface GigabitEthernet1/0/21
!
interface GigabitEthernet1/0/22
!
interface GigabitEthernet1/0/23
 channel-group 1 mode on
!
interface GigabitEthernet1/0/24
 channel-group 1 mode on
!
interface GigabitEthernet1/0/25
 switchport trunk encapsulation dot1q
 switchport mode trunk
 macro description cisco-switch
 auto qos voip trust
spanning-tree link-type point-to-point
!
interface GigabitEthernet1/0/26
 switchport trunk encapsulation dot1q
 switchport mode trunk
 macro description cisco-switch
 auto qos voip trust
 spanning-tree link-type point-to-point
!
interface GigabitEthernet1/0/27
!
interface GigabitEthernet1/0/28
!
interface Vlan1
 ip address 192.168.30.252 255.255.255.0
!
ip classless
ip http server
!
!
control-plane
!
!
line con 0
 exec-timeout 0 0
line vty 0 4
 password xxxxxx
 no login
line vty 5 15
 password xxxxxxx
 no login
!
!
end

gig-switch#
0
 
LVL 1

Author Comment

by:georgemason
ID: 17155730
It's ports 23 & 24 that I'm trying to aggregate. I'd like to get the fibre ports (25 & 26) connected but at the moment I'm trying to find a solution by the end of the weekend, so am looking at workarounds!
0
 
LVL 5

Expert Comment

by:jeffkell
ID: 17155928
you need to add:
conf t
int g0/23
 channel-group 1 mode desirable
int g0/23
 channel-group 1 mode desirable
int port-channel1
 no shutdown

that should get you up with two aggregated ports.

still sounds like your fiber problem is tx/rx reversal but hard to tell from the description (that's one you just sorta have to "look and feel" to know).
0
 
LVL 5

Expert Comment

by:jeffkell
ID: 17155946
make that g0/23 and g0/24 above (my typo).  make your actual configurations to the resulting port channel (switchport mode, etc) and not the individual group interfaces.
0
 
LVL 1

Author Comment

by:georgemason
ID: 17156732
This is really driving me nuts now.... Below are the configs, first from the 2950 and then the 3750.

I've connected them by 3 cat5 cables and am attempting to create an aggregated link from ports 46-48 on the 2950 to 22-24 on the 3950. At the moment, it seems I have a PaGP aggregated link, but only with one active port (46 - 22 respectively). The other two are down, and refuse to wake up.

If anyone can see what's wrong with these configs they'd be doing me a massive favour by letting me know..... Thanks!!

***** 2950 config *******

Current configuration : 2255 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Switch
!
enable secret 5 itsasecret!!!
ip subnet-zero
!
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
!
!
!
!
interface Port-channel1
 switchport mode trunk
 flowcontrol send off
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
*** big boring bit cut out here ***
!
interface FastEthernet0/41
!
interface FastEthernet0/42
!
interface FastEthernet0/43
!
interface FastEthernet0/44
!
interface FastEthernet0/45
!
interface FastEthernet0/46
 switchport mode trunk
 channel-group 1 mode desirable
!
interface FastEthernet0/47
 switchport mode trunk
 channel-group 1 mode desirable
!
interface FastEthernet0/48
 switchport mode trunk
 channel-group 1 mode desirable
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
 ip address 192.168.30.252 255.255.255.0
 no ip route-cache
!
ip http server
!
end


******* 3750 config ********

Current configuration : 2206 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname gig-switch
!
enable secret 5 itsasecret!!

!
no aaa new-model
switch 1 provision ws-c3750g-24ts
udld aggressive

ip subnet-zero
!
!
mls qos map cos-dscp 0 8 16 26 32 46 46 56
!
!
macro global description cisco-global
errdisable recovery cause link-flap
errdisable recovery interval 60
no file verify auto
!
spanning-tree mode rapid-pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
interface Port-channel1
!
interface GigabitEthernet1/0/1
!
interface GigabitEthernet1/0/2
!
** another big chunk chopped out here **
!
interface GigabitEthernet1/0/22
 channel-group 1 mode desirable
!
interface GigabitEthernet1/0/23
 channel-group 1 mode desirable
!
interface GigabitEthernet1/0/24
 channel-group 1 mode desirable
!
interface GigabitEthernet1/0/25
 switchport trunk encapsulation dot1q
 switchport mode trunk
 macro description cisco-switch
 auto qos voip trust
 spanning-tree link-type point-to-point
!
interface GigabitEthernet1/0/26
 switchport trunk encapsulation dot1q
 switchport mode trunk
 macro description cisco-switch
 auto qos voip trust
 spanning-tree link-type point-to-point
!
interface GigabitEthernet1/0/27
!
interface GigabitEthernet1/0/28
!
interface Vlan1
 ip address 192.168.30.253 255.255.255.0
!
ip classless
ip http server
!
!
control-plane

end
0
 
LVL 5

Expert Comment

by:jeffkell
ID: 17156809
You do NOT want 'switchport mode trunk' on the individual interfaces of the channel-group.

You DO want 'switchport mode trunk' and other related directives on the port-channel.

About all you want on the individual interface configurations of a port-channel is speed/duplex (if not auto).

Put all of the attributes of the virtual aggregated interface in the "port-channel" configuration.
0
 
LVL 1

Author Comment

by:georgemason
ID: 17156909
Ah, thanks. In the end I lost my temper and reset the 3750 to factory settings. After doing that, the port aggregation seemed to work perfectly after I'd added the "channel-group 1 mode desirable" statements to each interface (obviously by resetting the switch I removed the erroneous trunk statements too). So far, so good. But the link doesn't seem any faster despite me going from a 2x100mbps aggregated link to 3x100mbps. I guess I'm looking at this from a simplistic viewpoint but doesn't it work like this - more links = faster throughput?
0
 
LVL 5

Assisted Solution

by:jeffkell
jeffkell earned 125 total points
ID: 17157215
Well, now you're just getting downright picky :-)  And time to shed the marketing-speak and get down to reality.

With your 29xx/37xx switches, you don't have many options.  When you create a port-channel, you have to know how the traffic is going to be divided.  The switches will not load-balance on a per-packet basis like you might think (well, the right switches with the right software and the right configuration, but the 29xx/37xx doesn't qualify).

Traffic is balanced on a per-connection basis.  You basically get your choice of:

3550(config)#port-channel load-balance ?
  dst-mac  Dst Mac Addr
  src-mac  Src Mac Addr

Your 3750 might offer some other options, but I suspect it's just source or destination MAC based.  It will essentially use the low-order bits of the MAC address specified to decide which link of the port-channel to use.

Higher-end switches can use src/dst IP and or layer4 port numbers, but not the low-end ones.  

You'll never get more than 100mbps per connection.  For multiple connections, you can get more aggregate bandwidth in total, but not individually.

Channel-groups work best when you use 2, 4, or 8 links.  Suggest you add another to make 4 members until you get the fiber gigabit working.
0
 
LVL 79

Accepted Solution

by:
lrmoore earned 125 total points
ID: 17157382
>Got LT - MTRJ fibres
Make sure you have LC (LT = typo?) -> MTRJ cables
You have to make sure you have multimode fiber jumper cable, and multimode SFP module on the 3750.
What kind of jumber cables do you have? 62.5 or 50 micron? You should have 62.5 micron

Have you tried swapping the two ends of the LC on the 3750? They will swap individually, but the MTRJ ends are stationary

>I guess I'm looking at this from a simplistic viewpoint but doesn't it work like this - more links = faster throughput?
More links = more aggragate throughput, but no single connection can possibly get more than one link's worth of bandwidth.
0
 
LVL 1

Author Comment

by:georgemason
ID: 17159466
VICTORY!! lrmoore, I don't know if you drink or not, but if you were here in Spain I'd definitely buy you a beer! I'm increasing the point value of this question, and giving half points each to yourself and to jeffkell for his help.

I now not only have a pair of working fibres (attacking the LC connectors and swapping the tx/rx worked a treat although was very fiddly) but understand the basic mechanics of Cisco link aggregation. I can't thank you both enough, this was really driving me nuts.
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Most of the applications these days are on Cloud. Cloud is ubiquitous with many service providers in the market. Since it has many benefits such as cost reduction, software updates, remote access, disaster recovery and much more.
This article shows how to use a free utility called 'Parkdale' to easily test the performance and benchmark any Hard Drive(s) installed in your computer. We also look at RAM Disks and their speed comparisons.
Michael from AdRem Software explains how to view the most utilized and worst performing nodes in your network, by accessing the Top Charts view in NetCrunch network monitor (https://www.adremsoft.com/). Top Charts is a view in which you can set seve…
Monitoring a network: why having a policy is the best policy? Michael Kulchisky, MCSE, MCSA, MCP, VTSP, VSP, CCSP outlines the enormous benefits of having a policy-based approach when monitoring medium and large networks. Software utilized in this v…

630 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question