Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1288
  • Last Modified:

out of inodes HP UX 11.11

Hi Experts,

one of the Vxfs filesystem is giving "out of inodes" error while tryinging to create any new file or directory.

I check "df -i /filesystemx" and its show only "27%" used.

The filesystem was created with unlimited inodes option.

mkfs -F vxfs -o ninode=unlimited,bsize=8192,version=4,inosize=256,logsize=256,nolargefiles
/dev/vg1/lv7 2216114848

What is the quick fix for this problem other than deletion of old files?

Thanks
0
myrizvi
Asked:
myrizvi
  • 3
  • 2
1 Solution
 
tfewsterCommented:
It shouldn't happen with ninode=unlimited set, but if you have a directory with millions of entries, the directory itself may not be able to grow past 2Gb, so you'll need to enable largefiles

See: http://mailman.eng.auburn.edu/pipermail/veritas-vx/2000-September/000562.html   - It appears that the inode list itself requires the "largefiles" option, even if the directory structure doesn't

If you ARE using a flat file structure with millions of entries in a directory, I'd seriously consider reorganising it as filesystem performance will be poor.

Otherwise, you should look at patches for vxfs
0
 
tfewsterCommented:
Here's an HP-specific link that explains it better:
http://forums1.itrc.hp.com/service/forums/questionanswer.do?threadId=1009318
0
 
myrizviAuthor Commented:
Thanks tfewster,

I will go through these links and see if the larg file option can resolve this problem.
0
 
myrizviAuthor Commented:

So I have to unmount the filesystem, then set the largefile option and re-mount the filesyste. But I need to know what other steps are required as the filesystem is part of high availability cluster. If I add the largefile option in one node then do I need to do something on other node of the cluster.

I think I might open another question for this.
0
 
tfewsterCommented:
If this fileystem is part of the cluster resource that gets failed over, the largefile setting within the filesystem will get switched across too.

However, it needs to be mounted with the "largefiles" option (Or at least, without the "nolargefiles" option - HP-UX detects the settings from the filesystem if not specified); Normally this would be specified in /etc/fstab, but if it's clustered, the cluster config may need updating -   If I recall correctly, the config file will be in /etc/cmcluster/<package name> and changes can be checked/applied using cmcheckconf/cmapplyconf respectively. Personally, I'd use cmgetconf to extract the current applied config just in case the config file doesn't match what has actually been applied ;-)

I suspect you'll need to halt the ServiceGuard package that uses this filesystem, convert the filesystem (using the special device name rather than the mount point name), [modify the cluster config if needed] and then restart the package. In theory you could just drop this filesystem from the cluster config so it could be converted without halting the entire package, but that needs a good understanding of how the volume group & filesystem are used.

So until you can arrange an outage, the short-term fix might be to back up some files and remove them...
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now