Solved

Cisco 2924 VLAN2 Administratively Down

Posted on 2006-07-21
7
2,023 Views
Last Modified: 2008-01-09
Hello,
I have a Cisco 2924 switch configured with a  second VLAN to host a subnet used for a Microsoft Exchange Cluster Hearbeat only. It seems to be working because the NIC's on the VLAN2 are able to communicate with eachother, but it shows a status of 'Administratively Down' when the configuration is displayed. I've tried logging on to the interface and setting the 'no shutdown' command, but the status does not change. Any advice?
Thanks

Jeff



mosc2924#sho run
Building configuration...

Current configuration:
!
version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname mosc2924
!
enable secret 5 $1$MK12$Ws9ROqTnBBdbpbO7Ibi/01
!
!
!
!
!
!
ip subnet-zero
!
!
!
interface FastEthernet0/1
 duplex full
!
interface FastEthernet0/2
!
interface FastEthernet0/3
 duplex full
!
interface FastEthernet0/4
 duplex full
!
interface FastEthernet0/5
!
interface FastEthernet0/6
 duplex full
!
interface FastEthernet0/7
 duplex full
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
 duplex full
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
 duplex full
 switchport access vlan 2
!
interface FastEthernet0/18
 duplex full
 switchport access vlan 2
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface FastEthernet1/1
!
interface FastEthernet1/2
!
interface VLAN1
 ip address 192.168.1.248 255.255.255.0
 no ip directed-broadcast
 no ip route-cache
!
interface VLAN2
 ip address 192.168.2.254 255.255.255.0
 no ip directed-broadcast
 no ip route-cache
 shutdown
!
interface VLAN3
 no ip directed-broadcast
 no ip route-cache
 shutdown
!
ip default-gateway 192.168.1.254
snmp-server engineID local 00000009020000307BDEFF00
snmp-server community private RW
snmp-server community public RO
!
line con 0
 transport input none
 stopbits 1
line vty 0 4
 password 7 0506051C241E1E594B
 login
line vty 5 15
 password 7 0506051C241E1E594B
 login
!
ntp clock-period 22518413
ntp server 192.168.1.215 source VLAN1
ntp server 192.168.1.254 prefer
end

mosc2924#
0
Comment
Question by:fluffyfrog
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
7 Comments
 
LVL 27

Expert Comment

by:pseudocyber
ID: 17155168
Do you have an active device on the vlan?  I've seen them not come up until there's an active device there.
0
 
LVL 13

Expert Comment

by:ScooterAnderson
ID: 17155183
Did you try the noshut on the VLan interface (in case you didn't...):
>  enable
>  {password}
>  int vlan2
>  no shut

Also, check and see if VLAN2 is in the VLan Database...  
>  enable
>  {password}
>  vlan database
>  vlan 2 name {descriptive name, like "Heartbeat"}
>  exit
>  copy run star
0
 
LVL 5

Expert Comment

by:jeffkell
ID: 17155234
* one interface assigned to the vlan must have link established,
* the vlan2 SVI you defined needs 'no shutdown'
* note that you aren't going to be able to route with a 2924 (layer-2 only switch)
0
NEW Veeam Agent for Microsoft Windows

Backup and recover physical and cloud-based servers and workstations, as well as endpoint devices that belong to remote users. Avoid downtime and data loss quickly and easily for Windows-based physical or public cloud-based workloads!

 

Author Comment

by:fluffyfrog
ID: 17155671
Thanks for your responses, I'll answer accordingly...

pseudocyber - Yes, I have two NIC's connected to the VLAN for the purpose of cluster hearbeat.

scooteranderson - Yup, ran the 'no shut' command and also checked the vlan database and it is present

jeffkell - no routing necessary, the vlan is just to segregate traffic for a cluster heartbeat

**Just to reiterate my point from above, VLAN2 seems to be working, the NIC's are passing traffic, but the VLAN is listed as shutdown when viewing the config.

Thanks again.
0
 
LVL 5

Expert Comment

by:jeffkell
ID: 17155958
the old 2924XL may only let you have one active SVI (you don't need the SVI if you're trunking vlan2 out of the switch)
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 17157277
Just to be clear - you *cannot* have two vlan interfaces active simultaneously on a 2924XL.
Whichever vlan is currently active is considered your "management" vlan
Performing a "no shut" on either interface automatically shuts the other one down. This is by design.
This vlan interface is for no other purpose than for managing the switch itself
There is absolutely no chance to enable them both and try to route between them. This is *not* a layer 3 switch
0
 
LVL 79

Accepted Solution

by:
lrmoore earned 250 total points
ID: 17157290
You don't have to have the interface vlanX to be "up" for the layer 2 vlans to be present and fully functional, as you can attest because your applications are working as expected. Use "show vlan" to see which interfaces are in which vlan to verify your config..
0

Featured Post

Create the perfect environment for any meeting

You might have a modern environment with all sorts of high-tech equipment, but what makes it worthwhile is how you seamlessly bring together the presentation with audio, video and lighting. The ATEN Control System provides integrated control and system automation.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If you're not part of the solution, you're part of the problem.   Tips on how to secure IoT devices, even the dumbest ones, so they can't be used as part of a DDoS botnet.  Use PRTG Network Monitor as one of the building blocks, to detect unusual…
This article explains the fundamentals of industrial networking which ultimately is the backbone network which is providing communications for process devices like robots and other not so interesting stuff.
In this brief tutorial Pawel from AdRem Software explains how you can quickly find out which services are running on your network, or what are the IP addresses of servers responsible for each service. Software used is freeware NetCrunch Tools (https…
Monitoring a network: how to monitor network services and why? Michael Kulchisky, MCSE, MCSA, MCP, VTSP, VSP, CCSP outlines the philosophy behind service monitoring and why a handshake validation is critical in network monitoring. Software utilized …
Suggested Courses
Course of the Month11 days, 7 hours left to enroll

623 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question