Cisco 2924 VLAN2 Administratively Down

Hello,
I have a Cisco 2924 switch configured with a  second VLAN to host a subnet used for a Microsoft Exchange Cluster Hearbeat only. It seems to be working because the NIC's on the VLAN2 are able to communicate with eachother, but it shows a status of 'Administratively Down' when the configuration is displayed. I've tried logging on to the interface and setting the 'no shutdown' command, but the status does not change. Any advice?
Thanks

Jeff



mosc2924#sho run
Building configuration...

Current configuration:
!
version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname mosc2924
!
enable secret 5 $1$MK12$Ws9ROqTnBBdbpbO7Ibi/01
!
!
!
!
!
!
ip subnet-zero
!
!
!
interface FastEthernet0/1
 duplex full
!
interface FastEthernet0/2
!
interface FastEthernet0/3
 duplex full
!
interface FastEthernet0/4
 duplex full
!
interface FastEthernet0/5
!
interface FastEthernet0/6
 duplex full
!
interface FastEthernet0/7
 duplex full
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
 duplex full
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
 duplex full
 switchport access vlan 2
!
interface FastEthernet0/18
 duplex full
 switchport access vlan 2
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface FastEthernet1/1
!
interface FastEthernet1/2
!
interface VLAN1
 ip address 192.168.1.248 255.255.255.0
 no ip directed-broadcast
 no ip route-cache
!
interface VLAN2
 ip address 192.168.2.254 255.255.255.0
 no ip directed-broadcast
 no ip route-cache
 shutdown
!
interface VLAN3
 no ip directed-broadcast
 no ip route-cache
 shutdown
!
ip default-gateway 192.168.1.254
snmp-server engineID local 00000009020000307BDEFF00
snmp-server community private RW
snmp-server community public RO
!
line con 0
 transport input none
 stopbits 1
line vty 0 4
 password 7 0506051C241E1E594B
 login
line vty 5 15
 password 7 0506051C241E1E594B
 login
!
ntp clock-period 22518413
ntp server 192.168.1.215 source VLAN1
ntp server 192.168.1.254 prefer
end

mosc2924#
fluffyfrogAsked:
Who is Participating?
 
lrmooreCommented:
You don't have to have the interface vlanX to be "up" for the layer 2 vlans to be present and fully functional, as you can attest because your applications are working as expected. Use "show vlan" to see which interfaces are in which vlan to verify your config..
0
 
pseudocyberCommented:
Do you have an active device on the vlan?  I've seen them not come up until there's an active device there.
0
 
Scott AndersonPrincipal Support EngineerCommented:
Did you try the noshut on the VLan interface (in case you didn't...):
>  enable
>  {password}
>  int vlan2
>  no shut

Also, check and see if VLAN2 is in the VLan Database...  
>  enable
>  {password}
>  vlan database
>  vlan 2 name {descriptive name, like "Heartbeat"}
>  exit
>  copy run star
0
Improve Your Query Performance Tuning

In this FREE six-day email course, you'll learn from Janis Griffin, Database Performance Evangelist. She'll teach 12 steps that you can use to optimize your queries as much as possible and see measurable results in your work. Get started today!

 
jeffkellCommented:
* one interface assigned to the vlan must have link established,
* the vlan2 SVI you defined needs 'no shutdown'
* note that you aren't going to be able to route with a 2924 (layer-2 only switch)
0
 
fluffyfrogAuthor Commented:
Thanks for your responses, I'll answer accordingly...

pseudocyber - Yes, I have two NIC's connected to the VLAN for the purpose of cluster hearbeat.

scooteranderson - Yup, ran the 'no shut' command and also checked the vlan database and it is present

jeffkell - no routing necessary, the vlan is just to segregate traffic for a cluster heartbeat

**Just to reiterate my point from above, VLAN2 seems to be working, the NIC's are passing traffic, but the VLAN is listed as shutdown when viewing the config.

Thanks again.
0
 
jeffkellCommented:
the old 2924XL may only let you have one active SVI (you don't need the SVI if you're trunking vlan2 out of the switch)
0
 
lrmooreCommented:
Just to be clear - you *cannot* have two vlan interfaces active simultaneously on a 2924XL.
Whichever vlan is currently active is considered your "management" vlan
Performing a "no shut" on either interface automatically shuts the other one down. This is by design.
This vlan interface is for no other purpose than for managing the switch itself
There is absolutely no chance to enable them both and try to route between them. This is *not* a layer 3 switch
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.