Tech or Treat! Write an article about your scariest tech disaster to win gadgets!Learn more

x
?
Solved

Can't Configure IIS6 for Web Services - It Does Work on Development Workstation

Posted on 2006-07-21
6
Medium Priority
?
315 Views
Last Modified: 2008-02-07
I built a very simple web service for testing purposes.  It runs fine on my Windows XP Professional workstation which is the same machine that the project was developed on.  However, when I put it on my Windows 2003 Server using IIS 6, I get the following error when trying to browse to it.

Server Error in '/AcousticallyChallenged' Application.
--------------------------------------------------------------------------------

Configuration Error
Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: It is an error to use a section registered as allowDefinition='MachineToApplication' beyond application level. This error can be caused by a virtual directory not being configured as an application in IIS.

Source Error:


Line 37:            by Microsoft that offers a single logon and core profile services for member sites.
Line 38:     -->
Line 39:     <authentication mode="Windows" />
Line 40:
Line 41:
 

Source File: C:\Web Sites\AcousticallyChallenged\webservices\web.config    Line: 39


--------------------------------------------------------------------------------
Version Information: Microsoft .NET Framework Version:1.1.4322.2300; ASP.NET Version:1.1.4322.2300

What am I missing / not doing / doing wrong?  How do I deploy my web service to my web server so that it can be consumed by other applications?
0
Comment
Question by:Edward Stevens
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
6 Comments
 
LVL 2

Accepted Solution

by:
masoncooper earned 2000 total points
ID: 17156434
If the error message states:
This error can be caused by a virtual directory not being configured as an application in IIS
That would be the first place to look.  Did you place your ASP.Net application in a subdirectory of the root of the site? If so, you need to create a virtual directory and point it to that directory.  This causes IIS to treat your web app as an application instead of a subdirectory of a much larger application.
0
 
LVL 2

Expert Comment

by:kcchenkd
ID: 17157011

try this

in web.config file Change authentication mode form windows to Forms

<authentication mode="Forms" />
0
 
LVL 1

Author Comment

by:Edward Stevens
ID: 17157324
Thanks to both of you.  I will try both tonight.  Below is some additional info that I did not supply initially.

I created a Web Services project using Visual Studio .Net 2003 on my local machine (Windows XP Professional SP2).  After the project was created on my local copy of IIS, I moved the directory to my IIS server on Windows 2003 Server Standard.  I modified the directory reference on my local copy of IIS to point to the other directory such that I wouldn't have to keep copying the files everytime I made a change to the project.  From the workstation, all is still good.  Going to http://localhost/... still allows the web service to function as expected even though the virtual directory is now on the server.

From the server's perspective, the directpry with the web service is located under the virtual directory for the UI portion of the application.  From I've read above, it sounds like I need to create a virtual directory for the web service itself.

I will give that a try tonight.
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
LVL 1

Author Comment

by:Edward Stevens
ID: 17158446
I made the web service have its own virtual directory.  Now, when I go to the URL and click on the function that I have in the DLL, I get the following message in place of what would normally be the parameter dialogue.

The test form is only available for requests from the local machine.

If I go to the URL from my development PC, clicking on the function gives me the parameter dialogue where I am able to test the function and get a return value.

Looks like we're getting closer.  Any ideas?
0
 
LVL 2

Assisted Solution

by:masoncooper
masoncooper earned 2000 total points
ID: 17158481
It looks like you may need to modify your web.config a bit more: http://support.microsoft.com/default.aspx?scid=kb;en-us;819267
Try adding this into your system.web
<webServices>
        <protocols>
            <add name="HttpGet"/>
            <add name="HttpPost"/>
        </protocols>
    </webServices>
0
 
LVL 1

Author Comment

by:Edward Stevens
ID: 17158587
kcchenkd - Sorry I didn't award any points to you.  I tried your suggestion but it had no effect on this particular issue.  Thanks anyway.

masoncooper - I split the points on your two suggestions as a way to help others know that I needed to use both suggestions to handle this issue.  As they are both yours, you should still receive the full 500 points.  Thanks much!
0

Featured Post

Plesk WordPress Toolkit

Plesk's WordPress Toolkit allows server administrators, resellers and customers to manage their WordPress instances, enabling a variety of development workflows for WordPress admins of all skill levels, from beginners to pros.

See why 2/3 of Plesk servers use it.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Does your audience prefer people in photos or no people? How can you best highlight what you’re selling? What are your competitors doing, and what can you do that is different and unique from them?  Continue reading to learn how to make your images …
There’s a good reason for why it’s called a homepage – it closely resembles that of a physical house and the only real difference is that it’s online. Your website’s homepage is where people come to visit you. It’s the family room of your website wh…
The viewer will learn how to dynamically set the form action using jQuery.
Video by: Mark
This lesson goes over how to construct ordered and unordered lists and how to create hyperlinks.
Suggested Courses

649 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question