[Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 6471
  • Last Modified:

Password Policy options grayed out in secpol.msc and gpedit.msc... non-domain computer

I have a computer that is not part of a domain.  As far as I know it has never been part of a domain.  I have logged on as Administrator, and tried to change the password policy so there's no minimum length requirement (I want to setup automatic logon), but the settings are grayed out in both secpol.msc and gpedit.msc.

Any ideas?
0
netsmithcentral
Asked:
netsmithcentral
  • 4
  • 3
  • 2
  • +1
1 Solution
 
bbrunningCommented:
Is it WinXP Home? If so you can't edit that. It's only available in WinXP Pro
0
 
netsmithcentralAuthor Commented:
No, in XP home you cannot even access the secpol and gpedit snap-ins.  It is an XP Pro box.
0
 
bbrunningCommented:
That's weird, have you tried checking the permissions of the administrator username in computer management?

or

Have you check the policy settings within the registry?

I'm not sure where it would be for that particular policy but for"change password" policies the key is normally under HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
netsmithcentralAuthor Commented:
Yes, I've checked every permission setting relating to the Administrator account.  I can edit other secpol items, just not the password policy ones.  And I've checked in the registry.  Microsoft identifies the key relating to pasword policies as being HKLM\System\CurrentControlSet\Control\Lsa\NotificationPackages .  I've checked according to the KB article, and there's nothing there.
0
 
Jason WatkinsIT Project LeaderCommented:
If you want to log on automatically, make sure there is only one user account, and give it a blank password. Enable the welcome screen in the user's applet of the control panel. Are the icons next to the greyed out policies the same as the icons of the not greyed out policies?

If you open up the system properties, and choose the computer name tab does indicate domain or workgroup membership?



0
 
netsmithcentralAuthor Commented:
.... I know how setup automatic logon, and I'm quite aware that in a domain the domain policy will stop you from changing the local policy.  Here's some info on the system:

XP Pro SP2
Member of a Workgroup (NOT IN A DOMAIN)
Only one user account (Plus Administrator and Guest)
Configured not to use Ctrl-Alt-Delete for logon
Configured to use the welcome screen
Has a 4 character minimum for passwords... this is the problem
The policy (which you change in either secpol.msc or gpedit.msc) is grayed out
0
 
MereteCommented:
Here's the scoop: By default, Windows XP Home sets the number of days before changing the password setting to "unlimited"--so essentially, you never need to change it. If you're using XP Home (and this applies to the vast majority of home users) you won't see this behavior--unless, of course, you or some oddball software changes the password default.

In XP Pro, the default for when Windows asks for a new password is 42 days. But since many users don't use a password to log in, they have no idea this setting even exists. (Me? I just hit Enter at the password screen)

XP Home users who face the password-changing issue can use these instructions (XP Pro users can follow my instructions above or these):

Click Start, Run, type cmd, and hit Enter.
Type net accounts /maxpwage:unlimited and hit Enter.
Type exit and hit Enter.
http://www.pcworld.com/howto/article/0,aid,123227,00.asp
-----------------------------------------

Browse through these and see if onecan support the changes you want.
Remember youhave xp home.
Windows XP User Profiles
http://www.kellys-korner-xp.com/win_xp_logon.htm


if relevent:
Changing the password on a locked-out account generates a "domain not available" message
http://support.microsoft.com/?kbid=324141
0
 
bbrunningCommented:
Honestly it sound like your security policies are corrupt. I'd do a repair install of windows and see if that helps.
0
 
Jason WatkinsIT Project LeaderCommented:
One time, a user modified his local security policy to the extent it locked him out of the computer all together.  We were able to get around it by logging on as admin, and deleting the system.dat, and user.dat files then rebooting.  This had the affect of deleting the local policy all together, and upon the next reboot, the policy settings were at their default.

We had declared all was lost by the time we got to this point.  Be sure to back up all of your data before attempting anythin like this.

/F
0
 
netsmithcentralAuthor Commented:
I was able to use the command "net accounts /minpwlength:0" to fix my problem.  Thanks.
0
 
MereteCommented:
:) great thank you.
0

Featured Post

Hire Technology Freelancers with Gigs

Work with freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely, and get projects done right.

  • 4
  • 3
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now