Solved

Telnet configuration

Posted on 2006-07-21
7
5,331 Views
Last Modified: 2008-01-09
Hi
im new in ubuntu
i use ubuntu 5.10....
how to configure telnet on ubuntu as server?
as i know is telnet use default port 23
thank you
0
Comment
Question by:wismadank
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
7 Comments
 
LVL 12

Expert Comment

by:ibu1
ID: 17159022
Do this exactly
# chkconfig --level 35 telnet on
# vi /etc/xinetd.d/telnet

disable  = no

exit and save file

# service xinetd restart

Best of luck
0
 
LVL 88

Expert Comment

by:rindi
ID: 17159157
Don't use telnet, it is disabled by default for a reason (security, as the password is transmitted openly). You should rather use ssh instead, and that is most probably already installed and running!
0
 

Author Comment

by:wismadank
ID: 17160650
Comment from ibu1
Date: 07/21/2006 11:29PM PDT
      Comment       Accept

Do this exactly
# chkconfig --level 35 telnet on
# vi /etc/xinetd.d/telnet

disable  = no

exit and save file

# service xinetd restart

Best of luck
===================================
in that way if i try in fedora 3..it works..
but i try in ubuntu 5.10
#chkconfig ---> command not found

there is no files with name xinetd in ubuntu
i found that telnet was installed for client not as server

i try to login as telnet to server from my handphone
and the server is..ubuntu :P
please help me.....
thank you for the answer
0
Building an interactive eFuture classroom

Watch and learn how ATEN provided a total control system solution including seamless switching matrix switch, HDBaseT extenders, PDU, lighting control to build an interactive eFuture classroom.

 
LVL 24

Expert Comment

by:slyong
ID: 17161386
Have you installed telnetd and xinetd?  To install telnetd you need to enable the "universe" repository. This contains programs that aren't supported by Ubuntu but are imported from the Debian project and generally work well. See http://www.ubuntulinux.org/wiki/UniversePackages for information on how to enable that in synaptic, or if you prefer to do it manually edit the /etc/apt/sources.list to include "universe" at the end of the lines that have "main restricted", like the following:

deb http://archive.ubuntu.com/ubuntu/ warty main restricted universe
deb-src http://archive.ubuntu.com/ubuntu/ warty main restricted universe

After doing that and updating via "apt-get update" or reloading in synaptic, you'll be able to easily install telnetd, and then it should work no problem at all.
0
 

Author Comment

by:wismadank
ID: 17208904
i have installed telnetd and xinetd....
and i can execute this command
#/etc/init.d/xinetd start

in xinetd.d (#ls /etc/xinetd.d/ ) folder, i don't find any files with name telnet...
should i write it manually?
and then restart the xinetd.....
thanks for the answer
0
 
LVL 24

Accepted Solution

by:
slyong earned 125 total points
ID: 17208989
edit /etc/xinetd.conf to:

defaults
{
instances = 60
log_type = SYSLOG authpriv
log_on_success = HOST PID
log_on_failure = HOST
cps = 25 30
}
includedir /etc/xinetd.d

vi /etc/xinetd.d/telnetd to:
service telnetd
{
disable = no
flags = REUSE
socket_type = stream
wait = no
user = root
server = /usr/sbin/in.telnetd
log_on_failure += USERID
}

then do:

# /etc/init.d/xinetd restart

should work then
0
 

Author Comment

by:wismadank
ID: 17217073
thanks slyong...
it work now....but for correct
in /etc/xinetd.d when i write telnetd as you ask...it can not remoted...
and then i try this...

#vi /etc/xinetd.d/telnet
service telnet
{
disable = no
flags = REUSE
socket_type = stream
wait = no
user = root
server = /usr/sbin/in.telnetd
log_on_failure += USERID
}

and theni restart the xinetd
and now i can try to remote my server from my handphone....
thanks to all of you who comment to my question..
you are experts......

0

Featured Post

Manage your data center from practically anywhere

The KN8164V features HD resolution of 1920 x 1200, FIPS 140-2 with level 1 security standards and virtual media transmissions at twice the speed. Built for reliability, the KN series provides local console and remote over IP access, ensuring 24/7 availability to all servers.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
With Secure Portal Encryption, the recipient is sent a link to their email address directing them to the email laundry delivery page. From there, the recipient will be required to enter a user name and password to enter the page. Once the recipient …
Are you ready to implement Active Directory best practices without reading 300+ pages? You're in luck. In this webinar hosted by Skyport Systems, you gain insight into Microsoft's latest comprehensive guide, with tips on the best and easiest way…

730 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question