Solved

VPN Client Connection to PIX

Posted on 2006-07-21
15
623 Views
Last Modified: 2013-11-16
Hello,
I have configured the PIX with dynamic IP and need to be able to connect to it with VPN client. I have never had a problem before, establishing VPN to the PIX, but this is the first one withe dynamic IP. I think I am missing something obvious; it seems that it is connecting but times out during security authentication.
I would appreciate a fresh eye and thanks in advance for any help.
Something like this:

PIX Version 6.3
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password xxxxxxxxxxxxxxxx encrypted
passwd xxxxxxxxxxxxxxxx encrypted
hostname somepix
domain-name somedomain.com
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names        
access-list 101 permit ip any 192.168.253.0 255.255.255.0
access-list outside_cryptomap_dyn_10 permit ip any 192.168.253.0 255.255.255.0
access-list prod_in permit tcp any any eq www
access-list prod_in permit tcp any any eq smtp
access-list prod_in permit tcp any any eq domain
access-list prod_in permit udp any any eq domain
access-list prod_in permit icmp any any
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside pppoe setroute
ip address inside 192.168.1.50 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool starsuppool 192.168.253.1-192.168.253.20
pdm location 192.168.1.0 255.255.255.0 inside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list 101
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
access-group prod_in in interface outside
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection tcpmss 1350
sysopt connection permit-ipsec
crypto ipsec transform-set aesset esp-aes esp-sha-hmac
crypto ipsec transform-set supset esp-3des esp-md5-hmac
crypto ipsec security-association lifetime seconds 86400
crypto dynamic-map outside_dyn_map 10 set transform-set supset
crypto map newmap 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map newmap client authentication LOCAL
isakmp enable outside
isakmp identity address
isakmp nat-traversal 20
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption 3des
isakmp policy 10 hash sha
isakmp policy 10 group 2
isakmp policy 10 lifetime 86400
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption aes
isakmp policy 20 hash sha
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
isakmp policy 40 authentication pre-share
isakmp policy 40 encryption 3des
isakmp policy 40 hash md5
isakmp policy 40 group 2
isakmp policy 40 lifetime 86400
vpngroup starprod address-pool suppool
vpngroup starprod default-domain somedomain.com
vpngroup starprod idle-time 1800
vpngroup starprod password ********
telnet timeout 5
ssh 0.0.0.0 0.0.0.0 outside
ssh 192.168.1.0 255.255.255.0 inside
ssh timeout 5
console timeout 0
vpdn group pppoe_group request dialout pppoe
vpdn group pppoe_group localname name
vpdn group pppoe_group ppp authentication pap
vpdn username name password *********
dhcpd address 192.168.1.100-192.168.1.130 inside
dhcpd dns 11.22.33.44
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd auto_config outside
dhcpd enable inside
username user password PaSsWoRd encrypted privilege 2
terminal width 80
Cryptochecksum:
: end

Thanks.
0
Comment
Question by:awilner
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 7
  • 5
  • 3
15 Comments
 
LVL 8

Expert Comment

by:charan_jeetsingh
ID: 17159305
hi buddy, .....u missing few isakmp configs...

isakmp identity....
isakmp key .......

also... i beleive it wont be possible for u to put the central Pix on DHCP and setup a VPN...

let me check on tht!!

Cj
0
 
LVL 8

Expert Comment

by:charan_jeetsingh
ID: 17159391
u need to have a static ip...

Cj
0
 
LVL 32

Expert Comment

by:rsivanandan
ID: 17159787
What kind of connection do you have ? I mean, what gives you the dhcp address ?

Cheers,
Rajesh
0
Defend Your Organization from The Greatest Threats

Looking to fill the gaps in your security? Bring together information from the network, endpoint and threat intelligence feeds to really see what's happening in your organization. Join the WatchGuardians in their adventures fighting cyber crime!

 

Author Comment

by:awilner
ID: 17160394
I have the Verizon FIOS to which you have to login with username and password. The PIX is getting the external IP correctly, and works very well as a router. Now I registered with DynDNS to track the potentially changing IP - I have a program that detects if IP has changed and updates the DynDNS - that portion is working very well. The dhcp dns server that you see is the verizon's external dns.

The static IP is not an option for now - expensive with FIOS.

It was my understanding from reading the forums that you can setup a CA tunnel, so I assumed that you should be able to connect with VPN Client.  

As I mentioned the VPN connections seems to be establishing, but timing out during the authentication phase.

I do the isakmp identity (it's in the config: isakmp identity address)

But you are correct I am missing the isakmp key; I presume you are saying that I am missing:

isakmp key ******** address 0.0.0.0 netmask 0.0.0.0 no-xauth no-config-mode

Thank you, I will give it a try.
0
 
LVL 32

Expert Comment

by:rsivanandan
ID: 17160543
No No. you don't need all those. just hang in there..

Don't do that.

Cheers,
Rajesh
0
 
LVL 32

Expert Comment

by:rsivanandan
ID: 17160565
>>vpngroup starprod address-pool suppool

This seems to be incorrect, since the ip pool you have defined is 'starsuppool' as below;

ip local pool starsuppool 192.168.253.1-192.168.253.20

So change it to 'vpngroup starprod address-pool starsuppool'

Then;

>>access-list 101 permit ip any 192.168.253.0 255.255.255.0

Change the above to 'access-list 101 permit ip 192.168.1.0 255.255.255.0 192.168.253.0 255.255.255.0

Now try once again after you make all the changes.

Just a note, the DynDns and all won't work since you'll have some time lag in that though. But on the other side, hopefully the assigned dhcp address won't change for quite some time.

Cheers,
Rajesh

0
 

Author Comment

by:awilner
ID: 17160676
Thanks Rajesh,
change it to 'vpngroup starprod address-pool starsuppool' - the name of the pool is the same on the pix. Sorry, I made a mistake when I was posting it.
Change the above to 'access-list 101 permit ip 192.168.1.0 255.255.255.0 192.168.253.0 255.255.255.0 - sorry, but what is that going to do? This access rule has been created to allow access to the VPN user only on the 192.168.253.0 subnet.

The IP has been the same for about 2 weeks, but also I have to note that the speed of propagation and auto update  on DynDNS has been surprisingly fast.




0
 
LVL 32

Accepted Solution

by:
rsivanandan earned 500 total points
ID: 17161007
Changing the access-list would make the specific network traffic to go through the tunnel. I mean, if at all possible, I would eliminate the 'any' word from any access-list.

One more thing, the crypto map is not assigned to the interface.

crypto map newmap interface outside

The above is missing too.

Then in the vpngroup statements;

1. split-tunneling is missing.
2. dns servers are missing.

For now, lets see if it connects, so just add the crypto map to the interface.

Cheers,
Rajesh
0
 
LVL 8

Expert Comment

by:charan_jeetsingh
ID: 17161896
Rajesh's right,

you wont req those for client vpn connections.... sorry fr tht.... didnt gave much time to ur Q...
0
 

Author Comment

by:awilner
ID: 17162222
Thanks Rajesh,
crypto map newmap interface outside - was missing. Somehow I didn't see it.

The DNS server are in the script; not sure I wasnt to turn on split-tunneling.

By the way any suggestion on hardening the script?

Thanks again.
0
 
LVL 32

Expert Comment

by:rsivanandan
ID: 17162226
Awilner,

  Happens all the time :-) No Problemo..

Then about split-tunneling;

If you enable it, then only those traffic destined for your internal network will come through VPN. If you don't enable it, then even internet will be through that for the vpn clients.

Many company's policies don't allow to turn on the split-tunneling just for the fact that, that could do harm to your network (I mean infection and stuff etc), anyways I don't believe in that 'too much' :-)

About the script, which script are you talking about ?

Cheers,
Rajesh
0
 

Author Comment

by:awilner
ID: 17162235
Thanks for the advice, makes sense.
I was asking if you also have any advice about securing the pix a bit, based on the config that I have.
0
 
LVL 32

Expert Comment

by:rsivanandan
ID: 17163035
Oh. on the PIX config? Good, are you aware of 'Output Intrepreter' at Cisco site ?

Basically you can post your configuration there and it will tell you the configuration impact and an analysis. for your configuration. You need to have a CCO account to get there though.

The URL is;

https://www.cisco.com/cgi-bin/Support/OutputInterpreter/home.pl

Just paste in your configuration there and it will analyse it for ya.

Couple of comments I can make are:

1. Authentication using local is not advisible for VPN. What you can do is to have them authenticate to a radius server. One of the easiest and ideal way of configuring it would be, have the IAS installed on Windows and make it as a radius server. In turn, let IAS do the authentication through Active Directory for individual users.

http://www.cisco.com/en/US/products/sw/secursw/ps2120/products_configuration_example09186a00806de37e.shtml

2. Avoid using 'any' from all the access-lists except for incoming services like web, smtp etc.

    access-list prod_in permit tcp any any eq www
    access-list prod_in permit tcp any any eq smtp
    access-list prod_in permit tcp any any eq domain
    access-list prod_in permit udp any any eq domain
    access-list prod_in permit icmp any any

    access-group prod_in in interface outside
   
   This thing allows everything inbound!

3. Don't allow http access to the pix itself to the whole subnet. Just make 2 management servers (One your desktop, another one may be another one in the lab itself). 'http 192.168.1.0 255.255.255.0 inside' => this is what I'm mentioning. Rather narrow it down to something like 'http 192.168.1.10 255.255.255.255 inside'

4. Again ssh is enabled for everybody ? both inside and outside ?

   ssh 0.0.0.0 0.0.0.0 outside
   ssh 192.168.1.0 255.255.255.0 inside
   
   Not a good idea.
   
5. Finally enable logging of pix to a syslog server and keep monitoring on what kind of connections are coming in and going out. You can get Kiwi Syslog for free and it gets the job done.



Cheers,
Rajesh
0
 

Author Comment

by:awilner
ID: 17163176
This is great, thank you very much.
0
 
LVL 32

Expert Comment

by:rsivanandan
ID: 17163346
You're welcome. Keep watching this rsivanandan.wordpress.com when you get time. I keep posting certain things that is of security interest to me. You might want to follow the link there for 'Egress Filtering'...

Cheers,
Rajesh
0

Featured Post

Will You Be GDPR Compliant by 5/28/2018?

GDPR? That's a regulation for the European Union. But, if you collect data from customers or employees within the EU, then you need to know about GDPR and make sure your organization is compliant by May 2018. Check out our preparation checklist to make sure you're on track today!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

To setup a SonicWALL for policy based routing to be used with the Websense Content Gateway there are several steps that need to be completed. Below is a rough guide for accomplishing this. One thing of note is this guide is intended to assist in the…
Concerto Cloud Services, a provider of fully managed private, public and hybrid cloud solutions, announced today it was named to the 20 Coolest Cloud Infrastructure Vendors Of The 2017 Cloud  (http://www.concertocloud.com/about/in-the-news/2017/02/0…
As a trusted technology advisor to your customers you are likely getting the daily question of, ‘should I put this in the cloud?’ As customer demands for cloud services increases, companies will see a shift from traditional buying patterns to new…
Both in life and business – not all partnerships are created equal. Spend 30 short minutes with us to learn:   • Key questions to ask when considering a partnership to accelerate your business into the cloud • Pitfalls and mistakes other partners…

751 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question