Solved

Cisco 1841 Public IP Addressing Frame Relay Configuration

Posted on 2006-07-21
11
5,569 Views
Last Modified: 2013-12-12
I'm having problems configuring up an 1841 with a PIX behind it.  The PIX isn't the issue here, it seems to be the frame relay installation.  I received this information from the ISP in regards the frame connection.

This is a 1024k access circuit
Interface is X.21
CIR=PIR=1024k
Router details are: interface = X.21, LMI = ANSI, Annex D, DLCI = 16

IP addressing for the connection is:
Link network - xx.xx.xx.xx/30 (our router on xx.xx.xx.xy yours on xx.xx.xx.xz)
DMZ - yy.yy.yy.yy/29

So I understand that.. the DMZ ip's will be the public ones and the link network will the /30 as it normally is for frame.  So I get it configured thus:

Current configuration : 1181 bytes
!
version 12.4
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname topmaqhq
!
boot-start-marker
boot-end-marker
!
enable secret 5
enable password 7
!
no aaa new-model
!
resource policy
!
no ip source-route
no ip routing
no ip gratuitous-arps
no ip cef
!
!
!
!
no ip bootp server
!
!
!
!
!
interface FastEthernet0/0
 no ip address
 no ip route-cache
 shutdown
 speed auto
 full-duplex
 no mop enabled
!
interface FastEthernet0/1
 ip address yy.yy.yy.129 255.255.255.248
 no ip route-cache
 speed auto
 full-duplex
 no mop enabled
!
interface Serial0/0/0
 no ip address
 encapsulation frame-relay
 no ip route-cache
!
interface Serial0/0/0.1 point-to-point
 ip address xx.xx.xx.xz 255.255.255.252
 no ip route-cache
 no cdp enable
 frame-relay interface-dlci 16  
!
ip route 0.0.0.0 0.0.0.0 Serial0/0/0.1
!
no ip http server
no ip http secure-server
!
no cdp run
!        
control-plane
!
!
line con 0
line aux 0
line vty 0 4
 password 7
 login
!
scheduler allocate 20000 1000
end

And everything is up.. but I'm not getting anything happening and I can't ping the remote router of the link network.  Is there anything obviously wrong anybody can see??  I'm just off to onsite to get some more debugging information and then I'll post those.
0
Comment
Question by:Doogienz
  • 5
  • 5
11 Comments
 

Author Comment

by:Doogienz
ID: 17159209
Additional Info:

show frame-relay pvc

PVC Statistics for interface Serial0/0/0 (Frame Relay DTE)

              Active     Inactive      Deleted       Static
  Local          1            0            0            0
  Switched       0            0            0            0
  Unused         0            0            0            0

DLCI = 16, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/0/0.1

  input pkts 1057          output pkts 246          in bytes 70804    
  out bytes 10799          dropped pkts 0           in pkts dropped 0        
  out pkts dropped 0                out bytes dropped 0        
  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0        
  out BECN pkts 0          in DE pkts 0             out DE pkts 0        
  out bcast pkts 246       out bcast bytes 10799    
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
  pvc create time 01:07:30, last time pvc status changed 00:03:21

show frame-relay map
Serial0/0/0.1 (up): point-to-point dlci, dlci 16(0x10,0x400), broadcast
          status defined, active

show frame-relay lmi

LMI Statistics for interface Serial0/0/0 (Frame Relay DTE) LMI TYPE = ANSI
  Invalid Unnumbered info 0             Invalid Prot Disc 0
  Invalid dummy Call Ref 0              Invalid Msg Type 0
  Invalid Status Message 0              Invalid Lock Shift 0
  Invalid Information ID 0              Invalid Report IE Len 0
  Invalid Report Request 0              Invalid Keep IE Len 0
  Num Status Enq. Sent 401              Num Status msgs Rcvd 399
  Num Update Status Rcvd 0              Num Status Timeouts 3
  Last Full Status Req 00:00:30         Last Full Status Rcvd 00:00:30

show interfaces serial 0/0/0
Serial0/0/0 is up, line protocol is up
  Hardware is GT96K Serial
  MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation FRAME-RELAY, loopback not set
  Keepalive set (10 sec)
  LMI enq sent  392, LMI stat recvd 390, LMI upd recvd 0, DTE LMI up
  LMI enq recvd 0, LMI stat sent  0, LMI upd sent  0
  LMI DLCI 0  LMI type is ANSI Annex D  frame relay DTE
  Broadcast queue 0/64, broadcasts sent/dropped 238/0, interface broadcasts 238
  Last input 00:00:02, output 00:00:08, output hang never
  Last clearing of "show interface" counters 01:05:28
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: weighted fair
  Output queue: 0/1000/64/0 (size/max total/threshold/drops)
     Conversations  0/1/256 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 1158 kilobits/sec
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     1422 packets input, 74991 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     635 packets output, 16014 bytes, 0 underruns
     0 output errors, 0 collisions, 2 interface resets
     0 output buffer failures, 0 output buffers swapped out
     0 carrier transitions
     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 17161598
Try adding IETF to the interface:

interface Serial0/0/0
 no ip address
 encapsulation frame-relay IETF  <==


>and I can't ping the remote router of the link network.  
Try an extended ping and specify the source IP as your FastEthernet IP

Everything looks clean. Packets getting in, packets getting out and zero errors anywhere..
Do you have a x.21-G.703  converter? Is it configured properly? Is it provided by the telco?
Double-check - triple-check with the ISP that you have the correct IP address and that they can see your serial interface..

You  might change your default route to 'their' ip address instead of using the interface:
 no ip route 0.0.0.0 0.0.0.0 Serial0/0/0.1
 ip route 0.0.0.0 0.0.0.0 xx.xx.xx.xy

Can you ping xx.xx.xx.xy ?
0
 

Author Comment

by:Doogienz
ID: 17162334
Tried those, no go still.  

No I cannot ping xx.xx.xx.xy .  I spent a bit of time on the Telco's helldesk with not much luck.  Twas the weekend here so noone of note available to actually look at it.  They can see their end of the frame and the NTU but can't see my router or ping it, and neither can I ping their end.   The only interesting thing is that when I go show ip route I get no default gateway set which seems a bit weird.


0
 
LVL 79

Expert Comment

by:lrmoore
ID: 17183556
Try saving the config and power cycling the router. Something's not quite working right.
We have another question here where a user can't even get the 1841 router to see the WIC-1T module:
http://www.experts-exchange.com/Networking/Q_21930706.html#17183125
With line up/protocol up, you should not have any problems.
I'd punt this over to Cisco TAC
0
 

Author Comment

by:Doogienz
ID: 17183573
I think I might have found the issue... not 100% sure but it did start working although not passing through vpn traffic atm.

frame-relay switching

Was what I added to the config.
0
Highfive + Dolby Voice = No More Audio Complaints!

Poor audio quality is one of the top reasons people don’t use video conferencing. Get the crispest, clearest audio powered by Dolby Voice in every meeting. Highfive and Dolby Voice deliver the best video conferencing and audio experience for every meeting and every room.

 
LVL 79

Expert Comment

by:lrmoore
ID: 17256367
>frame-relay switching
Your router is not the frame switch, so that should not have to be enabled.
How is everything working now? Can you post output of:
show frame-relay map
show frame-relay pvc
0
 

Author Comment

by:Doogienz
ID: 17258504
hq#show frame-relay pvc

PVC Statistics for interface Serial0/0/0 (Frame Relay DTE)

              Active     Inactive      Deleted       Static
  Local          1            0            0            0
  Switched       0            0            0            0
  Unused         0            0            0            0

DLCI = 16, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/0/0.1

  input pkts 4552984       output pkts 3825079      in bytes 3106471994
  out bytes 1215176889     dropped pkts 0           in pkts dropped 0        
  out pkts dropped 0                out bytes dropped 0        
  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0        
  out BECN pkts 0          in DE pkts 0             out DE pkts 0        
  out bcast pkts 3589      out bcast bytes 173412    
  5 minute input rate 2000 bits/sec, 2 packets/sec
  5 minute output rate 1000 bits/sec, 2 packets/sec
  pvc create time 2w0d, last time pvc status changed 2w0d

I suspect that someone at the isp magically 'fixed' it without telling anyone.  
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 17258717
>I suspect that someone at the isp magically 'fixed' it without telling anyone.  
Typical of telco.
Glad you're working!
0
 

Author Comment

by:Doogienz
ID: 17459217
This was the configuration that finally worked 100%.  It was more a matter of crossing the t's and dotting the i's really.  Just needed to set everything explicity.

interface Serial0/0/0
 bandwidth 1024
 no ip address
 encapsulation frame-relay
 fair-queue
 frame-relay lmi-type ansi
!
interface Serial0/0/0.1 point-to-point
 bandwidth 1024
 ip address xx.xx.xx.xz 255.255.255.252
 no cdp enable
 no arp frame-relay
 frame-relay interface-dlci 16 IETF  
0
 
LVL 79

Accepted Solution

by:
lrmoore earned 500 total points
ID: 17459260
>frame-relay interface-dlci 16 IETF  
Looks like the "IETF" is the real key. You can set it on either the interface-dlci command or on the major interface with the encapsulation command as I suggested above..

>frame-relay lmi-type ansi
>LMI DLCI 0  LMI type is ANSI Annex D  frame relay DTE
LMI was already auto-determined to be ANSI prior to you specifying it in the config


0

Featured Post

6 Surprising Benefits of Threat Intelligence

All sorts of threat intelligence is available on the web. Intelligence you can learn from, and use to anticipate and prepare for future attacks.

Join & Write a Comment

    Over the past few years, small business and home owners have become so dependent on internet that a need for redundancy has arisen.    What happens when your small business or home / home office loses its internet connection?  The results c…
Cable Modem Provisioning from DPoE compliant server  This Article is to support CMTS administrators to provide an overview of DOCSIS compliance configuration file, and to provision a cable modem located at customer place from a Back office serve…
This tutorial demonstrates a quick way of adding group price to multiple Magento products.
You have products, that come in variants and want to set different prices for them? Watch this micro tutorial that describes how to configure prices for Magento super attributes. Assigning simple products to configurable: We assigned simple products…

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

22 Experts available now in Live!

Get 1:1 Help Now