Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

SBS 2003 Backup finished with error code 0X80070569

Posted on 2006-07-22
5
Medium Priority
?
1,913 Views
Last Modified: 2012-08-13
Our SBS 2003 backup fails with the following message in the log:

Backup Runner started.
LogonUser failed. (0x80070569)
NTBackup finished the backup with errors.

For more information about failed backups, see the article on troubleshooting your backup at the following Web page: http://go.microsoft.com/fwlink/?LinkId=18414

Backup ended at Saturday, July 22, 2006 10:27 AM
Backup error finished with error code 0X80070569

I have several SBS 2003 installations that I have access to, and all work except this one.  My research has found that the user SYSTEM has to have "Log on as a service" and "Log on as a batch job" rights in Default Domain Controllers Security Settings | Local Policies | User Rights Assignments.  

On those that work, SYSTEM is NOT listed in these policies as having this right.  When I compare settings on those that work and the one where it does not, I cannot find a difference, yet the SBS 2003 backup will not run and will give the above message within a minute of starting, whether it is scheduled or started manually.

Also, I see where the user that runs the backup cannot be a member of the Mobile users or Remote Security Operators groups, since these groups deny log in as a service.  This is not the case on the SBS 2003 installation that can't start the SBS 2003 backup.

The NT Backup runs without difficulty.

Someone please give me something else to go on!
0
Comment
Question by:timinoldsmar
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
5 Comments
 
LVL 74

Accepted Solution

by:
Jeffrey Kane - TechSoEasy earned 400 total points
ID: 17162281
Generally, you wouldn't have to modify ANY permissions for this to work, so somewhere along the line someone HAS modified permissions.  The backup task is run by the SYSTEM account which uses the "Backup User" account as well.

Please make sure that all of your users are in the default OU of MyBusiness\Users\SBSUsers.  This should include the account for "Backup User" which should be set as "disabled". (the SYSTEM account will enable it as needed).  The Backup User account should be a member of the following groups:

Backup Operators
Domain Admins
Domain Users

None of these groups should be a member of either the Remote Operators or Power Users groups.

Regarding the "logon as a batch job" and "logon as a service", the SYSTEM account most definitely needs to be listed in the "logon as a service".  There should be NO accounts listed in either the "deny logon as a batch job" or "deny logon as a service".

If all of that is correct, then rerun the backup wizard to NOT USE SBS Backup.  When that completes run it again to reconfigure the backup once more.

Jeff
TechSoEasy

0
 
LVL 1

Author Comment

by:timinoldsmar
ID: 17167505
You are a genius, Jeff!  Wow, great troubleshooting!  Your assessment was right on the money, even the initial analysis of someone changing permissions, which is what we suspected.

To summarize, based upon your instructions, I added the SYSTEM account to "log on as a service", removed Domain users from the Remote Operators group, and reran the wizard to NOT use SBS backup and then again to use it, and it ran!

In my opinion, removing the Domain users group from being members of the Remote Operators group was the key!
0
 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
ID: 17169705
Well, only a genius according to EE's rules.  Otherwise, I just don't mess with any of those settings on my SBS installs so it was pretty easy to just look at one of them and tell you how it should be configured.  :-)

Jeff
TechSoEasy
0
 
LVL 5

Expert Comment

by:Ubertam
ID: 23407800
I had this same problem.  Using your information, I found that Domain Admins was a member of Remote Operators.  Backup User is a Domain Admin, and hence a Remote Operator.  Removing Domain Admins from Remote Operators, setting "Do not use SBS backup" and running the wizard again fixed it no problem.

Thanks for the help.
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

The SBS 2011 release date (RTM) is supposed to be around Christmas, 2011.  This article is a compilation of my notes -- things I have learned first hand.  The items are in a rather random order, but I think this list covers most of what is new and d…
The articles for turning off the Client firewall policy on the internet are for SBS 2008 and don't really help for SBS 2011. They actually moved the Client firewall policy. In 2011, the client firewall policy has moved to the SBS computers conta…
This course is ideal for IT System Administrators working with VMware vSphere and its associated products in their company infrastructure. This course teaches you how to install and maintain this virtualization technology to store data, prevent vuln…
Add bar graphs to Access queries using Unicode block characters. Graphs appear on every record in the color you want. Give life to numbers. Hopes this gives you ideas on visualizing your data in new ways ~ Create a calculated field in a query: …
Suggested Courses

704 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question