• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1083
  • Last Modified:

Cisco 1130AG wireless interface flapping

Hi all,

I am trying to configure a Cisco 1130AG. I did one a few weeks back, but stupidly didn't keep a copy of the config. I think I'm going about it the same way, and I can see the WPA-protected SSID that I've created, but when I connect to it my XP machine keeps disconnecting and reconnecting approx every 10 seconds. I can't find anything obvious wrong with the config but since these aren't my speciality I'm sure there's something wrong in there somewhere.

I need to get it working approximately yesterday so I'm awarding high points for this one! Full config posted below for completeness. Very grateful for any insight....

Current configuration : 1787 bytes
!
version 12.3
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname ap
!
enable secret 5 password
!
ip subnet-zero
!
!
no aaa new-model
!
dot11 ssid MyWireless
   authentication open eap eap_methods
   authentication network-eap eap_methods
   authentication key-management wpa
   guest-mode
   wpa-psk ascii 7 graciegraciegracie
!
power inline negotiation prestandard source
!
!
username Cisco password 7 password
!
bridge irb
!
!
interface Dot11Radio0
 no ip address
 no ip route-cache
 !
 encryption mode ciphers tkip
 !
 ssid MyWireless
 !
 speed basic-1.0 2.0 5.5 6.0 9.0 11.0 12.0 18.0 24.0 36.0 48.0 54.0
 station-role root
 bridge-group 1
 bridge-group 1 subscriber-loop-control
 bridge-group 1 block-unknown-source
 no bridge-group 1 source-learning
 no bridge-group 1 unicast-flooding
 bridge-group 1 spanning-disabled
!
interface Dot11Radio1
 no ip address
 no ip route-cache
 shutdown
 speed basic-6.0 9.0 basic-12.0 18.0 basic-24.0 36.0 48.0 54.0
 station-role root
 no dot11 extension aironet
 bridge-group 1
 bridge-group 1 subscriber-loop-control
 bridge-group 1 block-unknown-source
 no bridge-group 1 source-learning
 no bridge-group 1 unicast-flooding
 bridge-group 1 spanning-disabled
!
interface FastEthernet0
 no ip address
 no ip route-cache
 duplex auto
 speed auto
 bridge-group 1
 no bridge-group 1 source-learning
 bridge-group 1 spanning-disabled
 hold-queue 160 in
!
interface BVI1
 ip address 192.168.30.80 255.255.255.0
 no ip route-cache
!
ip http server
no ip http secure-server
ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag
!
!
control-plane
!
bridge 1 route ip
!
!
!
line con 0
line vty 0 4
 login local
!
end

0
georgemason
Asked:
georgemason
  • 4
1 Solution
 
Rick HobbsRETIREDCommented:
It looks good to me, it should work if you enter the correct key unless I am missing something.  You can compare with: http://www.cisco.com/en/US/products/hw/wireless/ps4570/products_configuration_example09186a00801c40b6.shtml
0
 
georgemasonAuthor Commented:
Thanks for that. I can't see anything missing either, hence my confusion. I wonder if it could be a fault with the hardware? I can see the wireless network set up above but the machine just connects and disconnects constantly. No traffic is passed.

Will try connecting from another machine and see what happens.
0
 
georgemasonAuthor Commented:
Update - the fluctuating radio interface seems to only happen when it's configured for WPA connections - with no encryption it works fine. Don't know if this jogs anyone's memory?
0
Improve Your Query Performance Tuning

In this FREE six-day email course, you'll learn from Janis Griffin, Database Performance Evangelist. She'll teach 12 steps that you can use to optimize your queries as much as possible and see measurable results in your work. Get started today!

 
georgemasonAuthor Commented:
Got it. The error is with the PSK, so viewers of the site couldn't have seen the error because I blanked out the key.

I entered the command in the format: wpa-psk ascii 7 keythatiwant

when in fact what I should have done is this: wpa-psk ascii keythatiwant

and then the AP encodes the PSK and puts it back in the config with the "7" in the format: wpa-psk ascii 7 0201165A5321C65E7362512000C3212F
0
 
georgemasonAuthor Commented:
Solution was provided in my previous comment:

"The error is with the PSK, so viewers of the site couldn't have seen the error because I blanked out the key.

I entered the command in the format: wpa-psk ascii 7 keythatiwant

when in fact what I should have done is this: wpa-psk ascii keythatiwant"

Thanks.
0
 
GhostModCommented:
Closed, 500 points refunded.

GhostMod
Community Support Moderator
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now