Solved

configuration of named.conf

Posted on 2006-07-23
10
225 Views
Last Modified: 2010-03-04
Hi,

I've just got BIND up and running and would like to know how to get it setup to answer for one of my domains.

At the moment I have the name servers registered ns1.antbrown.com and ns2.antbrown.com and the domain name www.antbrown.com (the domain name is using these name servers) the name servers are apparently (according to Aplus.net) pointing to the IP address of my dedicated server.

So what do I need to do to get www.antbrown.com recognised?

I have looked at the following document but it did't seem to be ringing a bell with me....

http://yolinux.com/TUTORIALS/LinuxTutorialWebSiteConfig.html#DNS

Thanks
Ant
0
Comment
Question by:antum
  • 3
  • 2
  • 2
  • +1
10 Comments
 
LVL 24

Expert Comment

by:slyong
ID: 17165392
Hi Ant,

Since the last time that you asked about DNS question.  I think you are not getting enough advise of the issue.  Let's see what needs to be done and what is already in place:

1) Purchase a Domain Name (i.e. antbrown.com) from the registrar - done with Aplus
2) Setup the DNS - pending
3) Setup the Web Hosting - done

The problem is that you really need 2 NameServers (ns1 ns2) for any domain registered and those needs to be fixed IPs too.  In item (3), that you have already purchase a hosting (dedicated server) from someone.  Would you be able to let us know who that company is?  They might already have provided DNS server for you.  May be you should check with them.  To make the whole scenario a bit clearer.  When you purchase a domain name from the registrar, the registrar will configure nameservers which is the NS records.  The NS records should be pointing to your DNS servers (2 of them).  In your DNS servers, you then setup things like www pointing to where your Web Server is.
0
 
LVL 15

Accepted Solution

by:
periwinkle earned 250 total points
ID: 17169771
Assuming that you have two ip addresses and DNS set up properly, you then must change your registrar record at names4ever.com for antbrown.com.

However, according to domaintools.com (see: http://whois.domaintools.com/antbrown.com ),

- you are using the same ip address for both name servers (which is not allowed by the central registry)
- there are apparently errors with how you have set up dns.

I then went to dnsreport.com to find out more information:

http://dnsreport.com/tools/dnsreport.ch?domain=antbrown.com

There are many issues which you need to resolve;  perhaps this gives you a start in the right direction?
0
 

Author Comment

by:antum
ID: 17173374
Hi there,

Yes, very helpful. I do not have two IP addresses. Do I need to rent another one? or ? how do I proceed from here?

Currently antbrown.com works but www.antbrown.com doesn't work. Perhaps this is another issue unrelated....

Thanks
Ant
0
 
LVL 24

Assisted Solution

by:slyong
slyong earned 250 total points
ID: 17173410
Hi Ant,

It seems like the other way around.  www.antbrown.com give me your hello world while antbrown.com doesn't give me anything.  May be your have resolved the issue?
0
Comprehensive Backup Solutions for Microsoft

Acronis protects the complete Microsoft technology stack: Windows Server, Windows PC, laptop and Surface data; Microsoft business applications; Microsoft Hyper-V; Azure VMs; Microsoft Windows Server 2016; Microsoft Exchange 2016 and SQL Server 2016.

 
LVL 51

Expert Comment

by:ahoffmann
ID: 17176058
> Currently antbrown.com works but www.antbrown.com doesn't work.
are you talking about DNS (ping, nslookup, dig, etc.) or about accessing your webserver at these FQDNs (as I assume according the TA here)?
0
 

Author Comment

by:antum
ID: 17246271
Hmm.. FQDNs and TA are foreign to me so I guess I am missing something...

I'm talking about accessing them from the browser... my Apache conf for the Virtual Host seems to be setup right... it gives the Alias and ServerName, but in the DNS settings I have antbrown.com instead of www.antbrown.com 

I did try to change it once which is probably why slyong saw it the other way around... but I soon changed it back because all the examples I read left the www part out in the named.conf

Thanks,
Ant
0
 
LVL 15

Expert Comment

by:periwinkle
ID: 17246293
FQDN = fully qualified domain name - that means www.antbrown.com instead of just the domain name antbrown.com.
0
 
LVL 15

Expert Comment

by:periwinkle
ID: 17407385
There are still issues with your dns servers - please refer back to the dnsreport:

http://www.dnsreport.com/tools/dnsreport.ch?domain=antbrown.com

0

Featured Post

Ransomware-A Revenue Bonanza for Service Providers

Ransomware – malware that gets on your customers’ computers, encrypts their data, and extorts a hefty ransom for the decryption keys – is a surging new threat.  The purpose of this eBook is to educate the reader about ransomware attacks.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In my time as an SEO for the last 2 years and in the questions I have assisted with on here I have always seen the need to redirect from non-www urls to their www versions. For instance redirecting http://domain.com (http://domain.com) to http…
It is possible to boost certain documents at query time in Solr. Query time boosting can be a powerful resource for finding the most relevant and "best" content. Of course the more information you index, the more fields you will be able to use for y…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.
This video explains how to create simple products associated to Magento configurable product and offers fast way of their generation with Store Manager for Magento tool.

919 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now