Solved

companyweb asking for username and password?

Posted on 2006-07-23
8
1,657 Views
Last Modified: 2008-02-26
Hello Experts,

I've obviously been playing too much, and for some reason when I access http://companyweb it asked me for my username and password. Once I give them to it, it works as advertised.

Not all users on my server are asked to login. Some just get the page like they are supposed to.

What have I messed up? :-)
0
Comment
Question by:OzoneFriendly
  • 3
  • 3
  • 2
8 Comments
 
LVL 21

Expert Comment

by:suppsaws
ID: 17166161
Hi OzoneFriendly,

Do you still have the correct permissions on the companyweb folder in IIS?

The permission of companyweb under IIS console:


Administrators                          Full Control
CREATOR OWNER                   Special Permissions
INTERACTIVE                             List Folder Contents; Special Permissions
NETWORK                                 List Folder Contents; Special Permissions
SYSTEM                                          Full Control
Users                                           Read & Execute; List Folder Contents; Read; Special Permissions




Cheers!
0
 
LVL 21

Expert Comment

by:suppsaws
ID: 17166181
OzoneFriendly,

To check permissions go to "Companyweb" >Site Settings>Manage Users and
ensure that the  user is listed.
Permissions for companweb are set automatically by the Add User Wizard.
From the Users node of Standard
Management, you can re-apply permissions by selecting a template and one or
more users.

0
 

Author Comment

by:OzoneFriendly
ID: 17167165
Hi,

Okay, the permissions you mentioned first are all as advertised.

I'm having a little trouble following the 2nd set of instructions. I can't find companyweb>sitesettings>manageusers

I can't also quite figure out how to re-apply a template to an existing user. I'm still a bit of a noob at this :-)
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 21

Accepted Solution

by:
suppsaws earned 500 total points
ID: 17168345
open companyweb
at the top line you see home - documents and lists - create - site settings
click on 'site settings'
then click on 'manage users'

Go to the server > server management > users
click on you user account, then click on 'change user's permissions' to change the template
0
 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
ID: 17169452
You can do this from the Server Management Console.

Open Server Management > Internal Web Site > Manage Access.  Make sure that you are listed as a user on this list.  If you aren't, don't add yourself manually, instead reapply the user template to your account.

To reapply user template you must log into the server with the built-in Administrator account and then open Server Management > Users > and  click 'change user permissions' in the list of links under Manage Users.  Select the appropriate template (probably administrator template) and click Next (with the Replace any previous permissions granted to the users selected).  Add your account to the Change List and click next and then finish out the wizard.

Jeff
TechSoEasy
0
 

Author Comment

by:OzoneFriendly
ID: 17180096
The users are listed within Companyweb, so now I am applying the user template to everyone again to see if that fixes it. Quite possibly it will, as this server is how I learned the little that I know, so I have probably messed it up :-) Will let you know shortly.
0
 

Author Comment

by:OzoneFriendly
ID: 17180203
Hello again. The reapply of the template has fixed the problem. Great!

Looks like suppsaws was first in with the right answer, are you happy for me to award him the points, or should I split them?
0
 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
ID: 17181097
No, that's fine... I must have had this question open for quite a while before posting the response because his comment wasn't there when I did so... hence the almost identical answer.  :-)

I'd point out to you that when you run a wizard, the last page will give you a list of all the settings it will be changing.  If you want to ever review what settings were modified the last time you ran a wizard you can always find that information in  the logs found at C:\Program Files\Microsoft Windows Small Business Server\Support  on your server.

All wizards will overwrite previous settings except for the Change User Permissions one which has the option to APPEND OR REPLACE settings.  

Jeff
TechSoEasy
0

Featured Post

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
IIS 7.5 to 8.0 6 121
Migration path from SBS 2011 to ?? 4 116
Multiple Send Connectors - Exchange (SBS 2008) 10 93
aes256 Ransomware on SBS 2011 13 50
Written by Glen Knight (demazter) as part of a series of how-to articles. Introduction One of the biggest consumers of disk space with Small Business Server 2008(SBS) is Windows Server Update Services, more affectionately known as WSUS. For t…
This guide is intended to provide step by step instructions on how to migrate from Small Business Server 2003 to Small Business Server 2011. NOTE: This guide has been written using the preview version of SBS2011 therefore some of the screens may …
Nobody understands Phishing better than an anti-spam company. That’s why we are providing Phishing Awareness Training to our customers. According to a report by Verizon, only 3% of targeted users report malicious emails to management. With compan…

735 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question