Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

crystal reports and pre-printed forms problem

Posted on 2006-07-24
5
Medium Priority
?
855 Views
Last Modified: 2008-01-09
I have researched your excellant database for solutions to this problem
My default printer(generic line printer, text only) points at a form of 4" down x 8" wide, layout is landscape, paper quality is continuous feed no break.
Using label wizard and a customised form of the same size preview provides one label per sheet.
However if I then select print - all the motions are gone through - but nothing appears on the printer.

If I then change the default printer to not point at 4 x 8 but rather  german standard fanfold, then select print then labels print but are of course entirely in the wrong position
 
Please can anyone shed light on this as it feels like I'm painting the ceiling only to find the floor is covered also by a leaking tin!!!!
0
Comment
Question by:keith66miners
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
5 Comments
 
LVL 101

Accepted Solution

by:
mlmcc earned 1000 total points
ID: 17168375
When you say everything is in the wrong position what do you mean?
  Does the report look like it should just shifted left or right?
  Try this

Open the report
Click FILE --> PRINTER SETUP
Select the Printer
Select the fanfold paper

Reformat the page so the margins are correct
Top margin - 0
Bottom Margin Page length - 4
Left margin - 0

mlmcc
0
 

Author Comment

by:keith66miners
ID: 17174573
mlmcc
No it was all to do with the form length.

Why oh why can't you get at and edit the wizard values?

When I open the report, click FILE then options are either PRINT or PAGE SETUP
I have a test of 5 labels
I tried German Fanfold and setting the Top=0, Bottom=101.6mm, Left=0 and got 3 labels spaced correctly then a line dropped between labels 3 and 4 then 4 and 5 spaced correctly.
So then I tried US Std fanfold (as I think that's 12" so divisible by 4) - but then get labels printing alongside (2 up) as label width is defined too small in the wizard.
So - back to creating a new wizard label
Established new user label as:
35.00   0.794(default)
3.81     6.65
0         10.16
default  default

Now using german fanfold - all 5 labels spaced the same - all missing 1 line of drop

You know I have another question currently on the go with an old version 4 of crpe32.dll in winnt\system - can this be related at all?
I did remove the version 4 using remove programs before installing version XI - but could the wrong crpe32 be being picked up?
Keith
0
 
LVL 101

Expert Comment

by:mlmcc
ID: 17176403
I doubt it.  Crystal has changed the report format at least 3 times since version 4.  The old print engine wouldn't know how to handle the new reports.

Not sure what else to try except vary the length slightly to see if you can get rid of the extra line.

mlmcc
0
 

Author Comment

by:keith66miners
ID: 17309013
Solved this myself - after much heartache!
The solution appears to be best not using the Label Wizard, but utilising the hints contained therein.
1 Establish new form (via Control Panel -->Printers, select printer, File --> Server Properties, tick Create new form)
Set up the Width to be  11 inches, Height as 4 inches, Top Margin as 0, Bottom Margin as 0, Left Margin as 0 Right Margin - uninterested
Save form!
2 In crystal report -
suppress report header, page header, report footer and page footer - expand detail section to be 10 cms on ruler.
3 Now the bit that was missing:- Right click with mouse in the Detail contol section and then select Arrange lines. Adjust Report footer so that exactly 24 lines are displayed  (roughly at 8.5cm on the ruler).
4 select fields to be printed from Database, ensuring the horizontally fit within the lines.
5 File-->Page setup
Ensure form from (1) is Size, Sources is Continuous feed no break, Orientation Portrait
6 View -->Print preview and check there is exactly one form per page number and each page contains a form. If this is not the case then add/delete lines to form design and adjust report footer accordingly.
 
0

Featured Post

On Demand Webinar: Networking for the Cloud Era

Did you know SD-WANs can improve network connectivity? Check out this webinar to learn how an SD-WAN simplified, one-click tool can help you migrate and manage data in the cloud.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I hate sub reports and always consider them the last resort in any reporting solution.  The negative effect on performance and maintainability is just not worth the easy ride they give the report writer.  Nine times out of ten reporting requirements…
Hot fix for .Net Crystal Reports 10.2.3600.0 to fix problems with sub reports running on 64 bit operating systems ISSUE: Reports which contain subreports fail with error "Missing Parameter Value" DEPLOYMENT SERVER OS: Windows 2008 with 64 bi…
Sometimes it takes a new vantage point, apart from our everyday security practices, to truly see our Active Directory (AD) vulnerabilities. We get used to implementing the same techniques and checking the same areas for a breach. This pattern can re…
We’ve all felt that sense of false security before—locking down external access to a database or component and feeling like we’ve done all we need to do to secure company data. But that feeling is fleeting. Attacks these days can happen in many w…

721 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question