Solved

crystal reports and pre-printed forms problem

Posted on 2006-07-24
5
842 Views
Last Modified: 2008-01-09
I have researched your excellant database for solutions to this problem
My default printer(generic line printer, text only) points at a form of 4" down x 8" wide, layout is landscape, paper quality is continuous feed no break.
Using label wizard and a customised form of the same size preview provides one label per sheet.
However if I then select print - all the motions are gone through - but nothing appears on the printer.

If I then change the default printer to not point at 4 x 8 but rather  german standard fanfold, then select print then labels print but are of course entirely in the wrong position
 
Please can anyone shed light on this as it feels like I'm painting the ceiling only to find the floor is covered also by a leaking tin!!!!
0
Comment
Question by:keith66miners
  • 2
  • 2
5 Comments
 
LVL 100

Accepted Solution

by:
mlmcc earned 500 total points
ID: 17168375
When you say everything is in the wrong position what do you mean?
  Does the report look like it should just shifted left or right?
  Try this

Open the report
Click FILE --> PRINTER SETUP
Select the Printer
Select the fanfold paper

Reformat the page so the margins are correct
Top margin - 0
Bottom Margin Page length - 4
Left margin - 0

mlmcc
0
 

Author Comment

by:keith66miners
ID: 17174573
mlmcc
No it was all to do with the form length.

Why oh why can't you get at and edit the wizard values?

When I open the report, click FILE then options are either PRINT or PAGE SETUP
I have a test of 5 labels
I tried German Fanfold and setting the Top=0, Bottom=101.6mm, Left=0 and got 3 labels spaced correctly then a line dropped between labels 3 and 4 then 4 and 5 spaced correctly.
So then I tried US Std fanfold (as I think that's 12" so divisible by 4) - but then get labels printing alongside (2 up) as label width is defined too small in the wizard.
So - back to creating a new wizard label
Established new user label as:
35.00   0.794(default)
3.81     6.65
0         10.16
default  default

Now using german fanfold - all 5 labels spaced the same - all missing 1 line of drop

You know I have another question currently on the go with an old version 4 of crpe32.dll in winnt\system - can this be related at all?
I did remove the version 4 using remove programs before installing version XI - but could the wrong crpe32 be being picked up?
Keith
0
 
LVL 100

Expert Comment

by:mlmcc
ID: 17176403
I doubt it.  Crystal has changed the report format at least 3 times since version 4.  The old print engine wouldn't know how to handle the new reports.

Not sure what else to try except vary the length slightly to see if you can get rid of the extra line.

mlmcc
0
 

Author Comment

by:keith66miners
ID: 17309013
Solved this myself - after much heartache!
The solution appears to be best not using the Label Wizard, but utilising the hints contained therein.
1 Establish new form (via Control Panel -->Printers, select printer, File --> Server Properties, tick Create new form)
Set up the Width to be  11 inches, Height as 4 inches, Top Margin as 0, Bottom Margin as 0, Left Margin as 0 Right Margin - uninterested
Save form!
2 In crystal report -
suppress report header, page header, report footer and page footer - expand detail section to be 10 cms on ruler.
3 Now the bit that was missing:- Right click with mouse in the Detail contol section and then select Arrange lines. Adjust Report footer so that exactly 24 lines are displayed  (roughly at 8.5cm on the ruler).
4 select fields to be printed from Database, ensuring the horizontally fit within the lines.
5 File-->Page setup
Ensure form from (1) is Size, Sources is Continuous feed no break, Orientation Portrait
6 View -->Print preview and check there is exactly one form per page number and each page contains a form. If this is not the case then add/delete lines to form design and adjust report footer accordingly.
 
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Crystal Reports: 5 Tests for Top Performance It is complete, your masterpiece report.  Not only does it meet your customer’s expectations, it blows them out the water, all they want is beautifully summarised and displayed in a myriad of ways. …
Hello everyone, Hope you find this as helpful as we did. We have on the company I work for an application built in Delphi V with Crystal Reports 8. We all know that Crystal & Delphi can be temperamental sometimes and the worst thing is, nearly…
This tutorial demonstrates a quick way of adding group price to multiple Magento products.
You have products, that come in variants and want to set different prices for them? Watch this micro tutorial that describes how to configure prices for Magento super attributes. Assigning simple products to configurable: We assigned simple products…

948 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

21 Experts available now in Live!

Get 1:1 Help Now