10060 - Connection timeout when downloading large files

Hi,

Users on our site get 10060 - Connection timeout when they try to download files from the internet larger then 5mb. I do not beleive it is any particular file type that is being blocked becuase there are various file types that we have the issue with ie zip, pdf
The issue seems to be with timeouts, we use Finjan vital security v7 and IIS 2000. If I try turning off finjan it works fine, could this be becuase it does not take as long becuase finjan is not there to scan the file being downloaded?
We have finjan and IIS installed on the same box in the dmz, we use ICAP to relay traffic. I have tried re-installing IIS in cache only mode to see if that would make a difference but we still get the problem.

Is there a way to increased the timeout period? or does anyone have any other things we can try

Im completly lost on this one, its been going on for ages so I hope you can help!!

Thanks
Grimesy24
Grimesy24Asked:
Who is Participating?
 
CetusMODConnect With a Mentor Commented:
PAQed with points refunded (500)

CetusMOD
Community Support Moderator
0
 
Pete LongTechnical ConsultantCommented:
on the IIS server

1. Click Start, click Run, type regedit in the Open box, and then click OK.
2. Navigate to the following registry subkey:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\W3Proxy\Parameters
3. In the right pane of Registry Editor, right-click RequestTimeoutSecs, and then click Modify.
4. Click Decimal, and then type the number of seconds that you want the Web Proxy service to wait for a response before it returns an error message. A recommended value for this setting is 180 or more.
5. Click OK, and then restart the World Wide Web Publishing service. To restart this service: a.  Click Start, click Run, type cmd in the Open box, and then click OK.
b.  Type net stop iisadmin /y, and then press ENTER.
c.  When the service has stopped successfully, type net start iisadmin /y, and then press ENTER.

Note You may have to restart additional dependent services that were stopped together with the IIS Admin Service.
 
6. Test the new settings from a client computer that is configured to use the Web Proxy service: try to go to the Web site where you experienced the problem. If the issue is not resolved, go to the next step.
7. If you still experience the timeout problems, start Registry Editor (if it is not already started), and then navigate to the following registry subkey:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\W3Proxy\Parameters
8. In the right pane of Registry Editor, right-click SocketIoTimeoutSecs, and then click Modify.
9. Click Decimal, and then type a value of 300 (or more) in the Value data box.

Note This is the time in seconds that the Web Proxy service will wait before ending idle socket connections.
10. Restart the World Wide Web Publishing service.
11. Test the new settings from a client computer that is configured to use the Web Proxy service: try to go to the Web site where you experienced the problem. If the issue is not resolved, go to the next step.
12. Add the TcpMaxDataRetransmissions value to the Windows registry. For additional information about how to add and configure this value, click the following article number to view the article in the Microsoft Knowledge Base:  
0
 
Grimesy24Author Commented:
Thanks Pete,

What is the knowledge base article you mentioned?

Also I cannot see the SocketIoTimeoutSecs, does this need to be manually added?

Thanks
Adam
0
Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

 
Grimesy24Author Commented:
Hi,

I have added in the regiestry changes you suggested, I still get a timeout page when I try to download large docs

Does anyone have any suggestions?

Thanks
Adam
0
 
Grimesy24Author Commented:
Could this be anything to do with the way we have ISA setup? caching etc?
0
 
Grimesy24Author Commented:
we are still having a problem, does anyone have any further ideas?

Adam
0
 
Grimesy24Author Commented:

We did find a solution to this problem in the end, incase there is anyone else out there with the same problem we did the following

Open ISA and right click on the server
Click Properties
Click Outgoing Web Requests
Click Configure
Increase the connection timeout seconds

This fixed it for me, hope this helps someone else!

Thanks
Adam
0
 
VenabiliCommented:
Changed recommendation: PAQ - refund
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.