JumpDrive does not autoload

I have two Lexar JumpDrives, both of which have a Secure partition.  When I insert them in the USB port on my laptop I get the "Windows can perform the same action each time you insert" message and if i select the "run the program option" the preferences will allow the drive to autoload

On my desktop, however, the "Windoes can perform" box does not appear.  The public drive partition is visible in my computer but i must manually enter the drive and launch the .exe file to open the secure partion, despite the fact that I have set the preferences to "automatically open dashboard when i connect my jumpdrive" and "enable the single sign-on option".

Suggestions?
rcreteAsked:
Who is Participating?
 
DarthModConnect With a Mentor Commented:
Closed, 500 points refunded.
%%modname%%
Community Support Moderator
0
 
stevepoCommented:
Try this out:

1. Connect your device.
2. Open My Computer. You should see your connected device listed there (or if its a CDRW or DVDRW drive, it's already there)
3. Right-click on your device and select Properties.
4. Click on the AutoPlay tab.
5. Change the option from "Select an action to perform" to "Prompt me each time to choose an action" (or leave it as "Select an action," and select the action you actually want to happen every time).
0
 
rcreteAuthor Commented:
I've started to walk down this road based on previous posts.  I have checked the "prompt me each time" option.  It does not prompt me.  So, whether its set to "select and action" or "prompt me each time", I get the same outcome.....no prompt and no load.
0
Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

 
dragonjimCommented:
Assuming you are running XP...
try checking the group policy setting for the local machine

Group Editor (RUN >> gpedit.msc)

GROUP POLICY
>> LOCAL COMPUTER POLICY
>>>> COMPUTER CONFIGURATION
>>>>>>> ADMINISTRATIVE TEMPLATES
>>>>>>>>>>> SYSTEM

... you will see an option "Turn off Autoplay"

If this enabled (for ALL or the drive referenced in question) Windows will *NOT* use autoplay.
Select "NOT CONFIGURED" or "DISABLED" (you want AutoPlay to be set on).
0
 
rcreteAuthor Commented:
Not Configured
0
 
dragonjimCommented:
Have you tried removing the Registry keys / removing drivers and starting with a re-install?

... natural warning: Highly recommend making a backup prior to editing registry... also if you are not comfortable editing the registry: DON'T.
0
 
rcreteAuthor Commented:
comfortable with backup/edit of registry.  please advise keys/drivers to modify.  thanks
0
 
dragonjimCommented:
That will depend on the drive you are connecting... You will have to look in the registry. From prior tech support position for a cable modem company...

1) Look for references to the Hardware brand
2) Look in the USB sections for the MAC number
3) Mounted Devices

Best educated guess -- likely in HKEY_LOCAL_MACHINE or HKEY_CURRENT_USER
0
 
HyeProfileCommented:
Try this:

1) Run "Regedit"
2) Browse to "HKEY_LOCAL_MACHINE>SYSTEM>CurrentControlSet>Services>"
3) Next, try to locate the key (looks like a folder) for your USB storage device (probably somehing like "USBSTOR") and browse to it...
4) Add or edit a DWORD value called "Autorun" and enter a hex value of 1.
5) Delete a STRING value called "AutoRunAlwaysDisable" if it exists.
0
 
HyeProfileCommented:
If the registry mods don't work, then your drive is probably listed as a "removable mass storage" in WinXP which doesn't allow it to autorun... I also forgot to mention that you'll need an autorun.inf file on the root of the usb key which contains:

[autorun]
open=myprogram.exe

If the registy mods don't work, then look at http://www.paperinik.com/cgi-bin/eng/YaBB.pl?board=CDF;action=display;num=1086937446 as well for another alternative autorun.inf file...
0
 
rcreteAuthor Commented:
In examining Regedit on the Laptop (running XP where USB does autoload) and Desktop (running XP where USB does NOT autoload), the only difference is that the desktop has a subfolder under USBSTOR called Enum.  It has Default=value not set, 0=USB\Vid_05c&pid_a440\33000001937000000263, Count =0x0000001 (1), and NextInstance=0x0000001 (1).  Everything else in USBSTOR and its subfolder Security, are identical.

The particular Lexar USB JumpDrives do contain the necessary autorun.ini referenced by HyeProfile.

And, remember, this USB drives autoruns perfectly on the laptop, and other computers...just not on the desktop.

IDEAS?
0
 
dragonjimCommented:
I'm not well versed in the USB key area...

You may wish to wait to hear what the others in this question think...
But I would be inclined to try...

Make back-up, blah blah...

Export the settings that differ (subfolder & keys) from the working machine.
Import the settings to the machine to the Desktop

Not 100% sure this will have desired effect; but sounds like it is limited down... again, effect might be detrimental; so BACKUP the registry before changing...
0
 
rcreteAuthor Commented:
FIXED:  Just got a response back from Lexar Tech Support.  Seems Microsoft has an AutoPlay Autofix Wizard at:

http://www.microsoft.com/downloads/details.aspx?familyid=C680A7B6-E8FA-45C4-A171-1B389CFACDAD&displaylang=en

which searches and fixes this very tipe of problem.  Heres the file created by the fix program:

AutoFix [V5.2.3790.67]
Time [2006-07-27 11:49:36]
Microsoft Windows Version [5.1 (Service Pack 2) <2600>]

Test [The Shell Hardware Detection service is running.] - Instance [N/A]:
    Result [AutoStart Setting]: OK
    Result [The Shell Hardware Detection service is running.]: OK

Test [Policies] - Instance [G:\, Drive Type: 3]:
    Result [HKCU\...\Policies!NoDrives]: OK {Absent}
    Result [HKCU\...\Policies!NoDriveAutorun]: OK {Absent}
    Result [HKCU\...\Policies!NoDriveTypeAutorun]: OK {Present}
    Result [HKLM\...\Policies!NoDrives]: OK {Absent}
    Result [HKLM\...\Policies!NoDriveAutorun]: OK {Absent}
    Result [HKLM\...\Policies!NoDriveTypeAutorun]: Problems {Present}
    >> Repair << [HKLM\...\Policies!NoDriveTypeAutorun]
      Step: Resetting policy HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer!NoDriveTypeAutorun to 0x00000057.
      Result: This AutoPlay setting was successfully fixed.

>> Required action: The user must log off and log on again

Further information on the NoDriveTypeAutorun can be found at:

http://technet2.microsoft.com/WindowsServer/en/library/70eb7ca3-d834-4f74-9323-d350323ba7641033.mspx?mfr=true

Good luck to 0thers...this should solve the problem.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.