Windows Installer service won't start

raindave
raindave used Ask the Experts™
on
I have 2 applications that will not install:
1. MS CRM 3.0 Exchange router on 2003 sp1 server.
2. Sunbelt software Ninja messaging.
Event log:

vent Type:      Error
Event Source:      Service Control Manager
Event Category:      None
Event ID:      7023
Date:            8/21/2006
Time:            12:06:14 PM
User:            N/A
Computer:      
Description:
The Windows Installer service terminated with the following error:
The requested lookup key was not found in any active activation context.

If I attempt to start the service manually I get error 14007. I've went through these steps from MS:
http://www.support.microsoft.com/default.aspx?scid=kb;en-us;555175&SD=tech
 
No success, any suggestions appreciated.




Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Author

Commented:
Another event:

Event Type:      Warning
Event Source:      MsiInstaller
Event Category:      None
Event ID:      1015
Date:            8/21/2006
Time:            12:54:05 PM

Failed to connect to server. Error: 0x80070005

Author

Commented:
No luck so far. I've also checked this Kb: http://support.microsoft.com/kb/909444
PMI ACP® Project Management

Prepare for the PMI Agile Certified Practitioner (PMI-ACP)® exam, which formally recognizes your knowledge of agile principles and your skill with agile techniques.

Top Expert 2006

Commented:
http://help.lockergnome.com/windows/Windows-Installer-start-SP2-install-ftopict208649.html

this link seems to imply that there may be a GPO configured, look at the last post for solution

Author

Commented:
I manually removed the installer files and rebooted the server. The windows installer service starts again.
Top Expert 2006

Commented:
well then, all is well!

Author

Commented:
No not quite, I now receive "fatal execution engine error"  0x7927e826 when I attempt to install software, these are executables that use windows msi packages. Saw KB824210 and got the hotfix but that won't install cause I have newer versions that files that are being installed.

I used have .net framwork 1.0 and installed 2.0 per vendor suggestion. Anyone?

Author

Commented:
Finally got these apps installed, the final task was to replace net.exe in the system32 folder.
Top Expert 2006

Commented:
what a long process.....sorry i couldnt help

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial