DCOM error Event ID 10016

I am getting DCOM errors every 5 minutes with the following error message:It appears the error is in IIS, that's why I posted here. If it is not, let me know and I'll post in OS section.

Error: DCOM Event IS 10016

The application-specific permission settings do not grant Local Activation permission for the COM Server application with CLSID
 to the user MCOL6B\IUSR_MCOL6B SID (S-1-5-21-1000164821-1436205007-2007182233-1003).  This security permission can be modified using the Component Services administrative tool.

In clicking on the Microsoft link and followed the directions in the Component Services Admin tool, but I was stumped in Para 6 by the "friendly name" reference. I have no way to know what the friendly name is.

Help would be appreciated.
Who is Participating?
esmf23itConnect With a Mentor Commented:
This is a problem I was experiencing with 2 of my Citrix servers, both win2k3 sp1.  After much searching without much luck I came across the answer, first thing is the CLSID listed is refering to the NETMAN in the components list in the DCOM, please follow the information below, and that took care of my errors.

In Component Services


Component Services > Computers > My Computer > DCOM Config

Select netman from the list in the right window.

Right click netman select properties

In the Netman Properties window select the Security tab.

In the Security tab look for Launch and Activation Permissions. Select
Customize then click on the Edit Button.

In the Launch Permissions window click on the Add button.

Type in Network Service in the Enter the object names to select box.

Click on the Ok button.

Select the Network Service in the Launch Permission Security Tab, Group
or user names area and give it (allow rights) for Local Launch and Local

Click Ok
Click Ok

Close Component Services.

Check the event view to make sure the errors stop occurring.
Sam PanwarConnect With a Mentor Sr. Server AdministratorCommented:

This is happen due to some permission removed like network service permission so please check this.

1.      Open Component Services in Administrative Tools.
2.      Go to Component Services/Computers/My Computer/DCOM Config.
3.      In the right pane, find {BA126AD1-2166-11D1-B1D0-00805FC1270E}.
4.      Right click {BA126AD1-2166-11D1-B1D0-00805FC1270E} and click Properties.
5.      Click Security tab.
6.      Choose "Customize" under Launch and Activation Permissions.
7.      Add the network services account, if it is not exists
8.      Grant all permissions to Network services account.
9.      Click OKs to save the changes.
10.     Test whether the problem persists.
11.     If the problem persists, please also check the Access Permissions and
Configuration Permissions.

Also see my answer with same problem in OS topic area


Sam PanwarSr. Server AdministratorCommented:
Easily Design & Build Your Next Website

Squarespace’s all-in-one platform gives you everything you need to express yourself creatively online, whether it is with a domain, website, or online store. Get started with your free trial today, and when ready, take 10% off your first purchase with offer code 'EXPERTS'.

PWyatt1Author Commented:
Hello Abs:

I do not have SMS and the exchange soution link you provided is also not my problem here.

It looks like your detailed solution at the beginning was copy/pasted from the OS solution. It looks like you also copied over the other CLSIDs which aren't germaine for my problem :).

I did follow your suggestions at the first post. However what is very strange is that I could not find my specific CLSID number referred to in the Error message (10016) in the component services details list . There is also another DCOM error with another CLSID and it also I could not find in the Components Details list. How can I get error messages on component permissions if they do not appear in the components list???

As an aside, I have gone through the Microsoft articles #812614 and the Article #332097 and made sure all IIS permissions are correct.

Help would be appreciated. Thanks
Hi Abs_jaipur,

I have also had the same issue but only for a short period, exchange got locked and a server reboot cleared this issue. We now do not have any DCOM issues (at present) however when I tried to follow your 11 steps I found that I did not have {BA126AD1-2166-11D1-B1D0-00805FC1270E} listed in Component Services/Computers/My Computer/DCOM Config. {BA126AD1-2166-11D1-B1D0-00805FC1270E} is definatly what is shown on the error in event viewer.

Should I be concerned?

I too have the {BAE126.... exact same as Peter wrote. It is not listed in the Component Services/Computers/My Computer/DCOM Config section. I have Windows 2003 with SP2 running SQL server and nothing else.  My DCOM errors are 1x per day for a minute, or every few days...not multiple times each day.  Any ideas how to resolve as the fixes above did not seem to apply.  I also do not have "NETWORK SERVICES" as a selection when I try to add it as suggested in some of the posts earlier in this topic. Appreciate any suggestions.
Fix DCOM and NAP error using registry script
I have experienced the same annoying Event ID 10016 regarding local start permission and this is how I solved it creating a registry-file which is launched from a batch file. (Some choices may be slightly different, because I have a Norwegian version of Windows.)
1. Locate the APP ID by searching registry
- Copy CLSID from the event log      {24FF4FDC-1D9F-4195-8C79-0DA39248FF48}
- Copy CLSID into the search dialog of registry
- Search until you find a value named AppID
2. Locate the service
- Copy the data into the search dialog
- Search for the data until you find a value called LaunchPermission
you should see the standard value NAP Agent Service
3. Create a registry backup
- Backup the value via File-Export
4. Change the security setting and create a new reg-file
- Start dcomcnfg.exe
- Navigate to Component services-computers-my computer-DCOM configuration
- Right click NAP Agent service
- click the security tab
- click Start and activation permissions - Custom
- click Edit
- Choose System and tick Local startup
- Close dcomcnfg.exe
- Backup registry (dcomcnfg.exe should be closed first), call the file FixNap.reg
5. Batchfile (one line)
- regedit /s FixNap.reg

This is it! Now you have a batch file which you can use to automate this patch.
Good Luck  :)
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.