Avatar of philodendrin
philodendrin
 asked on

WebDAV Web Folders won't work outside of our own domain

I'm trying to setup a WebDAV folder on my SBS 2003 server. It is working internally, but I can't seem to get the site to open as "Web folder" in Internet Explorer from outside of the domain.

I have followed the instructions I found on this site http://www.windowsnetworking.com/articles_tutorials/WebDAV-IIS.html ...with no luck externally.

I have created a virtual directory under "Default Web Site" with an alias and basically tried every security configuration imaginable... with no luck. I can open the Web page externally, but I can't get Web Folders to work externally. Inbound Port 443 is open on my firewall, as is port 80 (both were already opened for OWA)... and since this is a virtual directory under my Default Web Site... I see that it is using the correct SSL cert (same one I use for OWA).

I have the Web Client service enabled and running remotely and locally. I've tried it with anonymous access enabled or disabled... I have the IUSR Guest Account enabled with full control under the share associated with the virtual directory (just as a test... not for keeps). No matter what I do, I can't get the site to open as a Web Folder outside of my own network.

What am I missing?
SBS

Avatar of undefined
Last Comment
Jeffrey Kane - TechSoEasy

8/22/2022 - Mon
Jeffrey Kane - TechSoEasy

Can you explain what you ultimately are trying to accomplish?  Since there are really better ways to do this with SBS.

At any rate, the reason you cannot access it from outside the LAN is because on the Directory Security Tab, the middle item, "IP address and domain name restrictions" probably is set for "Denied access" instead of "granted access".

Jeff
TechSoEasy
Murat Raymond

You have to run the ICW (Internet connection wizard) from Server management console and choose the option to allow website to be access externally.
You must also add the ports.
Once you start running it, it's pretty explicite but post if need more help on doing so.

Then you need to open IIS
under Web Services Extensions you must allow WebDAV which they seem to cover on the link above

Good luck!
philodendrin

ASKER
Granted Access is selected... so that's not it.

Essentially, we are trying to set up a secure and "universally accessible" way of sharing files... something with more security than FTP.

I assume you're going to suggest SharePoint...
I started with Experts Exchange in 2004 and it's been a mainstay of my professional computing life since. It helped me launch a career as a programmer / Oracle data analyst
William Peck
philodendrin

ASKER
I ran the ICW, but there's no change... all options were selected and granted access.

There are no ports to configure since I'm creating a virtual directory under the "Default Web Site", where I already have Outlook Web Access configured and running fine with port 80 and 443 enabled. So, basically, all I've done is asked the server to grabt access to a new virtual directory /test. It opens just fine remotely, but not as a Web folder.

It certainly seems like a firewall issue, but there's really nothing left for the firewall to do. In this office there's an Actiontec DSL modem with Port Forwarding turned on and ports 80 and 443 pointing to the SBS.

So... not sure where to go from here. I suppose I could just create an entirely new website on a different port, forward the ports to an alternate IP on the server and see if it works... but, I'd much rather get this working the way I have it so that we can just use the same SSL cert.

Murat Raymond

Try to Name the Directory somthing else.
TEST, CHECK Are name That AD in Windows gets confuse. It may not be your case But I seen it Happen in Many occasions
Jeffrey Kane - TechSoEasy

Wait.. so from outside can you get an http directory listing?  If so, then your problem is at the client side, not the server.  You need to make sure that you have the web client service running and that you have it configured properly.

Jeff
TechSoEasy
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
philodendrin

ASKER
The Web client service is definitely started. I am testing from a remote desktop session to an off-site Windows 2003 standard server. What is there to configure on the client side, other than enabling the service to run?
Jeffrey Kane - TechSoEasy

If you "add a network place" it will configure it automatically.

Jeff
TechSoEasy
Jeffrey Kane - TechSoEasy

And, yes, I was going to recommend Sharepoint because you can just use the Web view if you want a Windows Explorer look.

Jeff
TechSoEasy
Experts Exchange is like having an extremely knowledgeable team sitting and waiting for your call. Couldn't do my job half as well as I do without it!
James Murphy
philodendrin

ASKER
Tried that already too... says the folder is invalid when I try to add it ...as https://mail.myserver.com/phil (renamed from test, per vico1's response)

Tried it also without ssl... same thing.

What a pain...
Jeffrey Kane - TechSoEasy

Well, it may be a pain because of the roundabout way you configured it... As long as WebDAV is enabled in IIS manager, then you only really need to do the following:

1.  Using Windows Explorer, Navigate to the folder you want to share.
2.  Right click on the folder > Properties > Web Sharing > Enable.  be sure to check Directory Browsing.
3.  Click the Security Tab and add IUSR_Servername with default permissions.
3.  Open IIS Manager and expand default website to see the Virtual Directory of the folder you just shared
4.  Right click to open properties > Directory Security.  Enable Anonymous Access and Grant All Computers access -- close the properties dialogue
5.  Right click on the Default Web Site > Stop and then Start site.
6.  From an external source open https://mail.myserver.com/foldername

That's all there is to it.  You can then add the folder to My Network Places using https://mail.myservername.com/foldername as well.

Jeff
TechSoEasy
philodendrin

ASKER
Thanks, for the steps, Jeff. It was helpful in the sense that it validates what I've already done half a dozen times. I had been messing with it for so long, I stumbled on your way of doing it and the article's way... and yes, your way is less of a pain... not that it's a difficult task at all when it works.

My tests from an external source were all from either 2003 Small Business Servers or Windows 2003 Std. servers. When I try this from an external XP machine it works! So, what am I missing at the server end? They all have the Web Client service running... but apparently there's something else at the server that needs to be set, when using it as a client. Possibly some security setting in IE?

Ultimately, I guess I don't care about it not working from a server, since the goal is to allow XP clients to connect to and upload to the folder. But, if you have an idea as to why Server 2003 doesn't like Web folders, I'd be interested in understanding the behavior.  
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
ASKER CERTIFIED SOLUTION
Jeffrey Kane - TechSoEasy

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question