Sonicwall - slow pop3 email sending and receiving

We recently had a problem with our Sonicwall TZ-170 router and it was replaced with a brand new unit. I upgraded the firmware to the latest version and then imported the configuration back into the unit. Current firmware version is as follows;
Model: TZ 170 Standard
Firmware Version: SonicOS Standard 3.1.0.15-95s
ROM Version: SonicROM 3.1.0.2

We pull our email off of a server pop.mts.net and we send our mail out through mail.shawcable.com.

Both sending and receiving mail is painfull and usually times out. We use Outlook 2000 SP3, workstation is running Windows XP SP2. The sonicall is doing the DHCP.

Network WAN settings are as follows;
WAN Interface Settings: Auto Negotiate  
Fragment non-VPN outbound packets larger than WAN MTU   (checked off)
WAN MTU:   1500

Now, because we needed to keep our email running, I've pulled the sonicwall and put in a little Netgear RP114 router and we don't have any problems with email transfer at all

I also have no problem telneting into pop.mts.net either so the ports are working properly. We have this problem also when we use Outlook Express

Currently the MTU value 1500

Hope someone can help with this issue.


johnbowdenAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

jasonpaineCommented:
The firmware may be corrupt. If you export a tsr to your desktop and it show under the current firmware a negative sign, then firmware is corrupt. I would start there.
johnbowdenAuthor Commented:
No negative sing in the report.
jasonpaineCommented:
Do you have all the the security setting on like Gateway Anti-Virus, Anti-Spyware and Intrusion Prevention, if so turn them off and test the connect, then turn one on at a time to determine if they are effecting your email. the wan mtu at 1500 is for a t1 line.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
johnbowdenAuthor Commented:
I got the problem resolved...
Under Security Services / E-Mail Filter, I disabled the following options and this seems to make it work properly

Enable Rapid E-Mail Attachment Filtering

Enable E-Mail Attachment Filtering of Forbidden File Extensions

And I selected ‘Disable Forbidden File by altering the file extension and attach warning text’ because it was set to ‘Delete Forbidden File and attach warning text’

AlyorkCommented:
Had a similar problem after updating TZ 170 OS and security software.

Sightly different solution than johnbowden's.

We left  "Enable Rapid E-Mail Attachment Filtering"  checked on,
and unchecked only "Enable E-Mail Attachment Filtering of Forbidden File Extensions".

And selected "Disable Forbidden File by altering the file extension and attach warning text".
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Software Firewalls

From novice to tech pro — start learning today.