Link to home
Start Free TrialLog in
Avatar of rutlandict
rutlandictFlag for United Kingdom of Great Britain and Northern Ireland

asked on

Webalizer referrers not reporting (Fedora 4)

We have webalizer 2.01 installed on our Redhat Linux Fedora 4 web server.
It came preinstalled with the server from Pipex.

However, statistics generated do not include referring URLs or search words used to reach websites even though these global options are set.
It is also not reporting countries - just 100% UK.
We have uninstalled and reinstalled webalizer.
On our previous server (RAQ4) these statistics were reported by default using Webalizer 2.01

I understand webalizer refers to standard log files generated by Apache to get its data but cannot see any referrer log files setup on this server by default. (I'm looking in System/Log File Rotation)

This may not be the reason but is as far as I have got - any help appreciated.

thanks
David
Avatar of kenfcamp
kenfcamp
Flag of United States of America image

referers :

If you're not seeing a referer log file you'll need to add (for apache)
CustomLog /var/log/apache/referer_log referer

'IF" each domain has their own file(s) then you'll also need to do this per profile

Country %'s :

This requires reverse DNS being enabled within webalizers config file and does add some overhead as it will look up every connection. (can slow things down)

There may be other requirements (it's been awile) so read the documention

Hope this helps
Avatar of rutlandict

ASKER

Where do I add this

CustomLog /var/log/apache/referer_log referer


I tried in System/Logfile (create new log file) but it didn't work (could not create that path)
When I browse to /var/log there is no directory called apache

Happy to do without countries.

In here:

/var/log/httpd

there are access logs and error logs but no referrer logs
for a single file,

a few lines under your access_log listing
"CustomLog /var/log/apache/access_log common"

you should see:
#CustomLog /var/log/apache/referer_log referer

simply uncomment the line: (remove the "#")
CustomLog /var/log/apache/referer_log referer

if you dont' have it, add it under your access_log listing somewhere

save your changes and restart apache
<root>apachectl restart

do you mean the access log listing in webalizer.conf?

All I can see that is relevant in webalizer.conf is the following:

# LogFile defines the web server log file to use.  If not specified
# here or on on the command line, input will default to STDIN.  If
# the log filename ends in '.gz' (ie: a gzip compressed file), it will
# be decompressed on the fly as it is being read.

LogFile        /var/log/httpd/access_log

# LogType defines the log type being processed.  Normally, the Webalizer
# expects a CLF or Combined web server log as input.  Using this option,
# you can process ftp logs as well (xferlog as produced by wu-ftp and
# others), or Squid native logs.  Values can be 'clf', 'ftp' or 'squid',
# with 'clf' the default.

#LogType      clf



Also , as I said, there is no /var/log/apache directory on this DS1 Fedora 4 server.
So, for example, the acces logs are found here: /var/log/httpd
The access logs in each virtual site do not contain any referer details

/home/<virtualsite>/logs/access_log

[do you mean the access log listing in webalizer.conf?]

no, this would be your apache config file /etc/apache/httpd.conf (or were ever it's located for your system)


[ the acces logs are found here: /var/log/httpd]

?!??!

erm, so change /var/log/apache > to /where ever/you/want/them

[The access logs in each virtual site do not contain any referer details /home/<virtualsite>/logs/access_log]

so you would add the same for each virtual host
"CustomLog /home/<virtualsite>/logs/referer_log referer"

Here is where I should strongly recommend that you revew apache documention. All of this information is contained among other useful information
We resolved this ourselves. On this server the log files are not set to combined to default.
By changing it to combined webalizer was able to immediately pick up the data from the logs.

ASKER CERTIFIED SOLUTION
Avatar of kodiakbear
kodiakbear

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial