Postfix configuration with Windows DNS

We are running Windows 2003 domain, now get a new linux server for intranet mail only (smtp and pop3).

Suse Enterprise Server                                      Windows AD DC server with DNS
hostname: sv2                                                  hostname: sv1
domain: it.abc.com                                           domain: abc.com (AD)
IP           : 192.168.1.20                                    192.168.1.10
Subnet    : 255.255.255.0                                  255.255.255.0
Gateway  : 192.168.1.2                                     192.168.1.2
DNS        : 192.168.1.10                                    192.168.1.10

------------------------------------------------------------------------------------------
- Postfix configured
# postconf
myhostname = sv2.abc.com
mydomain = abc.com
myorigin = $myhostname
mydestination = $myhostname, $mydomain
inet_interfaces = all
mynetworks = 192.168.1.0/24, 192.168.2.0./24, hash:/etc/postfix/access
mynetworks_style = subnet
#postfix check (no error)

- qpopper installed for POP3 service

- Firewall opened for SMTP SERVER and POP3 SERVER
------------------------------------------------------------------------------------------

(Testing)
# mail user1
Subject: Test
...
EOF


- Use OUTLOOK EXPRESS to take a mail from Suse linux server from one desktop (192.168.1.101).
Mail received, it's fine (user1@it.abc.com),
Reply (user1@it.abc.com), Sent failed.
------------------------------------------------------------------------------------------



(Question)
1. If our Windows domain name "abc.com", can I use it for linux server domain name as my above setting ?

2. My prostfix configuration is correct ?  If I can use 'mail' command to send mail to one of account, is the postfix setup successfully ?

3. "# mynetworks_style = subnet" on main.conf, but why still display "mynetworks_style = subnet" by postconf command ?

4. In fact, the failure is come from Winodws side DNS ? how to set ? (I just add HOST name "sv2.abc.com" into Windows' DNS)

5. Any further comment please ?


Thanks help !



LVL 13
rhinocerosAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

RedfeatherCommented:
1.  Yes you can, and your configuration looks correct. I have run such a combination and it worked :)

2. Your postfix configuration is correct when it does what you want. I don't think that using the local mail command is enough to test your complete configuration: Try testing with clients and sending email from for example your hotmail account.

3. As it is the default setting (http://www.postfix.org/BASIC_CONFIGURATION_README.html#relay_from)

4. Uhh where are your MX records??? as i don't see an,y the error will continue to exist as you need an dns record to forward your abc.com to svc.abc.com. In your words this error is indeed your dns server configured wrong

5. For postfix: At least read this thoroughly: http://www.postfix.org/BASIC_CONFIGURATION_README.html
 and this is about the DNS records: http://www.ietf.org/IESG/Implementations/RFC1886-Implementation/DNSrecords.html

 

rhinocerosAuthor Commented:
Just also take a testing again
From SUSE side
# mail user1@it.abc.com  (failed)                 --> Why failed ? I need it for sending from client
# mail user1@sv2.it.abc.com  (succeeded)
# mail user1@abc.com     (To Exchange Server - succeeded)

From Exchange to user1@it.abc.com, and user1@sv2.it.abc.com (failed)


------------------------------------------------------------------------------------------

DNS setting:
- Forward Lookup Zones
   - abc.com
     - (same as parent folder)   Mail Exchanger [20]      exchange1.abc.com
     - it                                   Alias                            sv2.abc.com
     - sv2                                Host                            192.168.1.20

Reverse Lookup Zones
   - 192.168.1.x Subnet
     - 192.168.1.20                  Pointer                          it.hkqaa.org



Any idea pleae ?


Thanks !




rhinocerosAuthor Commented:
DNS setting:
- Forward Lookup Zones
   - abc.com
     - (same as parent folder)   Mail Exchanger [20]      exchange1.abc.com
     - it                                   Alias                            sv2.abc.com
     - sv2                                Host                            192.168.1.20

Reverse Lookup Zones
   - 192.168.1.x Subnet
     - 192.168.1.20                  Pointer                          it.abc.com


CompTIA Cloud+

The CompTIA Cloud+ Basic training course will teach you about cloud concepts and models, data storage, networking, and network infrastructure.

rhinocerosAuthor Commented:
One more, I can telnet port 25 on localhost, but failed to telnet from outsider ???

(I have stopped the firewall for testing)
rhinocerosAuthor Commented:
Solved

1. I don't know why "main.cf"  is not like normally linux file, it has many parameters stored at the bottom of file

...
myhostname = sv2.it.abc.com
inet_interfaces = 127.0.0.1 :: 1
mynetworks_sylte = subnet
...

The setting has been overlapped. So why I also changed inet_interfaces=all, it's still restricted interfaces on locally.


2. One more, we are able to receive mail by user1@it.abc.com as we want, when changed $myhostname = it.abc.com. So far, we think that must use fully-qualified domain name for $myhostname ($myhostname=sv2.it.abc.com). However, just look for some documents to answer my question...

-----------------------------------------------------------------------------------------------------------
My own hostname
The myhostname parameter describes the fully-qualified domain name of the machine running the Postfix system. $myhostname appears as the default value in many other Postfix configuration parameters.

By default, myhostname is set to the local machine name. If your machine name is not in fully-qualified domain name form, or if you run Postfix on a virtual interface, you will have to specify the fully-qualified domain name that the mail system should use.

Examples:

myhostname = host.local.domain (local hostname is not FQDN)
myhostname = host.virtual.domain (virtual interface)
myhostname = virtual.domain (virtual interface)

-----------------------------------------------------------------------------------------------------------

Overall, the problem was not come from Windows DNS resolving


Anyway, thanks for your help indeed !

DarthModCommented:
PAQed with points refunded (125)

DarthMod
Community Support Moderator

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.