A disk read error occurred

I've just been handed a free dell dimension 2350. When attempting to boot up I get:

A disk read error occurred
Press Ctrl+Alt+Del to restart


When I put the xp home addition disc in the cdroom and boot I get:
Press any key to boot from cd...

After I click any key I get:

Setup is inspecting your computer's hardware configuration...

Then the screen goes blank and nothing. The fan continues to run. The screen stays on. But it just sits there black...

Do I junk this thing... or, what should be my next steps? If I can salvage this, I'd be quite pleased.

Any input would be much appreciated. Thank You.

LVL 1
filibuster1015Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

ECNSSMTCommented:
obviously NOT as free as one was lead to believe.  

Well, best thing to do is check from the grounds up what is running or not.  Go into BIOS to see what you got and build from there.

Any beep sequences?

Regards,
dbruntonQuid, Me Anxius Sum?  Illegitimi non carborundum.Commented:
I'd get another hard disk for starters.

If you have an old Windows 98 hard disk available drop that in and see how that runs.

You don't have one?  Then get one, I use mine for testing suspect systems.
willcompCommented:
A more portable way to test hardware is by using a Linux boot disk such as Knoppix or Ubuntu.  If it fails to boot, disconnect hard disk.  Hard disk errors may be causing XP install to hang and Knoppix may do the same.

http://www.knoppix.org/    Click on US/British flag for English
OWASP: Forgery and Phishing

Learn the techniques to avoid forgery and phishing attacks and the types of attacks an application or network may face.

filibuster1015Author Commented:
How can I get into bios?
willcompCommented:
For most Dell PCs, press F2 during boot.
filibuster1015Author Commented:
okay,

I'm in bios... now what?
ECNSSMTCommented:
see if you can see the hard drive and memory.  If the bios can at least see it, they are presumbably good.

if not, you may have to replace the memory or hardrive.

then you can start to wipe the HD and start the install of your OS.

Regards
filibuster1015Author Commented:
How do I see the hard drive and memory?

Could you give me step by step? I've never been in bios before.
jimmymcp02Commented:
Ok if you are in the bios you should see primary hard drive and if it says none then the hard drive is either bad or somehow it got disconnected if hard drive is listed as none or no hard drive then open your pc and unplug the IDE cable and plug it back in then reboot and go into  bios if not listed then we are looking at a bad hard drive (also make sure that there is power going into the hard drive.

But if the HD is listed on the bios then we might be looking at a defective hard drive or a dirty CD please try clean the cd and if you still get the same result post back well  take it from there
filibuster1015Author Commented:
where should i see primary hard drive? In:

Main
Advanced
Security
Power
Boot
Exit

???
filibuster1015Author Commented:
Under advanced I see:

IDE Configuration
Primary IDE Controller (enabled)
Secondary IDE Controller (enabled)
IDE Drive UDMA (enabled)

IDE Primary Master [wdc wd 400BB 75DEAD]
IDE Primary Slave [none]
IDE Secondary  Master [Verbatim 321240A2]
IDE Secondary Slve [Compaq DvdramPRD]


Does that mean anything? Perhaps this is what you were asking about?
nobusCommented:
IDE Primary Master [wdc wd 400BB 75DEAD]    --<<-- your hard disk C:
IDE Primary Slave [none]                        
IDE Secondary  Master [Verbatim 321240A2]    --<<--second disk
IDE Secondary Slve [Compaq DvdramPRD]    --<<--   dvd player

i would disconnect everything not needed for the install, so keep only the C drive, and the DVD drive.
remove lan cards and modems, and disconnect printters etc from the PC
then install.
filibuster1015Author Commented:
When you say disconnect - do you mean literally take them out of the computer, or disenable them somehow in setup?

Sorry nobus, I need more literally direction here. I really don't know much about this.

For instance, I'm wonderinng... if I "disconnect" the secondary master, doesn't that mean that the secondary slave will stop working? I suppose I'd have to move the dvd player up so that it's no longer the slave???

When I began this process the lan card and modem card was removed and so I put it back in. You're suggesting I take it back out; which, I'm willing to do. Now, the printer... do you mean for me to take the card out, or just detach the cord? Because, I have no printer hooked up at this point. Just... a monitor and keyboard. The printer port looks to be directly off the mother board, so I'm not sure I could take it out anyhow. The only "card" is the lan card. Everything else looks to be off the motherboard.

I could take out the cd player though, if you think that will help.

So... thanks for the info, but please clarify.
nobusCommented:
disconnect = no connection; physical remove it, if not possible disable in the bios

>>  I'm wonderinng... if I "disconnect" the secondary ...  << just disconnect it, you should not wonder, it continues to work
filibuster1015Author Commented:
Okay, I have disconnected the lan, the cdrom, and the floppy drive. Is there anything more I should disconnect? I don't see any other connections within the casing of the computer, but maybe I'm missing something.

The IDE Configuration now reads:

Primary IDE Controller (enabled)
Secondary IDE Controller (enabled)
IDE Drive UDMA (enabled)

IDE Primary Master [wdc wd 400BB 75DEAD]
IDE Primary Slave [none]
IDE Secondary  Master [Verbatim 321240A2]
IDE Secondary Slve [Compaq DvdramPRD]

After changes to Peripheral Configuration I now have:

USB Controller (disabled)
IntegratedAudio (disabled)
Integrated Network Adapter (disabled)
Serial Port (disabled)
Parallel Port (disabled)

My Diskette Configuration now shows the controller as disabled as well.


My boot attempts continue to fail out as they had previously. Now what?
nobusCommented:
it still shows everything connected :
IDE Primary Master [wdc wd 400BB 75DEAD]
IDE Primary Slave [none]
IDE Secondary  Master [Verbatim 321240A2]
IDE Secondary Slve [Compaq DvdramPRD]

what is listed in the boot section ? set it first to cd drive, second hard disk
filibuster1015Author Commented:
Sorry, that was a typo. I meant:

IDE Primary Master [wdc wd 400BB 75DEAD]
IDE Primary Slave [none]
IDE Secondary  Master [none]
IDE Secondary Slve [Compaq DvdramPRD]

In the boot section, cdrom is listed first and the hard diskis listed second.
nobusCommented:
Good - then put the XP install cd in; it should boot from it
you sure it is a bootable XP install cd  ? ?
nobusCommented:
otherwise, download the ultimate boot cd, burn it onto a cd (it contains a lot of tests for ram, disk, etc...) and it is bootable.
you can also test if the pc you work on now can boot from the XP cd (to verify it is bootable)
If it is, and the other pc cannot boot from it, here your choices :
-bad cd drive
-bad ide cable
in each case : try another one.
filibuster1015Author Commented:
I'm sorry to say that it will still not boot from cd. The screen goes blank after the on-screen messege, "Setup is inspecting your computer's hardware configuration..."


I tested the xp home edition cd on the computer i'm now using to see if it would boot up with it and it worked without a problem.

I disabled the dvdrom and enabled the cdrom, but I get the same error. What's the chance both the dvd and cd drives are bad? Might that then indicate that the cable is bad?

I ran the drive diagnostic utility on primary ide and it passed. hmmm... thoughts?
willcompCommented:
Try completely erasing (wiping) hard disk.  This is a free, simple program that I recommend along with DBAN.  KillDisk is limited to one pass and that's all you need.

http://www.killdisk.com/downloadfree.htm

The WD Diagnostics will allow you to low level format (zero fill) the drive which serves the same purpose.
filibuster1015Author Commented:
Hi willcomp,

I'm willing to try that. How do I wipe the disk? Is there a way to do it without killdisk?

Otherwise I will have to put it on a floppy and I would have to reconnect the floppy drive of my computer, right?
willcompCommented:
It has a bootable CD version in iso format.
filibuster1015Author Commented:
can you recommend a free software program which will enable me to burn iso?

I don't have nero as is suggested by the readme file.
willcompCommented:
What about Easy CD Creator or some other burning software?  If not, here's help:

http://www.petri.co.il/how_to_write_iso_files_to_cd.htm
filibuster1015Author Commented:
ok... i have the killdisk boot cd ready...

Now I should wipe the disk? Then what?
willcompCommented:
Install XP.
filibuster1015Author Commented:
The machine freezes just after the messege, "Setup is inspecting your computer's hardware configuration..."

I even tried installing windows me and it too froze. I started windows setup from cd-rom and then received this messege:

This driver is provided by Oak Technologies OTI-91x ATAPI CDROM device driver RevD91x0352
Copyright Oak Technologies Inc. 1987 1997

Device Name: OEMCD001

At that point it froze up. I tried installing ME from the other rom drive, but it behaved the same way.

I don't get it...
willcompCommented:
OK.  We should have eliminated hard disk as source of error.  Assume KillDisk ran without errors.

Next you need to test memory.  Either download the UBCD (recommended) or Memtest86+ and burn to CD.

http://www.ultimatebootcd.com/
http://www.memtest.org/

UBCD includes Memtest and a number of other handy utilities/diagnostics.

What we're doing is taking one step at a time either eliminating or identifying possible causes.  Be patient, we'll get it sorted out.

Are there any PCI cards installed?  If so, remove them.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
filibuster1015Author Commented:
Well, I opened killdisk again and I did a scan of the drive and it still showed all the contents of the disk. I must have done something wrong with wipe disk. I am trying it again and I'm still not convinced it is working correctly.

When I select KillDisk and type "ERASE-ALL-DATA" the computer beeps and then it takes me to the erase session screen and sits without doing anything. It reads "Total number of erased devices, partitions: 0

When I escape from that screen it says "Refresshing devices and drives". If I scan the drive again, it still shows all the files on the hard drive - yet I expect that it will be clear. What am I doing wrong here?
filibuster1015Author Commented:
I have the ultimate boot cd prepared and ready to go. There are no pci cards currently installed. I removed the lan card at the start of this process.

Now what?
filibuster1015Author Commented:
willcomp, are you there?
dbruntonQuid, Me Anxius Sum?  Illegitimi non carborundum.Commented:
Start the computer from the UBCD.  Choose the first option available which should lead you to the memory tester.  Let the memory tester cycle through the tests at least three times to determine if there is faulty memory.
filibuster1015Author Commented:
Ah... okay... well, I was waiting for it to end and I get fed up and so I stopped it at 12 cycles.

I guess that was more than enough.... I got no errors.
nobusCommented:
back again ;
if i resume : you have no access to disk or cd drives, with any program? - and memtest is ok.
-does it boot from the UBCD ?
-can you run a disk test from the ubcd ?
-can you try another disk in there?
willcompCommented:
Did memtest run through 12 passes?  No errors?

12 passes would have taken several hours.

Assume that UBCD booted without problems and you were able to test memory.  That's a good sign.

Boot from UBCD and press F2 for hard disk tools.  Left and right arrow keys scroll through menu screens.  Press right arrow, select WD Diagnostics (latest version listed) and run a through disk test.
filibuster1015Author Commented:
Willcomp,
It ran for 90 to 120 minutes... I did not count all that closely. At about an hour in I went to the dinner table. The extended WD Diagnostic disk test showed no errors.

Nobus,
I could buy a used 40gig somewhere as a test. Do you think that's worthwhile at this point? FYI, I have the dvdrom installed at this point; although I have uninstalled it and have tried the cdrom instead - no luck with that either. The floppy drive is also uninstalled.




willcompCommented:
Looks like we still have a drive with old partitions and files.  The WD diagnostics will do a low level format, try that.  Or start KillDisk again and let it run.  As best I recall, it takes somewhere between 1 and 2 hours to wipe a 40GB hard disk.
filibuster1015Author Commented:
So... I should just let it sit, and not click escape???

Funny... it should have some sort of on screen message indicating that it's at work! I'll start it now.
filibuster1015Author Commented:
hmm... interesting... i used killdisk on ubcd this time... and it actually shows disk wipe progress this time. It wasn't before... hmmm...

Perhaps this is a good sign. Once the disc is wiped, then what? I to install again? or...?
filibuster1015Author Commented:
Oh wow... look at that... windows xp now seems to install... I'm working through the install now.

hmmm... Why killdisc didn't work before, I don't know. The UBCD is great...

Thank You!
filibuster1015Author Commented:
Well willcomp...

I'm not sure why the original killdisk didn't work... but it did this time with ultimate boot. The xp install worked like a charm this time.

Thank You for your help. It seems I have a new computer now.

Thank You
willcompCommented:
Very good!  Glad to help.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Hardware

From novice to tech pro — start learning today.