Avatar of akohan
akohan
 asked on

How to restore my X back?


Hello,

I was trying to work around my laptop driver but it seems I have messed up with something! all windows (in Fedora 5) will attached to the top of the screen and I cannot see or even if Isee the menu I wouldn't be able to use them.
For instance, when I open a Terminal it goes up and attached to the left upper of my screen. If open Office then I cannot close it only I can close the text but the mainframe stays up and like a disable window.

Any solution to undo all changes?

Thanks,
Linux

Avatar of undefined
Last Comment
akohan

8/22/2022 - Mon
nedvis

Whatever you did when installing proprietary video drivers from ATI Fedora hopefully saved your previous xorg.conf file ( backup copy ) . If you're lucky enough it's still there.
Open terminal windows ( console) and login as root ( su)
Change to directory where the file is located by typing:
cd /etc/X11
then type :
ls -l
to get the file list. If there are  xorg.conf.bak  or  xorg.conf.old  file(s) try this:

cp xorg.conf.bak  xorg.conf      (or cp xorg.conf.old  xorg.conf  depending on what file you have).

then depress  Ctrl+Alt+Backspace  keys at the same time to restart X server.
See if you have any better screen resolution.
=============================================================
If that does not work you can open terminal window and login as root.
Then type:
/usr/X11R6/bin/xorgcfg
which will bring graphical video configuration interface where you can change settings for your monitor
and video card. Save new configuration and restart X server by depressing Ctrl+Alt+backspace
=============================================================
Third solution to re-create default ( and very basic) xorg.conf  file is to press Ctrl+Alt+F1 in order to get
into text mode. Type : init 3 to switch to runlevel 3 and stop X server.
Then type :
cd /usr/X11R6/bin
where text mode X configuration tool is located.
Type :
xorgconfig
and follow prompts . Make sure to select appropriate entries for your monitor and video card .
save file and  type:
init 5
to return to graphical multiuser mode.

 
 
akohan

ASKER

Hello nedvis,

Thank you. It is weird that I had restarted my system 2 times and on the third time everything was back to normal! but regarding your advice yes I did check the /etc/X11 and the xorg.conf.bak file was there but since the OS is working fine then I didn't do any thing else.

However, still one question is remaining; when I start my computer before it gets to X the part which is text and comes up with messages about hardware devices gets to 1024x768 but as soon as it gets close to graphic part it goes back to 800x600 mode.
why is that? is there any way I can keep it in high resolution even in X?

Thanks.
AKOHAN
ASKER CERTIFIED SOLUTION
nedvis

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question
ssvl

just delete the .g* in your home dir
Experts Exchange has (a) saved my job multiple times, (b) saved me hours, days, and even weeks of work, and often (c) makes me look like a superhero! This place is MAGIC!
Walt Forbes
akohan

ASKER


Thanks! but it was so strange. Before I submit the quesetion I had restarted my machine twice but no luck. Anyway, after I turned it down all setting came back!!!
so it is working just fine and the resolution problem got solved too.

Thanks all.