Link to home
Start Free TrialLog in
Avatar of masseyn
masseyn

asked on

Cannot Get SBS Exchange EMail Working

We own a domain name and want to set up email addresses on this domain on our sbs. Easyspace who host our website have configured the MX record for our companyname.co.uk domain to point to our server on 192.168.1.*. I have configured the sbs accounts to have the smtp addresses as name@companyname.co.uk as primary but the local domain name of companyname.local still exists. i can send internally to the new addresses but nothing external can be sent or received....

Our setup is a netgear router to the internet, on a bband connection. We have a SBS with 2 network connections and 10 clients.
Avatar of Jeffrey Kane - TechSoEasy
Jeffrey Kane - TechSoEasy
Flag of United States of America image

Your Server's EXTERNAL IP cannot be 192.168.1.*  That's an internal address.  The MX Record needs to be pointed to a host name and that host name needs to be pointed to your External IP.  For more info, you can review http://sbsurl.com/pop2smtp

Also, you'll find that www.mxtoolbox.com can help you make sure that your ISP has configured things right.

Then, you don't configure the email addresses manually in SBS.  You need to do this by running the Configure Email and Internet Connection Wizard (CEICW -- which is linked as Connect to the Internet in the Server Management Console > Internet and Email)

A visual how-to is here:  http://sbsurl.com/ceicw and a full networking overview for SBS is at http://sbsurl.com/msicw

Jeff
TechSoEasy
Avatar of masseyn
masseyn

ASKER

so do i need to point the isp MX record to my internet gateway address from my router.... 80.*.*.*.... as i have a router in between my server and the internet
Avatar of masseyn

ASKER

I ran my domain name against the mxtoolbox and got this result !!!!!

RESULT: mail.blinkinglamp.co.uk
Banner: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond
Connect Time:  
Transaction Time:  
Relay Check:  
Rev DNS Check:  
GeoCode Info:  
Session Transcript:

Any ideas ????
The MX record nees to point to your STATIC IP address, not the internet Gateway Address.  If you don't have a staic IP address then you need to use a dynamic dns service.  Full instructions are in the http://sbsurl.com/pop2smtp link I provided above.

Jeff
TechSoEasy
Avatar of masseyn

ASKER

Ok i have now got mail being received, i set the mx record to my internet address and just port forward smtp port to my server.... now i cannot send mail to a new address, if i reply to a mail it works fine, it just doesnt work for new addresses......
ASKER CERTIFIED SOLUTION
Avatar of Jeffrey Kane - TechSoEasy
Jeffrey Kane - TechSoEasy
Flag of United States of America image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Avatar of masseyn

ASKER

Problem now resolved. It appears its just an issue sending to gmail for some reason.... The reason behind the initial issues where that i needed to point the isp mx record at my internet address and enable port forwarding for smtp to my server address. this resolved all mail issues. When i ran the wizard after this my mail accounts all setup perfectly.

Thanks for your help TechSoEasy...