Avatar of mrmyth
mrmyth
Flag for United States of America asked on

Centos User Interface

I would like a user interface for my Centos. Is there a way for me to run a command that will install it for me?

It is online, but it has no CD drive. I installed Centos originally by putting the hard drive in another computer first.

Linux

Avatar of undefined
Last Comment
nedvis

8/22/2022 - Mon
nedvis

What version CentOS do you have?
Depending on your operating system version you'll have to configure installers, package managers and
repositories ( installation files sources: e.g disk image, networked drive, FTP server  etc. )

nedvis
 
mrmyth

ASKER
I have version 4.4

It seems like there would be a simple way to download ui and install it.

I can do the yum update and update my system. Can't I just load and install the ui?
xDamox

Hi,

As root type:

yum groupinstall KDE

Then once that is instaleld type:

startkde
This is the best money I have ever spent. I cannot not tell you how many times these folks have saved my bacon. I learn so much from the contributors.
rwheeler23
nedvis

That's it :  yum groupinstall  will to the magic , as xDamox posted
yum groupinstall gnome   would  install gnome desktop.

mrmyth

ASKER
The groupinstall KDE installed fine but when I type startkde it says

xsetroot: unable to open display ''
xset: unable to open display ""
ksplash: cannot connect to X server
kdeinit: Aborting. $DISPLAY is not set.
Warning: connect () failed: : No such file or directory
ksmserver: cannot connect to X server
startkde: Shutting down
Warning: connect () failed: : No such file or diretory
Error: Can't contact kdeinit!
startkde: Running shutdown scripts...
startkde: Done
xDamox

Hi,

Do you have xorg installed?

rpm -qa | grep xorg
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
mrmyth

ASKER
Okay. So I tried that and I still get the same error. I also installed gnome to see if that would work.

Should I try starting Gnome?
ASKER CERTIFIED SOLUTION
nedvis

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question
mrmyth

ASKER
I'm in that directory /usr/bin/X11 and xorgconfig isn't working.

The directory is there and has files in it.

but when I try to run xorgconfig it says command not found

I also did the init as roon and it gave me 0123456SsQqAaBbCcUu

What does it mean?
nedvis

..."and xorgconfig isn't working"
That's because your xterm and bash PATH environment variable for user root
aren't set yet or differ from path varibales set for full GUI and/or other users.
Try typing ( as root) full path to the executable file as follows:
/usr/bin/X11/xorgconfig

"I also did the init as roon and it gave me 0123456SsQqAaBbCcUu"
Sorry my wrong, to get an info on what runlevel you're in type:
/sbin/runlevel
 
All of life is about relationships, and EE has made a viirtual community a real community. It lifts everyone's boat
William Peck
mrmyth

ASKER
Ok I found out that I'm on level N 3

I then tried the /usr/bin/X11/xorgconfig and it wouldn't find that file, so I just went ahead and typed init 5 and Centos handled the rest for me. It had a problem with the graphics and then solved it for me.

I am now at the CentOS UI desktop. I don't know what ui it is but this is looking good. I'll report back when I give it a test drive.

mrmyth

ASKER
It seems to be Gnome that is running.
nedvis

 I'm glad to hear you managed to get into full GUI mode.
  What happened , actualy, your system is booting into runlevel 3 by default so there was no opportunity
for HAL to detect video card and generate basic xorg.conf file.
First time you switched to runlevel 5 system did that and you only have basic video setting right now.
To get your hand on more granular display settings tool you'll need system-config-display package.
  And here, I have to apologize one more time , I've totally forgot CentOS is RedHat/Fedora  based distribution and as such they're using their own tools for system-wide X configuration ( so it's not xorgconfig) but their system-config-display  script that obfuscates and hides native xorg tools.
So , as long as you have access to rpm sources via YUM, please run command:
yum install system-config-*
to get all graphical tools you'll need soner or later in order to further tweak your system.
Here's the list of RedHat unified system-config- tools you can use in both Gnome or KDE environment.
system-config-authentication
system-config-network  
system-config-printer-gui
system-config-boot    
system-config-network-cmd  
system-config-printer-tui
system-config-cluster
system-config-network-gui
system-config-services
system-config-lvm
system-config-network-tui
system-config-netboot
system-config-printer

Also you can change default runlevel you CentOS will boot into by changing the line :
id:3:initdefault:  
to
id:5:initdefault:
File is located in /etc folder and you can use gedit or nano or pico textprocessors to do that.

thanks
nedvis
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
mrmyth

ASKER
That is great of you to follow up like that. There is just one thing I don't understand about it:

What is the file called where I change the id:3:initdefault:
to
id:5:initdefault

nedvis

I don't know what's wrong with me Today? ( BTW, I took sick day Yesterday)
As you may have found it , the file is   INITTAB

 good luck
  nedvis


mrmyth

ASKER
That worked great. I think you did a terrific job. Take care of yourself.

Experts Exchange is like having an extremely knowledgeable team sitting and waiting for your call. Couldn't do my job half as well as I do without it!
James Murphy
nedvis

It was a pleasure.
Thank you
nedvis