Link to home
Start Free TrialLog in
Avatar of glenj1978
glenj1978

asked on

Domain name conflict? Router?

I'm helping out at a school that just had a catastrophe. One of the servers dropped dead -- this thing was being used a proxy server for the internet. It had Microsoft ISA server on it, SurfControl, all kinds of stuff. I don't know why they did that, I would have used a Sonicwall appliance or something, but anyway, what I did, to at least get them back in business so they could read their email, was buy a $90 Linksys cable modem router. It works fine. But there's a quirk.

For reasons I don't know, the domain name on the domain controller is exactly the same as the school's internet domain name (hosted on the outside). So, when you fire up a web browser, and type www.whatever.org, you can't get to it. And I think its because the name of the domain on the server is whatever.org! If you do a tracert, whatever.org translates to the IP address of the domain controller, not the internet IP address. What do I do to fix that?

Now, I must say, that this did NOT happen when that proxy server was alive. So, there must have been some setting on it somewhere that figured this out. Of course, I never had the opportunity to examine it before it dropped dead.

I plugged the cable modem into the "internet" port on the cable modem router. I plugged the router into one of the ports on one of the network switches. I reserved an IP address for it in DCHP on the domain controller (192.168.124.10) . In the router's settings, I gave it a static IP address of the same. The router is not being used as a DHCP server.

On the client desktops, I set the TCP/IP properties of the nic card to use 192.168.124.10 as the DEFAULT GATEWAY.

Again, it seems to work fine, except for the confusion between the two domain names. I guess I need to know how to tell the network to point whatever.org to outside. I -SURE- don't want to rename the internal domain name to something else, because I really don't want to go around to 250 computers rejoining them to a new domain.

Please tell me what I missed???

Glen
Avatar of Les Moore
Les Moore
Flag of United States of America image

Is the Domain controller the primary dns for the lan also, or was the 'dead' server the primary DNS for the clients? If it was the ISA server, there may have been A records or hosts files that resolved properly.
Check the current primary dns server and see if it has A records for www.whatever.org that point to the proper IP for the server.
Else, try a hosts file on a local machine - just to see if it works.
Avatar of glenj1978
glenj1978

ASKER

The domain controller is also the primary DNS for the lan.

This has got to be a DNS thing somewhere. How do I get this to work??
ASKER CERTIFIED SOLUTION
Avatar of Keith Alabaster
Keith Alabaster
Flag of United Kingdom of Great Britain and Northern Ireland image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Hi Keith ...

When I do an nslookup, I get the internal IP address.

The web site is hosted externally with an ISP.

There is no www entry on the server. When I go into DNS, all that is there is the lan domain, that's it.

Also, when I look at the DNS events, I see this:

The DNS server encountered a packet addressed to itself on IP address 192.168.124.254. The packet is for the DNS name "www.whatever.org.". The packet will be discarded. This condition usually indicates a configuration error.


So, I guess I'm right about it coming back to itself, I just need to know how to get it out the door! :)
OK. Can you create an A record in the DNS server called www and give it the external IP address?

Alternatively, as a test you could follow lrmoore's good suggestion from above and add an entry to the hosts file on a workstation just as a test with the fully qualified domain name and the external IP address.
What I wound up doing was putting www.whatever.org into Forwarders in the DNS record and the IP address I gave it was the DNS server of our ISP. That worked good.