Avatar of manifestit
manifestit
 asked on

activesync 4.2 WM 5.0 and a support code: 85010004

Hello Experts.

I have SBS2003 and exchange 2003 (sp2) activesync 4.2 and windowsmobile 5.0

Im am trying to connect a HP IPAQ to the business network but when i
try to sync (using activesync 4.2) i keep getting stuck with this error
code:  85010004 and on my PPC it asks for a Password. The odd thing is
that there is another user who can connect no problem...?!


Right I KNOW that SSL has been configured correctly, the security
settings are correct, the certificates are up to date. Its not a global
setting becuase other member of the company can acess and snyc with no
problems and both users have the same rights.


I've gotten completly stuck on this, any suggestions would be *greatly*
appreciated.

ManifestIT
Smartphones

Avatar of undefined
Last Comment
DarthMod

8/22/2022 - Mon
Mikal613

Open up Exchange System Manager -> Global Settings -> Mobile Services

Righ click -> properties

Open Device Security. Uncheck all options in this panel. Close the panel.

As long as your Certs are in order, the synch should work.

And

setting up a new Virtual Directory for
Activesync, 2) Only allowing the server's IP address(s) access to the
directory, if the server had 1 or more IP addresses you need to allow
all of them. you can also  disable and reenable the account in Active
Directory users and Computers and that seemed to fix it.
Mikal613

manifestit

ASKER
Thanks for your reply.

It transpired that the SBS2003 Server had been installed a while ago and patched to the latest Service pack (with a bunch of other updates thrown in courtesy of MS!)

I had to copy the exact seting for directory security and access for the virtual directories from a virgin SBS2003 built with SP2, this helped but did not correct the problem.  I also discovered that I had to then recreate the exchange-oma virtual directory as described in MS KB817379 method 2.

NOTE: for those of you facing the same problem you must also delete the registry key HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MasSync\Parameters (string value ExchangeVDir) that exists, then recreate it as per the KB Article.

Another tip is to unrestrict the access on the OMA virtual directory and then using a web browser attempt to access it, if you can't then the logon to the exchange virtual directory from OMA is not working, what you should see is a list of items down the left top of the web browser.  If you get an error message then it ain't working!

It's also worth noting that the default domain should be entered on the appropriate virtual directories as well, for instance the SBS2003 server in question had a domain of city.company.local I simply used the city field for the domain.

I have struggled long and hard to fix this problem and have now documented the exact setting for all the virtual directories under the default website that are affected.

All is now well and OMA is working just fine. Phew!
This is the best money I have ever spent. I cannot not tell you how many times these folks have saved my bacon. I learn so much from the contributors.
rwheeler23
ASKER CERTIFIED SOLUTION
DarthMod

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question