Avatar of bdhtechnology
bdhtechnology
 asked on

Exchange Server corrupted database files

So the other day the someone unplugged (by accident) the power to the exchange server and it hasn't been right since.  The first error message that I got when trying to mount the store (both pub and priv) was:
The database files in this store are corrupted.
ID no: c104173b
Exchange System Manager

Unfortunately I didn't have a backup (that will be the first thing I do after I fix the problem), so I did some searching around on the Internet and found some information about eseuitl.  So then I ran eseutil /p, then eseutil /mh and then eseutil /d on both the priv & pub edb files.  It said that it fixed some errors (595 (JET_wrnDatabaseRepaired, Database corruption has been repaired) ) on both databases, so I thought it would good to go, but alas it is not.  So the error message I get now when I try to mount either store is:
An internal processing error has occured.  Try restarting the Exchange System Manager or the MSE IS service, or both.  Examine the App Log for events related to this error.. blah blah
ID no: c1041724
Exchange System Manager

So I looked in the app event log and I see these errors Event ID: 494:
Information Store (5652) First Storage Group: Database recovery failed with error -1216 because it encountered references to a database, 'D:\Program Files\Exchsrvr\mdbdata\priv1.edb', which is no longer present. The database was not brought to a Clean Shutdown state before it was removed (or possibly moved or renamed). The database engine will not permit recovery to complete for this instance until the missing database is re-instated. If the database is truly no longer available and no longer required, procedures for recovering from this error are available in the Microsoft Knowledge Base or by following the "more information" link at the bottom of this message.

Followed by Event ID 454:
Information Store (5652) First Storage Group: Database recovery/restore failed with unexpected error -1216.

Followed by Event ID 9518:
Error 0xfffffb40 starting Storage Group /DC=net/DC=*****/CN=Configuration/CN=Services/CN=Microsoft Exchange/CN=*****/CN=Administrative Groups/CN=First Administrative Group/CN=Servers/CN=******/CN=InformationStore/CN=First Storage Group on the Microsoft Exchange Information Store.
Storage Group - Initialization of Jet failed.

There isn't a whole lot of data (in fact nothing in the pub files at all I believe) just calendar, contacts, notes, etc.  Nothing in the inboxes, just sent items.  And there are only four users.  I just would like to recover the data somehow.  I should have access to the .ost files for all the users if that would help at all.


Thanks for any help!
Exchange

Avatar of undefined
Last Comment
Expert-Solutions

8/22/2022 - Mon
ASKER CERTIFIED SOLUTION
rakeshmiglani

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question
bdhtechnology

ASKER
They were both set to clean shutdown, so I removed the log files and mounted the stores successfully!

Thanks for your help!
Milton1626

i ran the eseutil /mh and came back with a dirty shutdown, what should i do ?
thanks for you help
Expert-Solutions

eseutil /p locationofyour\priv1.edb
eseutil /d locationofyour\priv1.edb

Worked for me
Experts Exchange is like having an extremely knowledgeable team sitting and waiting for your call. Couldn't do my job half as well as I do without it!
James Murphy