Link to home
Start Free TrialLog in
Avatar of merhi2405
merhi2405

asked on

USB Drive not accessible

Hi,

When I stick in a USB drive it shows up in the taskbar as the little green arrow icon (to remove) but does not show up in "My Computer" nor is it accessible through the "run" dialog if I type: "e:".

We have disabled access to the C: drive on this computer but that shouldn't affect removable drives right?

btw: I'm sure the usb drive works, I've tried it on another computer.

Thanks
Avatar of chalapa
chalapa

yes it will effect to removal disk also just enable to access all drives then try, if not also just right click on my computer and slect manage then select diskmanagement you can find your removal disk, you can assign drive letter it will come automatically in your my comouter
Avatar of matrixnz
Hi Merh

If the computer is on a domain, the USB drive can be given the same Drive letter as a mapped drive and as Chalapa pointed out, go in to computer management by:
Click Start
Click Run
Type: compmgmt.msc
Click OK
Expand Storage
Select Disk Management
Right Click your Removable Drive
Select Change Drive Letters and Paths..
Change to a Drive letter that hasn't been used.

Hope that Helps

Cheers
Also you need to make sure that there aren't any policies which blocks you to access USB, please check with your network administrator. Also for running Computer Management.

I normally change the drive letter of my CD ROM which is E: by default to some other and then E: drive becomes usable for USB drive.
ASKER CERTIFIED SOLUTION
Avatar of johnb6767
johnb6767
Flag of United States of America image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Does it even show itself in Disk Management? If not does it show properly in the Device Manager?