Avatar of Gavin Tech
Gavin Tech
Flag for United Kingdom of Great Britain and Northern Ireland asked on

My new pc does not register the full speed of the processor within System Properties-General(tab)?

I have just recieved my custom built be which does not have an o/s installed.

The pc contains a MSI P965 NEO motherboard and a Intel Core 2 Duo E6600 (2.4ghz) processor and 1gb of ddr2 667mhz ram and a Geforce 7600gt video card.

After loading the Windows XP SP2 o/s it seemed unusually slow for a pc of this spec.

I checked in My Computer-System Properties and it states that I do have the processor specified but to the left of where the ram is written it states the processor is running at 1.58ghz. This cant be right can it.

I called back the store I bought it from and they said that because the pc is custom made it has not been configured and that I will have to use the bios to put the processor to the right speed myself. Or wait at least a week for an engineer to call me to tell me what to do. I would rather not wait but im not sure where to start and do not want to ruin the pc by doing the wrong thing.  

Please can and expert help me resolve this issue.

Also(correct me if I am wrong):

I thought no configuration would be needed as the motherboard bios would automatically change to the processor or ram I install.

Could the hardware be faulty.



HardwareComponents

Avatar of undefined
Last Comment
Callandor

8/22/2022 - Mon
harbor235

Perhaps you have an incorrect bios configuration, most times bios settings are set to default values. You may need to changed the FSB, and multiplier for your particular chip.

1) Gather information on your chip
    a. Speed
    b. FSB setting
2) Check bios settings of your motherbard, some board have auto configure
    but they do not always optimally configure them.

Sounds like bios settings.

harbor235 ;}
Callandor

I agree - the E6600 has a multiplier of 9 and should be running on a motherboard FSB of 266 (DDR at 533).  It seems to be running at a motherboard FSB of 175 (DDR at 350).  Download and run Everest and you will be able to see your FSB and RAM settings: http://www.majorgeeks.com/download4181.html
enfz

Sounds like the speedstep technology of the E6600 kicking in, it lowers the multiplier in order to reduce the speed/heat etc when it is not in use. See if your bios has to option to disable it, though many may not. Goto the power properties, and select a power scheme other than Portable/Laptop to disable the 'EIST' command

Quote from Anandtech -
"However, once you disable it in the BIOS you will need a program like RightMark CPU Clock Utility from http://cpu.rightmark.org/products/rmclock.shtml to turn off C1E. It will be in the Advanced tab. I don't know why C1E is not in the BIOS but it may show up in a later version of the BIOS. To get maximum speed for performance measurements, you must turn OFF EIST and C1E."

Hope this helps :)
Your help has saved me hundreds of hours of internet surfing.
fblack61
ASKER CERTIFIED SOLUTION
jamone

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question
Gavin Tech

ASKER
Jamone

Sorry for the late reply. There have been a few problems in my family.

I have downloaded and installed CPU-Z and you are correct, it states 1596mhz , bus speed of 266mhz and a multiplier of x6.0 as you predicted.

I have also downloaded SuperPi but am not sure how to use it to increase the multiplier.
Can you help me out here?
Callandor

If this is all caused by SpeedStep, you don't have to do anything, unless you don't want it to slow down when idle.  I have an E6600 and SuperPiMod runs in 22 seconds to calculate a million digits.