Avatar of daly29
daly29
Flag for United Kingdom of Great Britain and Northern Ireland asked on

Lost RDP connection to 2003 server

Hi

I recently had to reinstal my network adapter and since then I have lost RDP access to my server.

I tried telnet to port 3389 and it wont connect

ran netstat and it is not listening on 3389

There is no firewall to block the connection. I have checked that the terminal server service is running fine and that RDP is enabled in remote settings for administrators.

Could anyone please help with this as I need to get this running asap

Regards

TD



Windows Server 2003

Avatar of undefined
Last Comment
daly29

8/22/2022 - Mon
trenes

Hi daly29,

You dont wanna hear this I guess but I had a similar issue at our Amsterdam office 2x (I did install some fixes)
And later on I could not connect through RDP.
All I did was restart the server from my workstation using the "shutdown /m \\server /r /f command"
And voila I could connect... I hope another expert has a say on this.


Regards,

Trenes
rgonser

Make sure windows firewall didn't kick on somehow. I'm guessing this isn't a remote server since you said you had to re-install the NIC. Before resorting to rebooting I would check your event logs, look for a service failure or anything of the sort. And of course if you run out of options, as a last resort, a good ol' reboot seems to fix a lot of strange things sometimes.
tim1731

I had this after installing a new card (hba) and it was because the terminal server service had stopped and was set on manual
Your help has saved me hundreds of hours of internet surfing.
fblack61
trenes

1. right click on my computer, choose properties, tab [remote], and check the box allow remote connections.

If 1 doesnot work

2. Reinstall Terminal Service this can be done through add / remove programs.
daly29

ASKER
Thanks guys but I have done that lot even reinstalling terminal services has'nt worked.

My other dc is working fine and I have an Acronis image of the DC with the problem (which is my main DC)  before it happened, but it is 10 days old now I am worried If I run the Image whether or not AD will replicate over ok with such an old Image. It is a small network so there is not masses going on but I may have to resort to that.
ASKER CERTIFIED SOLUTION
garyrafferty

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question
daly29

ASKER
Thanks for reply

I am not at work till next Friday now and cant check oh how I miss RDP. But after I reinstalled terminal services yesterday I think there was only one adapter there.
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
trenes

I think the same but it definately worth a try to check gary's tip.
daly29

ASKER
Had a look in Terminal services the problem was the network selected was the wrong one Thanks gary your tip resolved the issue for me so I am awarding you the points. Thanks to everyone for your help on this.

Regards

TD