Avatar of nexsysit
nexsysit
 asked on

*** Configuring Remote Access Policy returned ERROR 80072030

I've installed Small Biz Server 2003 with all updates and service packs, I've configured all other services on SBS.
I keep on getting an error when trying to set up Remote Access from the the wizard.

9/15/2006 10:02 PM
C:\Program Files\Microsoft Windows Small Business Server\Networking\RRASWiz\wizrras.dll, version 5.2.2651.0
Calling CRRASCommit::CommitEx
Calling CRRASCommit::ValidatePropertyBag
pdispPPPBag->QueryInterface returned OK
PropertyBag 257280
Reading property value for enabling Remote Access returned OK
bRemoteAccess = 1
Reading property value for VPN returned OK
bVPN = 1
Reading property value for RAS returned OK
bRAS = 0
Calling CRRASCommit::ValidateVPNProperties
Reading VPN Server Name returned OK
VPN Server Name is magnum.nexsysit.com
Calling CRRASCommit::ValidateDHCPProperties
DHCP server is installed on the box
CRRASCommit::ValidateDHCPProperties returned OK
CRRASCommit::ValidateVPNProperties returned OK
CRRASCommit::ValidatePropertyBag returned OK
pdispPPPBag->QueryInterface returned OK
Pointer to the property bag 257280
Calling CRRASCommit::CommitRRAS
Arguments:
PropertyBag 257280
bRAS 0
bVPN 1
Getting the GUID of the private NIC returned OK
Private NIC Guid is {18D428F5-3FE3-4961-B9CA-EA9FCA822CBB}
Checking whether RRAS is already running returned OK
RRAS is not running
Installing RRAS returned OK
Dhcp server is installed and running on this box
Enabling DHCP client addressing returned OK
Configuring ports returned OK
Identifying the private NIC for RAS returned OK
Setting the default authentication methods returned OK
Disabling NETBIOS for RAS returned OK
Changing RRAS startup type to automatic returned OK
*** Configuring Remote Access Policy returned ERROR 80072030
Specifying error location returned OK
*** CRRASCommit::CommitRRAS returned ERROR 80072030
*** CRRASCommit::CommitEx returned ERROR 80072030
SBS

Avatar of undefined
Last Comment
Jeffrey Kane - TechSoEasy

8/22/2022 - Mon
nexsysit

ASKER
Found the solution ...

http://www.mcse.ms/archive215-2004-12-1264106.html

David Pressman
2004-12-05, 7:10 pm
 
 Had the identical problem and searched everywhere for days. Finally found one
post that instantly solved this error, at least for me. It seems the remote
access wizard is following a script that expects to find the "MyBusiness" OU
in AD. If you rename that OU, as I had, it always fails. Simply name the OU
back to "MyBusiness"!
If Microsoft would have this error report what the script was looking for,
but could not find, I suppose the fix would often be readily apparent. A
shame they don't! Of course, it would be even better if the 'wizard' were
smarter, and asked you what the name of your business OU is! Talk about bad
hard-coding of changeable info!
 

ASKER CERTIFIED SOLUTION
Jeffrey Kane - TechSoEasy

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question
nexsysit

ASKER
I guess that would explain why i kept on getting errors....after the first problem was fixed; i got another error

Updating CMP template returned OK
Updating CMS template returned OK
Updating SED template returned OK
Creating proxy configuration file returned OK
*** Running IExpress to build the package returned ERROR 80004005
*** ERROR: Cannot delete temp directory CMP1CD.tmp
Specifying error location (in CMAK) returned OK
*** CRRASCommit::CommitCMAK returned ERROR 80004005
*** CRRASCommit::CommitEx returned ERROR 80004005

After googling for 1/2 hr to find the solution, I found a link that said to uninstall Windows Server 2003 SP1...
so I did, health monitor did not work , so i unistalled that too.  The wizard/script for Remote Access finished w/o any errors.

I previously had all the Small Biz Sp1 installed correctly etc...,I followed the instructions from Microsofts website on how to install Small Biz SP1, not sure why i didn't have the latest wizrras.dll and some of the scripts wouldn't work...

So right now I am without Windows Server 2003 SP1 or Small Biz SP 1, should I just go through the steps again to install Smalll Biz SP1 again? or would i be better off wiping my server ( this would be a huge pain in the ....)

thanks for your help


Jeffrey Kane - TechSoEasy

You should definitely go through all of the steps to install SBS SP1.  Because if you installed JUST Windows Server 2003 SP1 without the rest, then you would receive those errors.  If you are now without SBS SP1, you never had it... as it can't be uninstalled.

There are 5 components to SBS SP1 and all must be installed for things to work.

Jeff
TechSoEasy
This is the best money I have ever spent. I cannot not tell you how many times these folks have saved my bacon. I learn so much from the contributors.
rwheeler23
nexsysit

ASKER
I ran into some more errors trying to reinstall Smabll Biz SP 1,  got through steps 1-4 , but install SP1 for Small biz has given me the following errors...

It stops about 1/4 way and a windows pops stating it has encountered an error, for more info
check the log in C:\program files\microsoft integration\window ssmall business server 2003\logs\setup.log. then correct the error and run service pack 1 setup again.

I checked the setup.log file and everything returns success; then i checked the errorlog.txt and see that it has erros the last two lines

Server Tools: [2] BCreateProcess of DUpdate.exe failed with error [3]!.
Server Tools: [2] RunOMADupdate() failed with error [80070003]

prior to that, i had to remove Outlook Client deployment and re-add it , because it had given me error about that...

I think my system is hosed, because I had installed Exchanged SP2 also.  I do recall the system having Small Business service pack 1 installed because i had checked by right clicking on my computer -> properties and it displayed Service Pack 1...

Either way , let that be a lesson to me ... should have never uninstalled Windows Server 2003 SP1 .  Going to back up data and reinstall ... Thanks for the info and your help!.

Jeffrey Kane - TechSoEasy

You should be able to find plenty of info on those:  http://snipurl.com/wjh4

Jeff
TechSoEasy