troubleshooting Question

Cannot ping from one PC to another on a network - two PC's

Avatar of harrgo
harrgo asked on
Windows Networking
23 Comments1 Solution309 ViewsLast Modified:
I am trying to "fix" a pc for a friend. He has two PC's - one with XP Pro (PCXPPro) and one with XP Home (PCXPHome)

PCXPPro cannot ping PCXPHome and PCXPHome cannot ping PCXPProRO. Both can ping the loopbak (127.0.0.1) and both can ping themselves using their IP addresses (192.168.1.11/12 and 192.168.1.14 respectively.) Both detect when the cable is plugged in and when it is removed

When I connected my laptop to PCXPHomeE the laptop could ping it and PCXPHome could ping my laptop. Thus I know PCXPHome and the cable are both working.

PCXPPRO has supposedly never been conencted to the internet.
PCXPPRO has a network card on the motherboard and a PCI network card. Both NICs have been given a static IP addresses (192.168.1.12 and 192.168.1.12) and a netmask of 255.255.255.0

There is no firewall active on the PCXPPro and the firewall/ics and routing services have been turned off.

I have checked the PCXPPro has all its network components - plus unistalled and reinstalled them, used WINXP Socket fix, LSP, and netshell commands to try to fix the TCP/IP stack.

PCXPPro had no service packs installed when I started this process - and no legal disk so he has purchased XP Pro Service Pack 2 Update Version (he had a legal Windows 98 CD) and done un update install so he is now running a legitimate XPPro Service pack 2. (We did an up date as he no longer has some of his original disks thanks to a partner taking them with her when they broke up)

I have checked for viruses with NOD32, and checked for spyware with Spybot, Adaware and Ewido. Nothing found.

I have checked there are no other firewalls installed using MSCONFIG and a shareware program called Autoruns

Three other strange things
1. Both PC's have the NWLINK protocol installed and the PCXPHome can see the PCXPPro machine in network neighbourhood when that protocol is present. If the NWLINK IPX/SPX is removed it can no longer "see" the other machine.

2. PCXPPro cannot browse the workgroup (both PC has a workgroup of MSHOME - have tried changing it on both PCs but no change to problem) It responds that "you may not have premission to access the workgroup" even though I am logged on as an administrative user (and yes - I tried all these things with a new user as well - same behaviour)

3. The "add/remove" program list for PCXPPro has a large number of entries related to a sound card that have no description and no "REMOVE" button - in fact no button of any kind. In desperation I ran Reg Repair Supreme over it but this did not resolve any of the problems.

I could do a full install and I am sure that would "fix" the problem - but there must be some other way.

Can anyone help - thanks. (Sorry it was so long winded )
ASKER CERTIFIED SOLUTION
Fatal_Exception
Systems Engineer
Join our community to see this answer!
Unlock 1 Answer and 23 Comments.
Start Free Trial
Learn from the best

Network and collaborate with thousands of CTOs, CISOs, and IT Pros rooting for you and your success.

Andrew Hancock - VMware vExpert
See if this solution works for you by signing up for a 7 day free trial.
Unlock 1 Answer and 23 Comments.
Try for 7 days

”The time we save is the biggest benefit of E-E to our team. What could take multiple guys 2 hours or more each to find is accessed in around 15 minutes on Experts Exchange.

-Mike Kapnisakis, Warner Bros