Link to home
Start Free TrialLog in
Avatar of sah18
sah18Flag for United States of America

asked on

Ubuntu: File Browser won't let me delete a folder from a mounted drive - says it is read-only

Ubuntu.  I have attached a SATA hard drive (ntfs format) to the usb port of a computer that is running Ubuntu (using a special cable that I purchased).  I was hoping to copy some files from this drive, and delete others.  When I plugged in the drive, it was automatically mounted in Ubuntu and the File Browser opened.  I could see my folders on it just fine.  I can navigate through the folders, but I'm not able to delete any of them through the File Browser.  I get a message saying it is read-only.  I opened a terminal windows and typed in mount to see how this drive was listed.  Here is what the listing showed:

/dev/sdd1 on /media/VIDEO type ntfs (rw,nosuid,nodev,uid=1000,gid=1000,umask=077,iocharset=utf8)

I thought maybe it really was mounted as read-only (ro), but it shows rw, which should be read-write.  I'm still a newbie with linux, so I'm probably missing something obvious.

What do I need to do to be able to delete files from this drive?

Thanks for your help!
ASKER CERTIFIED SOLUTION
Avatar of ravenpl
ravenpl
Flag of Poland image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
Avatar of ssvl
is you have root access
Avatar of sah18

ASKER

Is it possible to convert from ntfs to fat or fat32 from within Linux, so that I don't lose any files?
Convert - no. Backup, reformat, restore.