Link to home
Start Free TrialLog in
Avatar of vladpaliy
vladpaliy

asked on

#5.5.0 smtp;521 - EHLO/HELO from sender [ip address] does not map to [mydomain.com] in DNS

Hello,

Recently switched to another ISP. Updated the MX record with the web hoster accordingly. Now, emails to comcast addresses (in particular), result in the following:

[recepient]@comcast.net on Sun, 17 Sep 2006 21:59:47 -0700
    There was a SMTP communication problem with the recipient's email server.  Please contact your system administrator.
    <acsportland.com #5.5.0 smtp;521-EHLO/HELO from sender 64.122.41.188 does not map to acsportland.com in DNS>I'

I've looked at some related articles on google, but none seem to give me step-by-step (detailed) instructions on how to get it resolved. If anyone has any suggestions here, I would appreciate it.  Thanks.
Avatar of MNH1966
MNH1966
Flag of Netherlands image

Sounds like a problem at the recipient side.
Most likely, the TTL of your MX, A or PTR record hasn't expired yet and the server was "using" the old record from its cache.
Try again. Your DNS configuration looks okay (checked it with http://cgibin.erols.com/ziring/cgi-bin/nsgate/gate.pl?mode=1&q=mail.acsportland.com)

Hope this helps,

Maurice
Avatar of vladpaliy
vladpaliy

ASKER

Thanks.

The same problem exists with my client: mail.thejoinery.com. They are actually the ones that went through the ISP switch-over. I just happened to get exactly the same error, although to a different comcast user. So I used acsportland.com as an example. Here's what they are getting:

[recepient]@comcast.net on 9/3/2006 12:38 PM
            There was a SMTP communication problem with the recipient's email server.  Please contact your system administrator.

            <thejoinery.com #5.5.0 smtp;521-EHLO/HELO from sender 68.178.108.235 does not map to thejoinery.com in DNS>
ASKER CERTIFIED SOLUTION
Avatar of redseatechnologies
redseatechnologies
Flag of Australia image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
vladpaliy,

I should clarify that.

*A* problem is that you don't have Reverse DNS entries

That may not be THE problem, you may also want to have a look at using a smarthost for comcast - as detailed here; http://www.amset.info/exchange/smtp-connector.asp

-red
Try to speak with the ISP's...I belive that they can help you more...
No objections here, but I really hope the author would let us know what the solution was...
No problems.
Thanks redseatechnologies. I called the ISP and got them to setup the rDNS. It seems to working just fine. I also added an SMTP connector for those domains that were being rejected.