dns redirecting all pages to google.com

I've got a Win2000 server being used for dns.  It's worked fine for a few years until yesterday.  Now when you sit down at any pc using this for dns resolution and type in an address (yahoo.com, msn.com, download.com, etc) the browser hangs for a minute, then opens google.com.  Doesn't matter what page you type in, it goes to google.com.  Do a google search, click on the link, hangs again then opens a fresh google search page.  I changed the dns server on each local pc to another dns server, and it all works just fine.  Obviously the problem is with this specific dns server.  Any idea what would cause this?  And more importantly, how do I fix it?  Can I do a complete flush of it's dns files, then update from the name servers?  Thanks for any help.
LVL 27
michkoAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Bradley FoxLAN/WAN Systems AdministratorCommented:
Do you use forwarders to resolve outside domains?

Check to make sure you have no "." zone on your DNS server and that forwarders are setup correctly.

If you have another DNS server with your AD Integrated zone you can just remove DNS on the offending server and re-install it and re-create the forward lookup zone for your domain and it will grab the records from another AD DNS server.

I would also do a virus scan on the offending DNS server.
Steve KnightIT ConsultancyCommented:
Try an ipconfig /flushdns on the server, have you tried just restarting the DNS service or the whole server?

Try this:

nslookup
server ipaddress.of.dodgy.server
www.yahoo.com.
someinternalhost.yourdomain.local
exit

And see what it can resolve or not.

As has been said above it could be that the DNS servers you are specifying as forwarders (if it isn't just using root hints) don't exist any more for instance -- try them in the nslookup above to test.

Steve
michkoAuthor Commented:
Thanks guys, the ipconfig/flush did the trick.
Steve KnightIT ConsultancyCommented:
No problem.  Don't forget to choose "accept answer" next to one one of the answers or use the split points like at the bottom of the question to split..

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Networking

From novice to tech pro — start learning today.