Solved

The system administrator has set policies to prevent this installation

Posted on 2006-10-19
24
1,898 Views
Last Modified: 2010-05-18
Hi,

I'm logged in with an account that is a local admin in a Windows 2003 R2 SP1 server that is part of a SBS 2003 domain.

I'm running a .exe file that is an InstaShield Wizard to install an upgrade to a product. It extracts a few files, and then the Windows Installer window says "Preparing to install... " and after a minute or so we get this error window:

        The system administrator has set policies to prevent this installation

Now, I have been able to install other products here, particularly the previous version of the product which I am upgrading.

Any ideas?

Thanks!
0
Comment
Question by:drotkopf
24 Comments
 
LVL 3

Expert Comment

by:Stekman99
Comment Utility
Hi,

try to refresh your GPO settings like this

start --> run
gpoupdate /force

It could also be so that the upgrade is trying to install files on new placeses where u dont have the rights for.

Have u asked admin if he changed your credntials?

Cheers,
Stefan
0
 
LVL 27

Expert Comment

by:David-Howard
Comment Utility
If your administrator is pushing Group Policy to networked pc's that hold installation restrictions the administrator will have to alter policy in order for you to install the software.
0
 

Author Comment

by:drotkopf
Comment Utility
I am the administrator...

The event log is showing:

The installation of C:\DOCUME~1\icadmin\LOCALS~1\Temp\1\pft37.tmp\ServiceUpdate.msi is not permitted due to an error in software restriction policy processing. The object cannot be trusted.

As said before, I'm logging in with an account tht has local admin rights.
Also, I have installed SW before, but I don't know if using MSI.

0
 
LVL 9

Expert Comment

by:gopal_krishna
Comment Utility
This issue could have happened due to antivirus upgrade from old to new version or this can happen if your system is infected by virus :

Please check the URL mentioned below:

http://support.microsoft.com/kb/322963

Please let me know if this helped you.
0
 

Author Comment

by:drotkopf
Comment Utility
No antivirus running on that server.
0
 
LVL 13

Expert Comment

by:haim96
Comment Utility
try this:
make sure your software is on local drive (c:\)
logon with local administrator (not domain admin)
try to run the software.
worked for me once in similar situation.
0
 
LVL 9

Expert Comment

by:gopal_krishna
Comment Utility
Check if you have an admin rights for the user who has logged in. I feel that this is the issue. If you do not have the admin permission please provide the admin permission and then restart the computer and check. you would be succesed.

good luck

regards
Gopal Krishna K
0
 

Author Comment

by:drotkopf
Comment Utility
haim96 - the software is on the local drive

haim96 and gopal krishna - I am running this while logged in with a domain account that is a local admin to the server. I also tried it with the local administrator account.
0
 
LVL 4

Expert Comment

by:hclgroup
Comment Utility
If the admin is making use of restricted groups and has the local admin account in a restricted group he could effect a policy that disallows you from installing software. There is nothing you could do really but convince him/her to relax it.
0
 

Expert Comment

by:cslack1313
Comment Utility
I would remove that computer from the domain and add it to the workgroup, try running the install, if it works, you know for a fact group policies are being pushed down. After joining the domain again, run gpudate as mentioned above and look through the output given to see what polices are associated with that user/device
0
 
LVL 10

Expert Comment

by:Chris_Gralike
Comment Utility
check the settings either @

Start > Administrative tools > Local security Policy || Security policies > Software Policies

Or install the policy manager at the domain controller and generate an effective policy overview while having the OU selected in wich the computer objects reside..

Group policy management can be downloaded here >>

http://www.microsoft.com/downloads/details.aspx?FamilyId=0A6D4C24-8CBD-4B35-9272-DD3CBFC81887&displaylang=en

Regards,

0
Find Ransomware Secrets With All-Source Analysis

Ransomware has become a major concern for organizations; its prevalence has grown due to past successes achieved by threat actors. While each ransomware variant is different, we’ve seen some common tactics and trends used among the authors of the malware.

 
LVL 2

Expert Comment

by:micromarch
Comment Utility
view the policies that have been applied to your server you are logging on. I know there is a command to do so in command prompt but i dont remember it on top of my tong. I know you can also do this through windows 2003 server in active directory users and computers but I do not know about small business server though.
0
 
LVL 5

Expert Comment

by:trarthur
Comment Utility
Move the .exe out of the temp folder and then rerun the installer.
0
 

Author Comment

by:drotkopf
Comment Utility
Sorry guys, but None of the Above.

This is how it was solved:

1. Opened Local Security Policy
2. In Local Security Setting MSC, Click on Software Restriction Policies, the were "No Software Restriction Policies Defined".
 3. Right-click the Software Restriction Policies, and selected New Software Restriction Policies  
 4. Double-clicked on the Enforcement entry, to open Enforcement Properties dialog  
 5. Under "Apply software restriction policies to the following:" section, kept "All software files except libraries (such as DLLs)" options checked.
 6. Under "Apply software restriction polices to the following users:" section, changed to "All users except local administrators".  
 7. Rebooted the server.

0
 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
Comment Utility
That really wasn't necessary.  Had you logged onto your computer with a DOMAIN Admin Account it would have overridden your local policy.

Jeff
TechSoEasy
0
 

Author Comment

by:drotkopf
Comment Utility
rindi,
I had answered the question myself
Comment from drotkopf
Date: 10/24/2006 02:10PM PDT
I'll go now to http://www.experts-exchange.com/help.jsp#hs5 to have it properly closed.
Thanks!
0
 
LVL 9

Expert Comment

by:gopal_krishna
Comment Utility
Thats perfect solution drotkopf  as provided. this is applicable for Windows Vista to. If any users who have installed vista and facing this issues, please gohead and follow the same steps you would be able to resolve it and install the applications. This I faced yesterday when I addedd the test machine in my domain and try to install MSoffice and other applications.

drotkopf, Thanks for your solution, which helped me a lot in my bitter situtuation..........

Cheers
Gopal Krishna K
0
 

Author Comment

by:drotkopf
Comment Utility
I'm happy that the same way that I could benefit from someone else's solution, other people can benefit from me passing the solution on.
0
 
LVL 87

Expert Comment

by:rindi
Comment Utility
OK, so please accept the answer(s) that gave you the solution and close the Q.

Thanks
0
 

Author Comment

by:drotkopf
Comment Utility
Rindi, I answered the question!

Comment from drotkopf
Date: 11/15/2006 12:23PM PST

Comment from drotkopf
Date: 10/24/2006 02:10PM PDT
0
 
LVL 87

Expert Comment

by:rindi
Comment Utility
Actually you could have asked for a PAQ/Refund, the "PAQ" as opposed to a "Delete" will stay in the EE Database for future references. But anyway, since you posted in the Support TA, the moderator will post a query here shortly asking whether the other experts are OK with a refund, and then we can ask for a PAQ. Anyway, you followed the official way which is good...
0
 
LVL 1

Accepted Solution

by:
DarthMod earned 0 total points
Comment Utility
PAQd, 500 points refunded.

DarthMod
CS Moderator
0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

Suggested Solutions

Introduction How to create multiboot configuration with XP\Vista and Windows 7 on it? And most important question - how to do this correctly so not to have any kind of nightmares we get when system gets screwed? First of all one should realize t…
Many people tend to confuse the function of a virus with the one of adware, this misunderstanding of the basic of what each software is and how it operates causes users and organizations to take the wrong security measures that would protect them ag…
Polish reports in Access so they look terrific. Take yourself to another level. Equations, Back Color, Alternate Back Color. Write easy VBA Code. Tighten space to use less pages. Launch report from a menu, considering criteria only when it is filled…
You have products, that come in variants and want to set different prices for them? Watch this micro tutorial that describes how to configure prices for Magento super attributes. Assigning simple products to configurable: We assigned simple products…

771 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

7 Experts available now in Live!

Get 1:1 Help Now