Solved

PS$ Published app only launches with Citrix Admin or Domain Admin User and Password

Posted on 2006-10-19
7
784 Views
Last Modified: 2008-03-10
Hi Everyone,

I am using Presentation Server 4 with Advanced Access Control and Citrix Access Gateway with a single farm server. I have several published applications and all launch fine except for one. The application that will not launch except with Domain Admin logon is an accounting application.

The app has the appropriate users in the the published app properties. The startup directory has the appropriate security and user access. The application will launch fine if I use the Domain Admin user logon. This same logon is also the data store logon for SQL. I don't think that it is a permission issue because I set up another user and gave that user all of the Domain authority and that user could not launch the app?

Any one have any thoughts on this issue?

Thanks!
0
Comment
Question by:w7kr
  • 4
  • 3
7 Comments
 
LVL 19

Expert Comment

by:BLipman
Comment Utility
Well, you could use RegMon and FileMon to see what the security issue/rights issue might be...otherwise you need to give up some more info.  Anything logged in the event viewer regarding this?  

RegMon - http://www.sysinternals.com/Utilities/Regmon.html
FileMon - http://www.sysinternals.com/Utilities/Filemon.html
0
 

Author Comment

by:w7kr
Comment Utility
Nothing logged in the event viewer. I have tried Filemon and nothing stuck out. I was looking for "access denied" or something similiar. I also ran Regmon and could see all of the keys that were being accessed. I need to study both of these a bit further.

The key here is why this one user can launch the app just fine? So, you would think that it would be a permissions or rights issue, but I haven't nailed it down yet.

Thanks!
0
 
LVL 19

Accepted Solution

by:
BLipman earned 250 total points
Comment Utility
Remember, regedit won't show permissions; for that you need to use Regedt32 and use Permissions from the 'View' menu.  Good luck and keep posting your status.  I will try to think of more to try!
0
How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

 

Author Comment

by:w7kr
Comment Utility
BLipman - Thanks,

I might not get back to this until Monday. I will post the status after I try a few things. Thanks for your help!
0
 

Author Comment

by:w7kr
Comment Utility
OK - Latest update.

If I change the logon to anonymous in the Users area of the application launch permissions, the application will launch but then fail to connect with the ODBC connection because it passes the logon through to the application and the anonymous user is not a valid NT login for the ODBC connection. It tried changing the ODBC DSN to SQL authenication, but same issue. I assume that it is using the DSN being used to launch this application is on the Citrix server which is where I am starting the application from?

So, a anonymous user can start the app but an authenicated one can't? Insead of using groups, I entered the individual user in the application launch properties, but same issue?

Thanks!
0
 

Author Comment

by:w7kr
Comment Utility
I believe that the issue is now resolved. All remote users needed to have logon authority in SQL Server for the database being used by the accounting application. I ran across this today through a process of elimination.

BLipman - I will reward you with the points since you had several suggestions and were the only one who responded.

Thank You!

0
 
LVL 19

Expert Comment

by:BLipman
Comment Utility
Thanks for the points, I am really glad you figured out what was happening!
0

Featured Post

Maximize Your Threat Intelligence Reporting

Reporting is one of the most important and least talked about aspects of a world-class threat intelligence program. Here’s how to do it right.

Join & Write a Comment

Citrix XenDesktop 7.6 Citrix Policies Disable Peripherals
Citrix XenDesktop 7.6 Citrix Policies Audio
How to install and configure Citrix XenApp 6.5 - Part 1. In this video tutorial we have explained step by step installation of Citrix XenApp 6.5 Server on Windows Server 2008 R2 is explained in this video. We have explained the difference between…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

10 Experts available now in Live!

Get 1:1 Help Now