Solved

Crystal Reports and InfoView - Don't see my Prompts

Posted on 2006-10-19
10
561 Views
Last Modified: 2008-02-01
Experts-
I am using Crystal XI. I used the Publishing Wizard to add several reports to the system. All seemed to go smoothly. I can view my reports with the default data in InfoView. However, I am not being prompted with the report prompts (e.g., enter a date). If I run my reports in Crystal Developer, I can refresh to invoke being prompted. But, I don't see the ability to do so in InfoView.


What am I misisng?
0
Comment
Question by:DataDesignIT
10 Comments
 
LVL 13

Expert Comment

by:crgary_tx
ID: 17769439
Open the report object in the infoview
Click on the schedule
Expand Parameters (you will find this if you are using parameters in the report)
Enter the parameter values and schedule the report

Hope this works..

Gary
0
 

Author Comment

by:DataDesignIT
ID: 17769487
Gary-

I did the steps you described, saw my parameter, entered it, and successfully scheduled the report. However, when I run the report separately (calling it via a URL), I'm not being prompted at run-time (that's what I'm ultimately needing) for a new date value. I want to be prompted each time the report is called via the URL.
Thanks.

0
 
LVL 13

Expert Comment

by:crgary_tx
ID: 17769530
I guess you need to set the option to prompt for the param somewhere..may be in CMC. Lemme check and come back
0
 
LVL 17

Expert Comment

by:MIKE
ID: 17769786
Did you create your prompt using Business View Manager  Create LOV?

MikeV
0
 
LVL 13

Expert Comment

by:crgary_tx
ID: 17769819
The parameters you set are used as the initial values.
Do this:
Login to the Central Management Console
Find the report object of interest and click on it.
Right Beneath the 'properties' tab you will find the 'refresh options' tab
Uncheck Current and Default Parameter Values

Let me how it comes along

Gary
0
How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

 
LVL 100

Expert Comment

by:mlmcc
ID: 17770972
It is possible you need to use Crystal Reports XI Release 2

http://www.businessobjects.com/products/reporting/crystalreports/xi_release_2.asp

mlmcc
0
 
LVL 13

Accepted Solution

by:
crgary_tx earned 500 total points
ID: 17771706
This should work!

--Log in to CMC
--Browse to the folder containing report object and click on it
--Click on process tab
--Click on Parameters
--Click on the value of the parameter
This is gonna take you to the screen where you are asked to enter the initial value for the parameter.
--Here check the check box 'Prompt the user for new value(s) when viewing'
Schedule the report
Now when try viewing the report from the Infoview you will be prompted to enter the parameter

Gary
0
 

Author Comment

by:DataDesignIT
ID: 17773879
I am using XI Version 11.0.0.1282, the issues pertaining to release 2 don't seem to apply to me (at least according to the brief bullet list issued by Business Objects).

I must be missing something that's obvious... but it's still not working. Here's the run-down, just to ensure I'm not missing something with my t's being crossed and my i's being dotted.
- Prompts were created in the report, in the Developer edition. The prompts are the standard {?v_month} variety.
- When I preview the report in the Developer edition, I must enter a value when prompted (as I would expect it to do when launched in InfoView).
- Reports were successfully loaded using the Publisher Wizard.
- From the CMC, I can preview the report, but I am not prompted for {?v_month}. It runs with my default value.
- From the report properties in the CMC, in Properties > Refresh Options, I have the 'Current and Default Parameter Values' checkbox cleared (not checked).
- From the report properties in the CMC, in Process > Parameters, I can see my parameter (v_month) and the default value I assigned it when I created the report in the Developer edition (June).
- From the report properties in the CMC, in Schedule, the report is set to run on demand.
- When I preview the report, using the Preview button in the CMC, it is rightly loaded with my default month of June.


Thank you
0
 

Author Comment

by:DataDesignIT
ID: 17773903
I missed your last post there Gary before posting my lengthy one this AM; I'll test that and let you know.
0
 

Author Comment

by:DataDesignIT
ID: 17774092
Gary-
Works! Thanks for walking me through this!
-Tom
0

Featured Post

How to improve team productivity

Quip adds documents, spreadsheets, and tasklists to your Slack experience
- Elevate ideas to Quip docs
- Share Quip docs in Slack
- Get notified of changes to your docs
- Available on iOS/Android/Desktop/Web
- Online/Offline

Join & Write a Comment

There have always been a lot of questions related to when Crystal Reports evaluates report components (such as formulas, summaries, cross-tabs, charts, to name a few examples). Crystal Reports uses a two-pass reporting process to provide greater …
Hello everyone, Hope you find this as helpful as we did. We have on the company I work for an application built in Delphi V with Crystal Reports 8. We all know that Crystal & Delphi can be temperamental sometimes and the worst thing is, nearly…
This video discusses moving either the default database or any database to a new volume.
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

760 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

23 Experts available now in Live!

Get 1:1 Help Now