Solved

Cannot log on through Terminal Services

Posted on 2006-10-20
13
550 Views
Last Modified: 2008-01-09
I have a new servers, running Windows Server 2003 R2, it is the Domain controller and the Terminal Server.

Terminal services is configured and has 6 CALs.  Users that are members of Domain Users and Remote Desktop Users cannot log on through Terminal Services.  Upon starting an RDP session and entering username/password they get the standard message: "To log on to this remote computer you must be granted the allow log on through terminal services right. By default the remote desktop users group ...".  They are members of this group and still can not log in. I checked the rights of the RDU group and everything looks normal.  In active directory the profile does NOT have the deny login to terminal servers checked.

This was not a problem in Windows Server 2003 SP1 or lesser, where it was possible to right-click My Computer and select the Remote tab and and add Remote Users there.
0
Comment
Question by:Ivertec
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 4
  • 3
13 Comments
 
LVL 8

Expert Comment

by:caddlady
ID: 17773977
What about your Policies for  

Allow logon through Terminal Services

or

Deny logon through Terminal Services
0
 

Author Comment

by:Ivertec
ID: 17774106
Hi caddlady,

Thanks for your quick response.

The Remote Desktop Users group has the permission to Allow log on through Terminal Services in Group Policy in Active Directory and also locally in the Domain Security Policy and the Domain Controller Security Policy.

The Deny log on through terminal services permission is not configured.
0
 
LVL 8

Expert Comment

by:caddlady
ID: 17774137
What about those policies for Group  

try looking at   gpedit.msc   to look at the policies there.
0
Salesforce Made Easy to Use

On-screen guidance at the moment of need enables you & your employees to focus on the core, you can now boost your adoption rates swiftly and simply with one easy tool.

 

Author Comment

by:Ivertec
ID: 17774212
Just checked that out.

RDU group are in the "Allow log on locally" and "Allow log on through Terminal Services" policies.

"Deny log on locally" and "Deny log on through Terminal Services" contain no user or group.

I am beginning to think that this issue may be peculiar to W2k3 R2.
0
 
LVL 5

Expert Comment

by:modathir
ID: 17774241
Hi,
As caddlady said check local policy on TS
On the Terminal Server start > run> type gpedit.msc enter >Local policy> User Rihgts Assignment > Allow logon through Terminal Services
Make sure that Remote Desktop Users are added

Thanks
Mo
0
 

Author Comment

by:Ivertec
ID: 17774351
Hi Mo,

Yeah, Remote Desktop Users group have been added and still no luck.

Jim
0
 
LVL 5

Expert Comment

by:modathir
ID: 17774414
Ok try to add there the users by name add one user for test & go to command line type gpupdate & try to logon to terminal server as that user.
0
 

Author Comment

by:Ivertec
ID: 17774471
Thanks Mo,

I have added the user, ran GPUPDATE /FORCE and still cannot log on to the Terminal Server.

Jim
0
 
LVL 5

Expert Comment

by:modathir
ID: 17774611
In Active Directory Users & Computers right click on one of the users that you added last time & go properties > Dail-in tab > remote access permissions (Dail-in or VPN) make sure is Allow access.

Thanks
0
 

Author Comment

by:Ivertec
ID: 17774788
Allow Access is checked in Properties>Dial-In tab.

I have gone over all the steps again and the user is still unable to log on through TS.

At this stage I'm convinced that the issue is specific to R2 and am thinking about implementing a separate box running W2k3 SP1 for Terminal Server. However, my client may not agree to that due to the extra licence involved, and to be honest, he would be right.
0
 
LVL 8

Accepted Solution

by:
caddlady earned 500 total points
ID: 17775058
The only policy above those is OU (organizational unit)  - do you have an GPOs linked to an OU?
0
 

Author Comment

by:Ivertec
ID: 17803450
Thanks caddlady.

I haven't had time to post until now; sorry for the delay.
0
 
LVL 8

Expert Comment

by:caddlady
ID: 17805244
Did you find the error?
0

Featured Post

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

I guess it is not common knowledge to most Wintel engineers/administrators: If you have an SNMP-based monitoring system in your environment (and it's common to have SNMP or Syslog) it's reasonably easy to enable monitoring of the Windows Event logs,…
Recently, I had the need to build a standalone system to run a point-of-sale system. I’m running this on a low-voltage Atom processor, so I wanted a light-weight operating system, but still needed Windows. I chose to use Microsoft Windows Server 200…
How to Install VMware Tools in Red Hat Enterprise Linux 6.4 (RHEL 6.4) Step-by-Step Tutorial
Attackers love to prey on accounts that have privileges. Reducing privileged accounts and protecting privileged accounts therefore is paramount. Users, groups, and service accounts need to be protected to help protect the entire Active Directory …

738 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question