[Last Call] Learn about multicloud storage options and how to improve your company's cloud strategy. Register Now

x
?
Solved

IIS httpcfg

Posted on 2006-10-20
6
Medium Priority
?
1,747 Views
Last Modified: 2010-05-18
Trying to use multiple services that both use TCP 80 and 443 - but on two different IP addresses.  

One is IIS6.

I thought this would be a simple command to stop IIS from listening on all IPs (0.0.0.0:80 & 443) to just the single public address.
httpcfg set iplisten –I xxx.xxx.x.x:y

Tried that and although IIS would start, none of the sites were able to start.  

What am I missing?





0
Comment
Question by:gatorIT
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
6 Comments
 
LVL 29

Expert Comment

by:Nightman
ID: 17774602
You can configure IIS to listen on only one IP address (in fact, you can even do this per web site). Select the web site, properties, on the first tab change IP Address from 'All unassigned' to the IP address you want (and as I said, you can actually do this per site).

For port 443 on that IP, ensure that no other services are using it.
0
 

Author Comment

by:gatorIT
ID: 17774744
I'm sorry I failed to mention that I have triple checked that there are no sites (including all host headers and SSL) set to 'All Unassigned'.

When I added the appropriate entries with httpcfg, IIS would start but none of the sites would go to Running status.

Actually I just realized what the problem was....

I added an IP address with httpcfg that isn't bound to any interfaces.  I have several IPs, most of which are on the same subnet, but a couple are not, so in haste I added all IPs via httpcfg on the same subnet.

The following event was thrown:
"Unable to bind to the underlying transport for xxx.xxx.xxx.xxx:80. The IP Listen-Only list may contain a reference to an interface which may not exist on this machine.  The data field contains the error number."



0
 
LVL 29

Expert Comment

by:Nightman
ID: 17774762
Ahh - error logs are a wonderful thing ;)
0
 

Author Comment

by:gatorIT
ID: 17777909
Actually, the problem ended up being that it didn't like specifying the ports in the httpcfg command.

httpcfg set iplisten -i xxx.xxx.xxx.xxx
(without :y where y is the port)

Works just fine.



0
 
LVL 1

Accepted Solution

by:
Computer101 earned 0 total points
ID: 17991807
PAQed with points refunded (125)

Computer101
EE Admin
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Debug Tools to analyse IIS process: This article focus on taking memory dumps from IIS to determine which code is taking more time and to analyse which calls hangs/causes more CPU usage. To take dumps,download the following. Install1: To st…
When it comes to showing a 404 error page to your visitors, you do not want that generic page to show, and you especially do not want your hosting provider’s ad error page to show either. In this article, I will show you how to enable the custom 40…
Video by: ITPro.TV
In this episode Don builds upon the troubleshooting techniques by demonstrating how to properly monitor a vSphere deployment to detect problems before they occur. He begins the show using tools found within the vSphere suite as ends the show demonst…
In this video you will find out how to export Office 365 mailboxes using the built in eDiscovery tool. Bear in mind that although this method might be useful in some cases, using PST files as Office 365 backup is troublesome in a long run (more on t…

656 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question