Solved

Remote Desktop Setup not working out...

Posted on 2006-10-20
8
241 Views
Last Modified: 2013-11-21
Hey,

I am trying to set up my home machine to have remote desktop.. I used to do it all the time, but that is awhile ago... and I can't remember if I am doing it wrong or right....

Host
OS: WinXP Professional
Remote Desktop is set as allowed on the host ("allow users to connect remotely" is checked)
on the router I forward the port 3389 to the host machines ip address (ie 192.168.1.109)
Got my real ip by looking at router settings and verifying with "Whatismyip.com"

Client
OS: WinXP Home
Start -> accessories ->communication -> Remote Desktop
enter in username: (the real ip)

connect....
that should do it.. but it doesnt...

I tested it internally by using the computers name..and that works...
0
Comment
Question by:Pharcyde616
  • 3
  • 2
8 Comments
 
LVL 27

Expert Comment

by:David-Howard
Comment Utility
This is the setup procedure for Remote Desktop (WinXP Pro)
http://www.microsoft.com/windowsxp/using/mobility/getstarted/remoteintro.mspx
This is the setup procedure for Remote Assistance (XP Home)
http://www.microsoft.com/windowsxp/using/helpandsupport/learnmore/remoteassist/intro.mspx
:-)
David
0
 
LVL 27

Expert Comment

by:David-Howard
Comment Utility
Your client OS is XP Home. I believe that Remote Desktop only works with Pro.
You may have to use Remote Desktop. David
0
 
LVL 27

Expert Comment

by:David-Howard
Comment Utility
Just found this link. It's looking like you will need to run the Remote Assistance.
"To use Remote Desktop, you need the following:
Windows XP Professional installed on your office computer, or whichever computer you plan to operate remotely."
http://www.windowsnetworking.com/articles_tutorials/Using-Remote-Desktop-Windows-XP-Pro.html
0
Backup Your Microsoft Windows Server®

Backup all your Microsoft Windows Server – on-premises, in remote locations, in private and hybrid clouds. Your entire Windows Server will be backed up in one easy step with patented, block-level disk imaging. We achieve RTOs (recovery time objectives) as low as 15 seconds.

 
LVL 77

Accepted Solution

by:
Rob Williams earned 125 total points
Comment Utility
A couple of things, looks like you have done everything correctly.
-check the windows firewall. By default when you enable remote desktop it creates an exception for remote desktop, but usually just for local LAN users. To change/check go to control panel | windows firewall | exceptions | verify remote desktop is present and checked | highlight remote desktop and chose edit | highlight tcp 3389 and choose change scope | verify "any computer (including those on the Internet )" is checked
-verify there are no other NAT (Network Address Translation) devices between you and the Internet by connecting to   http://www.canyou seeme.org   from the host computer. Test for port 3389. If time out, or error, you may have a modem that needs port forwarding as well.
-verify the terminal Services service is running
If you have access to the remote machine make sure it is "listening" for your connection. To do so at a command line enter (substitute port # if not using default 3389):
  netstat  -an  |find  "3389"
You should get the following result:
TCP   0.0.0.0:3389    0.0.0.0:0    listening
If not go to Start  | Run | services.msc and see if Terminal Services is started and set to automatic
-you must be a member of the remote desktop users group (administrators are by default)
-the host machine must be XPpro, which you say it is but it doesn't mater for the client machine.
0
 
LVL 77

Expert Comment

by:Rob Williams
Comment Utility
Sorry link above is broken up:
http://www.canyouseeme.org
0
 
LVL 8

Assisted Solution

by:nitadmin
nitadmin earned 125 total points
Comment Utility
Its possible your ISP is blocking you from connecting remotely.
Also are you sure your public ip address is static.
Most high speed ISP (dsl and cable carriers) provide dynamic ip addresses to residential customers.
The only exception to this fact, is Cablevision, which also provides dynamic ip addresses. But  cablevision DHCP servers do not change the dynamic ip address given to your router/computer unless the MAC address of the router/computer changes. In effect, you get static ip address from cablevision.

When you check you public ip address using whatismyip.com website.
Does your public ip address change from day to day?

Also, I would check you PC ip addresses and verify that your port forwarding
on your router is forwarding port 3389 to correct private ip address.

Another thing I would check is the Windows Firewall and other Firewall software installed on your PC.

Cheers,
NITADMIN
0

Featured Post

How to improve team productivity

Quip adds documents, spreadsheets, and tasklists to your Slack experience
- Elevate ideas to Quip docs
- Share Quip docs in Slack
- Get notified of changes to your docs
- Available on iOS/Android/Desktop/Web
- Online/Offline

Join & Write a Comment

Resolve DNS query failed errors for Exchange
When it comes to security, there are always trade-offs between security and convenience/ease of administration. This article examines some of the main pros and cons of using key authentication vs password authentication for hosting an SFTP server.
Viewers will learn how to connect to a wireless network using the network security key. They will also learn how to access the IP address and DNS server for connections that must be done manually. After setting up a router, find the network security…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

771 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now