Go Premium for a chance to win a PS4. Enter to Win

x
?
Solved

Monitor loses power after screen saver is invoked ..

Posted on 2006-10-20
37
Medium Priority
?
550 Views
Last Modified: 2013-11-08
I think this is whats happening:

I recently installed a new graphics card - ATI Radeon 9550 - and I have it displaying everything ok, except when the screen saver comes on, the monitor light goes to amber and then I cannot get it to come on again with a mouse move? I have to reset my machine completely!

Any ideas ?
0
Comment
Question by:Eternal_Student
  • 20
  • 6
  • 4
  • +4
37 Comments
 
LVL 18

Author Comment

by:Eternal_Student
ID: 17777841
Also when I tried to run Unreal Tournament, the same thing happens.

Could my old graphic card drivers be interfering ? I had a Nvidia Geforce 4, but the fan died on it, so I got this new card.
0
 
LVL 27

Expert Comment

by:David-Howard
ID: 17777844
Check the Power settings the Screen Saver section.
Make sure that Hibernate is not enabled.
0
 
LVL 27

Assisted Solution

by:David-Howard
David-Howard earned 80 total points
ID: 17777851
That update does seem point towards a graphic issue. Make sure that you have the updated and correct drivers for your card and OS.
:-)
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 6

Accepted Solution

by:
austinstace earned 400 total points
ID: 17777897
There are quite a few places that could be causing the symptoms you are experiencing. If you are using your screen saver for security reasons (i.e. password required on resume) then you need to troubleshoot further. If you are just using it to save your screen, disable the screen saver. the monitor going into standby mode will do that for you.

If you can provide more info about your computer (make/model) your monitor (make/model), and operating system, I can help you make sure that you don't have conflicting settings in your BIOS vs Operating system. Also, if this is not a screensaver that shipped with your OS, it could be a problem with that specific screen saver.
0
 
LVL 6

Expert Comment

by:austinstace
ID: 17777903
You should always remove your old video drivers when installing a new card. You can find some instructions to make sure you get all of the NVidia out on this page http://www.overclock.net/faqs/12466-info-nvidia-driver-cleaning-guide.html
0
 
LVL 18

Author Comment

by:Eternal_Student
ID: 17779327
@ David

Here are the power options I have set up:

Turn off monitor: After 1 hour

Hybernate is not enabled

Im not sure where to get the latest drivers from?

Here is info on the current graphic card drivers I have:

Date: 21/03/2006
Version: 8.241.0.0
0
 
LVL 18

Author Comment

by:Eternal_Student
ID: 17779353
@ austinspace:

I am running:

AMD Athlon XP 2500 Processor with heatsink and fan, KM400 Socket A Motherboard
1GB PC32000 RAM

I am running Windows XP and my monitor is GNR VL997 - display - CRT.

Do you need any more info?

As for my screensaver, it is just a standard windows one. [3D flower box, to be precise]. Also this is occuring when I try and run unreal tournament, so when ever my video card is being tested, I guess?

My nvidia card does not appear in "device manager" BUT I get two entries under "display adapters":

CONNECT 3D RADEON 9550
CONNECT 3D RADEON 9550 Secondary

Is that ^ correct ?

Also under "Otherdevices" I have a fat yellow question mark for the following:

VID_04E6 PID_80000040

I believe that is my onboard graphics, which, I was using for a couple of weeks. Is anything wrong there?

Cheers,




0
 
LVL 32

Assisted Solution

by:willcomp
willcomp earned 400 total points
ID: 17781353
Disable on-board video in BIOS Setup.  If you need to re-enable it, clearing CMOS will do the trick (restore to defaults).

Remove nVidia drivers.

Install updated ATI drivers.  Link below:

https://support.ati.com/ics/support/default.asp?deptID=894&task=knowledge&folderID=27

Post back with results.
0
 
LVL 18

Author Comment

by:Eternal_Student
ID: 17784336
Hi Will,

I am not sure how to disable on-board video in the bios?

I have installed the latest drivers and removed the nvidia drivers [as far as I know].

Still no joy though.

I WILL ADD HOWEVER that the reason I changed my graphics card in the first place is because of this:

http://www.experts-exchange.com/Hardware/Q_21992492.html

HELP!
0
 
LVL 18

Author Comment

by:Eternal_Student
ID: 17788483
Anyone around today! lol.
0
 
LVL 18

Author Comment

by:Eternal_Student
ID: 17794096
Also, when I first boot up the computer before windows starts the monitor turns off and the light goes to amber also. If I restart then it is fine.
0
 
LVL 18

Author Comment

by:Eternal_Student
ID: 17796586
Ive increased the points to 500, so hopefully some one can help me out here.
0
 
LVL 32

Assisted Solution

by:Scott C
Scott C earned 400 total points
ID: 17796687
Since the fan died on your nVidea card have you considered purchasing an after market fan and returning the ATI card?

It sounds like a driver conflict.

Also, you may consider going with an older ATI driver.  For my 9800 I can go back a number of versions if I want to.

If you go with the replacement fan you can return your ATI card and get your money back.
0
 
LVL 18

Author Comment

by:Eternal_Student
ID: 17796746
I would rather try and get my ATI card working properly.

So you think it is a driver conflict. How could I resolve this?
0
 
LVL 32

Expert Comment

by:Scott C
ID: 17796803
I would go to Add/Remove Programs and make sure both drivers have been unistalled.

I would then go to Divice manager and uninstall the ATI card from the Video Adapter section.

Also you may want to run a program to clean up any unwanted junk left over in the registry.

Something like this:  http://www.pctools.com/registry-mechanic/

And as a final make sure to remove all folders that have to do with ATI and nVidea.

Reboot.

Then install the latest ATI driver.

Hopefully that will remove anything left over causing a problem.

Let me know how it goes.

0
 
LVL 18

Author Comment

by:Eternal_Student
ID: 17796831
I will do. Ill try that when I get home.
0
 
LVL 9

Assisted Solution

by:ParadiseITS
ParadiseITS earned 400 total points
ID: 17796988
Eternal -- did you disable the onboard video?  To do this, when you turn your PC on you will need to enter setup.. ususally F2, F10 or DEL key... you'll see it quickly during POST.  Then, scroll through your BIOS until you find the power saving/energy star features.  I would turn them ALL off.

This is dfinitely a driver issue as a couple of people have speculated.  Next, boot to Windows, disable ALL power saving features in Windows.  Make sure you have removed all video drivers except the one for your new ATI card.  Downlaod the latest drivers from ATI and install them then test Unreal -- also, doesn't Unreal need to have the graphics reinitialized if you change video cards?
0
 
LVL 18

Author Comment

by:Eternal_Student
ID: 17798062
ok when I go into the bios all I get it power management options and I cannot see specifically what I am looking for?
0
 
LVL 32

Expert Comment

by:Scott C
ID: 17798084
Something like "Integrated Devices or Perihpials" Onboard video.  Enable/Disable.
0
 
LVL 9

Expert Comment

by:ParadiseITS
ID: 17798860
Yes, you can turn it off, it will be in something like ScottCha said... it is possible -- depending on your machine -- that you can't do it... but not likely.
0
 
LVL 18

Author Comment

by:Eternal_Student
ID: 17799063
ok, guys, I go to :

Integrated Peripherals

And I get:

VIA OnChip IDE Devices
VIA OnChip PCI Devices
Super IO Device
Init display first [PCI slot]

I cannot find onboard graphics in any of them there. Which one should it be in? I can see onboard audio and Lan but not graphics.

I have tried uninstalling and removing all ATI and Nvidia evidence and removing the ATI from the device manager, then the computer boots up and tries to install the onboard graphics or the Radeon card. When I quit windows from doing it automatically and use the latest drivers from ATI the exact same scenrio confronts me!

I am about to try again.
 
0
 
LVL 32

Expert Comment

by:Scott C
ID: 17799081
It might be the "Init display first" option...

Make sure it's looking at the slot that your ATI card is in.
0
 
LVL 18

Author Comment

by:Eternal_Student
ID: 17802366
I changed that to AGP and you know what ... I think all is well !

I am going to test again when I get home and then probably awards the points tomorrow.

Thanks guys !
0
 
LVL 18

Author Comment

by:Eternal_Student
ID: 17805715
ok, here is the latest:

- My computer now displays everything correctly
- I can play unreal tournament and the graphics are good
- My display is OK on first boot up [before the monitor was on amber]
- My screensaver PREVIEW works fine

BUT

- After a while of in-activity the monitor loses its power and I cannot activate the monitor by moving the mouse. The only way is to restart the machine!
0
 
LVL 18

Author Comment

by:Eternal_Student
ID: 17815270
Anyone have anymore suggestions, I think I have tried just about everything!
0
 
LVL 32

Expert Comment

by:willcomp
ID: 17815333
Check power saving setup (Screen Saver Seup Page) and Power Saving settings in BIOS.  You can simply disable power saving in XP to prevent monitor from blanking.  The most lokely culprit is either turning off hard disks or entering standby.  Try disabling those two first.  To help any further, will need to know all power saving settings.
0
 
LVL 18

Author Comment

by:Eternal_Student
ID: 17815594
control panel > power options:

Power schemes: always on;
Turn off monitor: Never;
Turn off harddisks: never;
System standby: never;

I will now check the bios settings ...
0
 
LVL 18

Author Comment

by:Eternal_Student
ID: 17815647
There were quite a few settings but here are the ones that may be of relevance:

HDD Power Down - [disabled]
Suspend Mode - [disabled]
Video off option - [suspend -> off]
video off method - [V/H sync + black]

Should I mess with any of them ?
0
 
LVL 32

Expert Comment

by:willcomp
ID: 17815691
No.  Not necessary.

It's not unusual for a PC to refuse to wake from standby (sleep) mode and I suspect that may have been your latest problem.  In that case, screen would be blank and HDD powered down.
0
 
LVL 18

Author Comment

by:Eternal_Student
ID: 17817759
So how would I fix this problem?
0
 
LVL 32

Expert Comment

by:willcomp
ID: 17819940
Disable standby.
0
 
LVL 18

Author Comment

by:Eternal_Student
ID: 17820790
In my control panel ? It is already set to System standby: never;

Is that what you were refering to or is there something else I need to do?

thanks.
0
 
LVL 32

Expert Comment

by:willcomp
ID: 17820828
That's it.  Should now be OK.
0
 
LVL 18

Author Comment

by:Eternal_Student
ID: 17821840
Ummm, I had it set like that already and it hasnt made a difference. The monitor goes on standby when the screen saver kicks in and then doesnt turn back. At the minute I am turning my screen saver off, which isnt the end of the world!
0
 
LVL 32

Expert Comment

by:willcomp
ID: 17822074
Screen Saver may be faulty or corrupt.  Bottom line is to just disable whatever is creating the problem.
0
 
LVL 18

Author Comment

by:Eternal_Student
ID: 17852293
OK, I have disabled my screen saver and once windows has loaded all is well, no problems.

The problem arises when I first start windows up and the monitor power goes amber and I have to do a hard reset. This is happening all the time when I first boot up now.
0
 

Assisted Solution

by:Canabian
Canabian earned 320 total points
ID: 17869596
In your BIOS, try changing your video off method to DPMS or just 'blank'. Then change the Video off option to 'Always On'.

Oh, and this:

VID_04E6 PID_80000040

is probably a HP scanner or printer\scanner, you can just download the driver from HP and that should fix the warning.
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Stuck in voice control mode on your Amazon Firestick?  Here is how to turn it off!!!
This article shows how to use a free utility called 'Parkdale' to easily test the performance and benchmark any Hard Drive(s) installed in your computer. We also look at RAM Disks and their speed comparisons.
Loops Section Overview
Screencast - Getting to Know the Pipeline

971 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question